Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Error 1806 on only one PC

Error 1806 on only one PC

Error 1806 on only one PC

I'm having a problem that only occurs on one particular PC with one particular VFP 9 SP1 application.  This application runs fine from several other PCs.  (And this PC can run several other VFP applications without errors.) The exe file is run from a Novell network drive and the operating system on the PC is Windows 2000.

The error message that appears as the data entry form is loaded (during the OpenTables method of the data environment) is Error number 1806, (SQL: Column "field | variable" is not found) but a specific column name is not listed.  Instead, the error message reads 'SQL: Column " is not found.'  Several errors appear after that (if you select Ignore rather than Cancel) including 'Alias " is not found' but, like the other error, the table name is not listed.

In this application on this particular PC, the report form loads okay and is able to access the tables and generate reports.

This particular PC was recently set up using an image that has been used for other PCs that are able to run this application successfully.  It is possible, however, that something could have changed after the image was loaded.

Does anyone have any ideas as to what particular workstation configuration settings could cause this to happen?


RE: Error 1806 on only one PC

If anyone is interested, I did find a solution.  I discovered that in fact this particular PC had been changed after the image was loaded.  A VFP application from an outside source had been installed and its config.fpw was messing up my application. I have never used config.fpw files, but all I had to do was put an empty config.fpw file in the same directory as my exe, and problem solved.


RE: Error 1806 on only one PC


I have never used config.fpw files, but all I had to do was put an empty config.fpw file in the same directory as my exe, and problem solved.
You could avoid future problems by adding that blank config.fpw to the project and building it into the executable. At runtime the exe will find that it's got its own config and not go looking for another.

Geoff Franklin

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close