×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

I am getting an error "Error communicating with connection process..."

I am getting an error "Error communicating with connection process..."

I am getting an error "Error communicating with connection process..."

(OP)
I am keep getting the following error on the I server. We are running the adhoc query reports on I Server through web during day time. And there are quite a bunch of services which runs during night time from Narrowcast that access the reports on I Server.

Following is the error message.

"QueryEngine encountered error: Unknown failed. Unable to connect. Error type: System call error. Error communicating with connection process. Process hung."

Has anybody encountered this error messages earlier and what was the remedy for this problem.

RE: I am getting an error "Error communicating with connection process..."



Your issue sounds more related to the MCM (Memory contract management) issue. You get this due to various reasons. Some of the common reasons are

if the report result set is very large and when the I-server does not release the memory for this large report.

If your cache size limit is small.
If your I-Server is not configured with the recommended hardware and software.
If your I-server restarts automatically again due to other reasons.

Quick workaround:
     Restart your I-server to get immediate fix. Have a maintenance window for the I server to be restarted frequently.

Permanent workaround:
    Check the settings on the I server and the project configuration.
    Contact MSTR tech support to update this and get a resolution answer through hotfix or updates.

  teccum

RE: I am getting an error "Error communicating with connection process..."

(OP)
Thanks teccum for you reply.

We figured out what was the problem. In the ODBC connection, the IP addresses that was included for the Teradata server was incorrect. In the sense that, four nodes of the Teradata server were down. On Teradata server we have hosted our dwh. There are about 16 IP addresses (nodes) defined in the ODBC connection. The Microstrategy application was trying to reach the 4 nodes out of 16 nodes which are down, for authentication but it was failing. This is the reason we were getting the "...Process hung..." error.

After the change made to the ODBC by removing those 4 nodes, we are able eliminate the above problem. The 4 nodes will be up after the new year.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close