×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Facing problems in OLAP Services

Facing problems in OLAP Services

Facing problems in OLAP Services

(OP)
Hi there!

Let me describe the problem i am facing in detail.


TOOL : SQl Server 7.0 OLAP Services

DIMESNSIONS : Year
Segments
Customers - Branches (One Branch can have more than one Customers)
Account Type
AMR Codes
Products

MEASURES : Balance Amount



- I have 7 master tables (i.e: Year, Segments, Customers, Branches, Account Type, ARM Codes & Products).

- There is one fact table with following fields : Year, Segment Code, Customer Code,
            Branch Code, Account Type, ARM Code, Product Code, Balance Amount.

- I built 6 dimensions; 5 built directly on each one of the 5 master tables.
      The sixth dimension is Customers which has Branch and then customers (at one level lower than Branch).

- I then went on to create a cube that linked each of the dimensions to their respective fields in the fact table.

- After the cube was complete, i saved it and selected the VIEW and DATA options from the menu in the Cube editor (ie : <View> <Data>).

- This is where the PROBLEM started. When i see the measure value against any of the dimensions, i see the same Balance amounts for all the
members of the dimension i.e: If see a balance amount of 25000, i see 25000 against all the members of the selected dimension.
If i view the data with respect to another dimension, i see 145.67 for all the members of this selected dimension.

- I am sure that the data that is stored in SQl server 7 database is not being shown correctly from the cube.

- Please note that the cube is still unprocessed and when i selected the <View> <Data> option from the menu, it says 'Cube not processed! Showing sample data'
before showing me the data. Am i having this problem because i have not yet processed the cube yet?


PROBLEM - 2
-----------

- The reason i was talking about un-processed cube in the previous problem was that i was not able to process the
cube. Whenever i tried to process the cube, it tried to process the first dimension doing which, it would fail and come
up with an ERROR message that says
'ODBC error: Client unable to establish connection;08001;[DBNMPNTW]ConnectionOpen (CreateFile()).;01000; Time:5/27/00 9:17:00 AM'

- I am not sure why it is not able to connect to the SQl Server. My Data source uses login 'sa' and the password is correct.
I even pressed the 'Test Connection' button and it could connect successfully.

- Could you help?

Thanks a lot. I appreciate the time you took to read my problems. Could you please send me a reply on my e-mail address as well? Its

Harpreet.Singh@ae.standardchartered.com

[Harpreet Singh]

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close