×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Cannot register MSFLXGRD.OCX with Regsvr32

Cannot register MSFLXGRD.OCX with Regsvr32

Cannot register MSFLXGRD.OCX with Regsvr32

(OP)
I'm trying to deploy a third-party VB application on a Win2k SP4 machine. The application runs until a certain point at which it falls over with : "run-time error 339: Component 'MSFLXGRD.OCX' or one of its dependencies is not correctly registered: a file is missing or invalid'

So I search for MSFLXGRD.OCX on my machine and it's not there. I download it. I try to register it with regsvr32 and get the message : "MSFLXGRD.OCX" is not an executable file and no registration helper is registered for this file type.

As a last resort I thought I'd try registering the file with MS Access, using the ActiveX controls register. The error message this time is : C:\WINNT\system32\Msflxgrd.ocx cannot be added. Either it is not an OLE control or it requires a separate setup utility.

Any help anyone can offer or any light anyone can shed on this would be much appreciated. Thanks in advance.

RE: Cannot register MSFLXGRD.OCX with Regsvr32

There are three parts to the msflxgrd.ocx

msflxgrd.dep
msflxgrd.oca
msflxgrd.ocx

I would start by copying all three files to the system32 folder and then at the command prompt type

regsvr32 msflxgrd.ocx and see if it registers then.

Andy Baldwin

"Testing is the most overlooked programming language on the books!"

Ask a great question, get a great answer. Ask a vague question, get a vague answer.
Find out how to get great answers FAQ219-2884.

RE: Cannot register MSFLXGRD.OCX with Regsvr32

(OP)
Thanks for your reply, Andy.

However, I obtained a new copy of msflxgrd.ocx and copied this to WINNT\System32 and this solved the problem.

I don't have either of the .dep or .oca files present. I assumed my initial problem was a corrupt or damaged msflxgrd.ocx which is why the new version has solved it. Mysterious - but at least my problem is fixed!

Many thanks.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close