×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

SYSTEM command wait

SYSTEM command wait

SYSTEM command wait

(OP)
Using WebFocus, how can I ensure when calling a DOS command via the SYSTEM command, that sufficient time is allowed for the operation is complete? Is there some way to "pause" the fex until the DOS command has completed?
I'm having occasional problems when the DOS command takes more than 5 or 6 seconds in that a messaage appears saying "There is no response. Do you want to keep waiting?"
This is flagged as a "Focus Message" but I'm not sure whether it's being issued by DOS, Windows (2000) or WebFocus. Many Thanks, Peter.

RE: SYSTEM command wait

One of the advantages to using the SYSTEM subroutine, rather than a straight DOS call, is that the SYSTEM subroutine WAITS until the called routine finishes.

I can't find any timer, or indication that WebFOCUS produces this message. If you issue this command from a DOS box, outside of WebFOCUS, does the message appear? When I tried to repro this situation from within WebFOCUS, calling a BAT file with a PAUSE command, it just sat there, no message.

Also, WHAT DOS command(s) were you trying to execute?

RE: SYSTEM command wait

have you tried SLEEP 10
which holds focus for 10 seconds
On my windowsserver, i use the CMS syntax instead of the word DOS
CMD COPY someting to somewhere
and i've never had a problem
even tho some of these commands can take a good 10 minutes.

-SUSANNAH

RE: SYSTEM command wait

(OP)
Hi SUSANNAH,

I, too, was a former occupant of the Focus CMS environment. Things were so much simpler there!

Anyway, the SLEEP command does work in WebFocus - but only after the DOS copy command has finished - so it does not really help. I also tried the CMD copy command, as you suggested but to no avail. I have no way of attaching an image file here but if I could, you would see from the the actual copy attempt and the resulting "Focus" error message.

Peter.

[img c:\focus.gif]

Quae vita est cui orbatus est vino?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close