×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

CLS database

CLS database

CLS database

(OP)
I have a nortel switch and an old CLS server running ver4.23. I am trying to insert the inbound phone number into the database. Right now all calls with the direction IN has the phone number field blank. Any idea what needs to be changed for the CLS to reconize the inbound phone number.

RE: CLS database

Does the trunk you used support Caller ID function?

RE: CLS database

(OP)
Yes it does, I can pull the call records from the switch and it shows all the inbound calls. When you look in CLS callsrvr the field is blank.

RE: CLS database

Have you checked that cti is sending ANI. Can't remember much about 4.23 but can you look in the switch driver window on the cls and see the incoming cti events and if so is ANI present.

When I was born I was so suprised I didn't talk for 18 months

RE: CLS database

(OP)
I have Dispatch which starts the services, statsrvr which shows all the services are running correctly, dbsrvr which shows what table in SQL the call records are being placed.

Call Server which shows the details of the call in which I do not see ANI, channel server gives ststus of the loggers and recordings. then BT_NT which is the switch driver port which always shows (fail to translate terminator).

RE: CLS database

call server is the next stage after the switch driver so if you are not seeing it there I'd say that either the switch is not sending ANI or symposium or other cti server is not sending it.

When I was born I was so suprised I didn't talk for 18 months

RE: CLS database

(OP)
I can see the switch shows inbound numbers, I dont think the CLS is looking for it. Do you know how to add ANI to CTI?

RE: CLS database

The pabx may be showing ANI but whether it is sending it via cti ia another thing. The switch driver uses a parsing file to interpret the cti information it receives (a different file for each switch type) by default it will look for every field possible but whether it inserts this into the database is down to the columns or indexes configured in server manager (server controller > database menu > customise columns). If the calling number field is available but empty in query app then it is looking for it but is not receiving it from the pabx.

When I was born I was so suprised I didn't talk for 18 months

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close