×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

The Mysterious "Not Supported" error

The Mysterious "Not Supported" error

The Mysterious "Not Supported" error

(OP)
I have the strangest error message.

I brought this report from Crystal 8 that someone else wrote and opened it in Crystal 11.  It wouldn't run and gave me an error message:  "Not Supported"   It stops part-way through data collection and says Not Supported, with one of those irritating [OK] boxes.  

NO OTHER DESCRIPTION OF THE PROBLEM IS PROVIDED.  Also, when I close the report, I get the message Font still in use

(Background info:  Running XP locally, MS 2003 server for the DB operating system, XI Crystal developer edition with MS SQL 2005 database using Microsoft SQL Server ODBC Driver Version 03.85.1117 – Driver.  I had also tried the Microsoft SQL Native Client Version 09.00.2047 driver but that gave the same error.  I am now less inclined to believe this is because it was using native SQL or because it needed ODBC.  It’s now using ODBC and failing; it once used native and failed as well.

I've done a lot of problem solving, and followed some suggestions on the net that I've seen, even though they are limited and not specific to my problem.  In case one is about to suggest these steps here they are... I checked that no fields had spaces in their names from the DB, and there are no UDF's in the select statement.  The entire report uses times new roman font.  From what I can tell I do not have any "WhileReadingRecords" formulas and went through each formula.  I've gone through the suggestions from cr_xi_designer_migration.pdf and xir2_cr_usergde_en.pdf as well.

The following thread experienced the same kind of problem but he hadn't seemed to of obtained a solution:   thread149-1095513

I could really use some help.  Any suggestions?

RE: The Mysterious "Not Supported" error

First, makes sure that the Database->Show SQL Query hasn't been manually edited, and that there aren't any SQL Expressions, either might cause this.

As for the whilereadingrecords formulas, export the report to the report definition format in CR 8, and then you can search the text file for whilereadingrecords, and for % (SQL Expressions).

Obviously you need to also check for subreports as well, sometimes they are shrunk down to a dot so exporting to report definition is very helpful.

I would guess that one of the above is the source of your problem.

-k

RE: The Mysterious "Not Supported" error

(OP)
I didn't know about report definition technique.  That's pretty kewl!  Thanks.  

I think I've eliminated 3 of the potential causes you outlined.
1. I can't find whilereadingrecords.  
2. I can't find any subreports in the report definition.  
3. I can't find any SQL expressions.

The one thing I can't pinpoint is how I would discern if there was a change in the SQL so that it was manually edited.  Obviously I can see it in SHOW SQL in 8 and I can see it in XI and I can tell that in 8 you can edit it and that in XI you can't because they want you to use commands for more specific SQL.  But how can I tell if the person before me edited the SQL?

I might be back to square one unless you know how I can prove one way or another if the SQL was changed.

Thanks for your help,
Keith

RE: The Mysterious "Not Supported" error

Keith,

In my opinion - the "not supported - font still in use" error messages are "kiss of death" messages - in other words - your rpt file has become corrupt.

When this happens to me (and I haven't already saved my work) - it is a case of creating a new report while the error report is still open in the designer - and copying and pasting all the report ojects - record selection formulas - etc - into the new rpt file and saving it.

I never found any rhyme or reason as to why this appears - it has happened numerous times to numerous developers at my work place and what I have outlined is the only workaround I have been able to come up with.

Cheers
paulmarr

RE: The Mysterious "Not Supported" error

If you can open it in CR 8.X, try saving it to CR 7, that used to be a workaround for me.

Otherwise you may be out of luck, as Paul stated.

I;'ve recovered about 50% of the reports with that sort of error, generally by eliminating objects until it played nice, then going back and eliminating the item which resolved.

Just make sure that you make plenty of copies, and as you go along, save every 1/2 hour or so with a different name (ver 2.x, etc.), I always do now.

-k

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close