Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Cannot see newly created table on client

Cannot see newly created table on client

Cannot see newly created table on client

I've created a new table using the create table wizard on the server, and I cannot see the tables on the client's PSQL Control Center. We're using PSQL2000.

I checked the X$File table and I cannot see the new table in there.  

However, I check the dcitionary path of the new table and it is the same as the the rest of the tables in the database.

Doesn't the create table wizard supposed to take care of this? I'm not sure what's going on and how do I resolve this?

Thanks in advance.

RE: Cannot see newly created table on client

What OS is the server?
Any errors or messages?
What happens if you use a CREATE TABLE SQL statement rather than the wizard?

Certified Pervasive Developer
Certified Pervasive Technician

RE: Cannot see newly created table on client

Do you have security enabled on your database?  
Is your client connecting to the server database or a local database?  Use the PSQL monitor on the server to verify the client user is connected to the right database on the server.

Pervasive Software

RE: Cannot see newly created table on client

I tried the create table method and the table info is not written to the X$File table, I'm doing this using the PCC on the server.  OS on server is Windows.

I'm assuming the database defined on the client is local because I see the name of the database under the client's engine in the PCC?  However, the DDF Files and the Data Files are pointed to the server.

If I use Register New Engine on the abovementioned server, I do not see any of the databases that are specified on that server, although I can see them if I right click on the Configuration and select Maintain named database.

RE: Cannot see newly created table on client

The wierd thing here is that I was able to create a table and it was written to the X$File table a few days ago. Then I set up the client connection to the server and I could not create the tables anymore to bind to the X$Files table.

I tried to create table for databases not connected by the client and those tables bind to their respective X$File tables properly.

RE: Cannot see newly created table on client

Another thing is that I created triggers for the problem database and a new X$Trigger table was created with the correct entries.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close