×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

"Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

"Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

"Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

(OP)
Hello,

I have created a simple web application with a security-constraint at the web.xml.
When I put <transport-guarantee>NONE</transport-guarantee> everything is working well but when I put CONFIDENTIAL or INTEGRAL I receive "Page cannot be displayed" when requesting the application. I am using Tomcat 5 and as far as I know at this case Tomcat should automatically transfer the request to the HTTPS port. Any advice?

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

Do you have an HTTP over SSL (ie HTTPS) listening ? !'m willing to bet not ...

--------------------------------------------------
Free Java/J2EE Database Connection Pooling Software
http://www.primrose.org.uk

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

(OP)
Hello sedj,

How can I check it?

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

Look in your Tomcat server.xml file ?

Or run netstat on your machine to assess the open ports.

Or telnet to port 443 or port 8443 (usual HTTPS ports)

Or ....

--------------------------------------------------
Free Java/J2EE Database Connection Pooling Software
http://www.primrose.org.uk

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

(OP)
10X I am not by the machine now but I will check it and let you know. One question though: everything is running on my local machine, I don't have firewall or other software that is blocking ports, so how can it be that they are not open?

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

Its not that the port is being blocked by a firewall - I suspect that you have not configured Tomcat to listen on the HTTPS port - its not default behaviour to do so - you have to configure it specially (and its not that easy either !)

--------------------------------------------------
Free Java/J2EE Database Connection Pooling Software
http://www.primrose.org.uk

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

(OP)
Well 10X I assume this is the problem than since I didn't change the default behaviour.
Since you say it's not that easy (and I beleive you), do you happen to have a referance document for such configuration?

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

One of my colleagues did it a while back ... I'll dig out his notes on how to do it when I'm back at work tomorrow.

--------------------------------------------------
Free Java/J2EE Database Connection Pooling Software
http://www.primrose.org.uk

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

(OP)
10X for thehelp sedj.
BTW, I thought that since using HTTPS is very common Web containers such as Tomcat are giving it out of the box...

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

Most people front Tomcat with the Apache HTTP server - which handles the HTTP/HTTPS protocol slice ... plus IMO Tomcat is not a *great* product. Servers such as Jetty IMO are a lot better, but thats just my opinion.

--------------------------------------------------
Free Java/J2EE Database Connection Pooling Software
http://www.primrose.org.uk

RE: "Page cannot be displayed" when using CONFIDENTIAL or INTEGRAL

(OP)
And if I'll do that (front Tomcat with the Apache HTTP server) I will have HTTPS out of the box? Can you please direct me to the Apache HTTP server? And by the way, which one are you using?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close