×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Can't access stored procedures

Can't access stored procedures

Can't access stored procedures

(OP)
Hi everyone,

let me start by saying that I am totally new to Pervasive (I am working on the version 8). I need to take some data out of Pervasive to use it in some Sql Server Stored Procedures.

I have created some Stored Procedures in Pervasive to facilitate my work and they worked just fine.

Unfortunately, I had to do some operations in the software that uses Pervasive and my stored procedures are no longer accessible. I can see them through the Pervasive Control Center (as icons), but when I click on them I get the following message:

[Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface]Unable to open table: X$Proc.

I looked through the various tables and I find out that I have to insert a record in the table X$File as to make the X$Proc table come back into the database.

Unfortunately, though, I cannot inser records in the X$File table by using the INSERT INTO sql statement.

My question to you experts is the following: how can I insert a new record into the X$File table? Or is there another way to make the X$Proc table come back into the database?

If I call the stored procedures through the CALL sql statement, they return the correct data, so I assume their sql must be stored somewhere. It must still be there.

Thanks for your help.

RE: Can't access stored procedures

Sounds like your DDFs were replaced at one point.  To make the X$PROC entry come back, you'll need to:
1.  Temporarily rename PROC.DDF to PROC.OLD
2. Create a stored procedure (doesn't matter what it's called or what it does).
3. close the PCC (and any applications using the DDFs.
4. delete the new PROC.DDF (it's created in step 2).
5. rename PROC.OLD back to PROC.DDF.  
THe Procedures should be available at that point.

Mirtheil
Certified Pervasive Developer
Certified Pervasive Technician
http://www.mirtheil.com

RE: Can't access stored procedures

(OP)
Mirtheil,

just tried your solution and it worked!

Thank you SO MUCH!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close