Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Wireless Network Not Showing Up?

Wireless Network Not Showing Up?

Wireless Network Not Showing Up?

Hi All,

I was running D-link DI-624 wireless router.  My desktop was connected to the net no problem (For years) using a D-Link AirPlus Extreme G DWL-G520 Adapter.  My work laptop was able to connect as well.  I had WEP enabled.

Now, I've upgraded to the Dlink DI-634M so that my kids computers upstairs and at the other end of the house could get a better signal (supposedly).

Anyway, w/o WEP enabled, my laptop and desktop can connect no problem.  However, even though my desktop can connect, if I try to view available networks...nothing shows up.  The advanced button is not even enabled.  The only option is the cancel button.

When I enable the WEP, I can find my network in the available networks and connect to it no problem with my laptop.  However, my desktop now will not connect.  And, again there is no available networks to find even though I'm broadcasting my networks name.  The advanced button isn't enabled either so I can't even type in the network name.

Why would I not be able to see or do anything at all except canel, when I look at the 'available networks' on my desktop which is running win xp pro sp1???


RE: Wireless Network Not Showing Up?


P.S.  The "Wireless Networks" tab is completly missing from my desktop 'Wireless Network Connection Properties' window when I right click on the wireless tray icon.  I was there with the previous router...but not this one?!?!?! And as mentioned, if WEP is not enabled...I can connect with the desktop.

RE: Wireless Network Not Showing Up?

Have you tried upgrading the firmware on the router?

There is a point in wisdom and knowledge that when you reach it, you exceed what is considered possible - Jason Schoon

RE: Wireless Network Not Showing Up?

Is there anything here?

How to troubleshoot wireless network connections in Windows XP

How to troubleshoot TCP/IP connectivity with Windows XP

How to troubleshoot network connectivity problems

Windows XP Wireless User Guide

Connecting to Wireless Network

RE: Wireless Network Not Showing Up?

Thanks for the reply.

Some additional information:
I appear to be virus free with full scans using Microsoft's AntiSpyWare and LavaSofts Ad-Aware SE. I also can see in the hardware device manager that the wireless adapter in the desktop is functioning properly.

Also, I'm very very hesitant to update to win xp sp 2 because I've tried it on two separate occasions and on both instances I had some office products get corrupted, namely password protected excel sheets. At this point, I can't afford to do that again so I'll have to stick with sp1 for now.

I've updated the routers firmware to the latest. The adapters all have current drivers per documentation.

I'm seeing this error in my win xp event viewer:
The DHCP allocator has detected a DHCP server with IP address xxx.yyy.z.1 on the same network as the interface with IP address xxx.yyy.z.161. The allocator has disabled itself on the interface in order to avoid confusing DHCP clients.

Also, when doing an ipconfig /all i see that my 'Default Gateway', 'DHCP Server' and 'DNS Servers' all have the same default D-link I.P. I suspect this is the issue, but I'm not sure how to resolve it.


RE: Wireless Network Not Showing Up?

Put in a manual ip for the computer.  Go to properties of local area connection, then tcp/ip properties and enter a manual ip (of course different then the one that they all seem to be using).  Let us know if that helps.  put in something like or , etc..

There is a point in wisdom and knowledge that when you reach it, you exceed what is considered possible - Jason Schoon

RE: Wireless Network Not Showing Up?

Thanks for the reply.

After doing some more searching on dlink's support site, I found that I was indeed off by 1 adapter driver version. Something I missed the first time through the search.

In hind site, I guess I should have concentrated on the adapter because of the fact that nothing was showing up in the 'available network' properties and as mentioned...the whole thing was greyed out leaving only the cancel button. What threw me off was the fact that non WEP was working, and WEP wasn't.

Anyway...issue solved.

RE: Wireless Network Not Showing Up?

Glad to hear you got it solved and thanks for posting the solution.

There is a point in wisdom and knowledge that when you reach it, you exceed what is considered possible - Jason Schoon

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close