Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Odd error message "can't open a form whose query..."

Odd error message "can't open a form whose query..."

Odd error message "can't open a form whose query..."

I get the below error in access97:


Can't open a form whose underlying query contains a user-defined function that attempts to set or get the form's recordsetclone property
When I run a query.  The query contains one function Len()--not even a user defined one.

There are no forms whatsoever in this mdb--it's a scratch db I created and have just a couple of local jet tables and a couple of odbc-linked tables.  Again--no forms, no reports, no user-defined functions.  I'm just opening a query that looks at a jet table and gets the len() on one of the fields.

I googled the err msg and found nothing, I was just wondering if anyone has seen this?

RE: Odd error message "can't open a form whose query..."

Sounds strange, have you tried repairing the database?

If that doesn't do anything I would create a new database and import the tables and queries into the new one.

Sounds like it may be corrupted.

RE: Odd error message "can't open a form whose query..."

I've never seen it, my bet is the ODBC table links are causing the weird behavior.

RE: Odd error message "can't open a form whose query..."

Thanks for the responses.  There's one other possible explanation, but I checked and the timing doesn't add up.  I'm working on a terminal server from home, and I have a few scheduled tasks that are Access db's that run and do a few things.

So I thought maybe it was from one of those tasks, yet none of the task run times were close to when this happened (and they only run a few minutes), plus, the times when I'm on the server and those tasks do run, I see them pop up and I have to minimize them to keep working.  When I got this particular error, the db I was working on was the only thing open.

The db was near max size, in fact as I was moving data I had to compact it once when it got too close to max, but it never showed any corruption signs and worked fine but for that one error.  It hasn't happened again so for now I'll chalk it up to 'one of those things'.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close