×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Using CVS 1.11.20 for Solaris 10 Login Issue

Using CVS 1.11.20 for Solaris 10 Login Issue

Using CVS 1.11.20 for Solaris 10 Login Issue

(OP)
After installing CVS 1.11.20 on a new Solaris 10 box, I realize Solaris uses services and not inetd in the traditional way. I got the service up and running using the xlm file that came with CVS.

Now I am having logon issues using Solaris 10. When attempting a login to cvs, here is what happens.
-bash-3.00$ cvs login
Logging in to :pserver:cvs@sam.cleanwise.com:2401/home/cvs/cvsroot
CVS password:
Server configuration missing --allow-root in inetd.conf
-bash-3.00$

In the now legacy inetd, you would normally put this line in the inetd.conf file... but now I don't know how this is or was translated to the new configuration using Solaris services...
cvspserver      stream  tcp     nowait  root    /usr/local/bin/cvs      cvs --allow-root=/home/cvs/cvsroot       pserver

Here is what the cvs service looks like.
-bash-3.00# inetadm -l svc:/network/cvspserver/tcp:default
SCOPE    NAME=VALUE
         name="cvspserver"
         endpoint_type="stream"
         proto="tcp"
         isrpc=FALSE
         wait=FALSE
         exec="/usr/local/bin/cvs -b /usr/local/bin pserver"
         user="root"
default  bind_addr=""
default  bind_fail_max=-1
default  bind_fail_interval=-1
default  max_con_rate=-1
default  max_copies=-1
default  con_rate_offline=-1
default  failrate_cnt=40
default  failrate_interval=60
default  inherit_env=TRUE
default  tcp_trace=FALSE
default  tcp_wrappers=FALSE

Has anyone gone through this yet?
Thanks!
steve

RE: Using CVS 1.11.20 for Solaris 10 Login Issue

(OP)
I figured out how to change the "exec" line in the cvs config for the new inetd svc. so I am trying to figure out what the exact command should be for my installation. once I added --allow-root=/home/cvs/cvsroot in this exec command, it worked better. Although I now get
/home/cvs/cvsroot: no such repository which I am going to try and fix....
It now looks like this...
exec="/usr/local/bin/cvs --allow-root=/home/cvs/cvsroot/ pserver"

I will try a couple different ways to run this command and report back...
Steve

RE: Using CVS 1.11.20 for Solaris 10 Login Issue

(OP)
Ok you're not gonna believe this. Well maybe you will. The extra slash here --allow-root=/home/cvs/cvsroot/ <---- was enough to throw it off. Once I removed it, cvs worked like a champ.

exec="/usr/local/bin/cvs --allow-root=/home/cvs/cvsroot pserver"

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close