×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Permission denied: 'CreateObject'
2

Permission denied: 'CreateObject'

Permission denied: 'CreateObject'

(OP)
hi all,

i'm getting the below error message:

Error Type:
Microsoft VBScript runtime (0x800A0046)
Permission denied: 'CreateObject'
/dump2.asp, line 22


my code is:

<html>
<head>
<title>test</title>
<%
Sub LaunchApp

Dim qtApp
Dim qtTest
Dim qtResultsOpt

Set qtApp = CreateObject("QuickTest.Application")
qtApp.Launch
qtApp.Visible = True

End Sub
%>

</head>
 <body>
<%Call LaunchApp%>
</body>
</html>


Any ideas why I'm getting the permission issue?

I tried the below in a vbs file and it manages to open the wanted application:

Dim qtApp
Dim qtTest
Dim qtResultsOpt
Set qtApp = CreateObject("QuickTest.Application")
qtApp.Launch
qtApp.Visible = True


So why doesn't it work when I put the vbs code into asp?
Which permission do i need to check?

looking forward to hearing from someone,
thanks in advance,
kev

RE: Permission denied: 'CreateObject'

(OP)
By the way. I forgot to mention that I have checked the IIUSR_<machine> account and i have given it admin rights..

What else shall I look at?

thanks,
Kev

RE: Permission denied: 'CreateObject'

2
Where does the application reside that you are trying to launch?
Your code is running server side so if the app is on the server you may need to use Server.CreateObject.
But this would not make the app visible to you it would open the app on the server as a process.

If the app resides on your machine then you may have more luck adding in vbscript script tags for your code so it runs client side.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
Bascically, I want to create an web front-end using asp to enable users in my office to launch QuickTest automated test script remotely. (QuickTest is the name of the test automation tool)

- QuickTest application resides on the server.

- Users will then be able to launch QuickTest from the asp page (not only as a process - but actually opening the application)

- The Web server resides on the same machine as QuickTest.


Looking forward to hear from anyone,
thanks,
Kev

RE: Permission denied: 'CreateObject'

I do not think this can be done.
When you launch an application on the server it runs as a process on the server but even at the console you would not see the application window.  
There is no way the application window can appear on the clients desktop or even within the browser.

At best you may be able to read results back from the application to display in the browser but you would have to build your entire application on the web to just pass info to and from the server side application and you will of course be limited by what ability that application has for automation.

If you find a way to do it I would be very interested in seeing it but I do not think it is possible without the applicaiton or a custom interface being installed client side.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
Thanks for your quick response,

Using the QuickTest Object model, I can actually launch the application remotely. I have succesfully done it using a vbs file. Now, I just need to do the same using asp. I'm using asp as I want to give users an interface to parametize the test remotely. I can easily parametize the test using QuickTest object model. (which i have done in the past using a vbs script)


the below code, which does work using vbscript should also make the application visible on server I believe:

qtApp.Visible = True ' Make the QuickTest application visible


- Yes, I don't want the application to be visible to the client. All I want to do is for the user to launch the application remotely. The application will then open up on the server and kick the test off and then email the results once completed.

So, all I need is asp to launch my application.


I have just modified my code to:

Set qtApp = Server.CreateObject("QuickTest.Application")


And I'm now getting the following error message:


Server object, ASP 0178 (0x80070005)
The call to Server.CreateObject failed while checking permissions. Access is denied to this object.


Any ideas why I'm getting the above error messages? It sounds to be caused by not having the correct NTFS permissions. Anyone has any ideas which specific permissions do i need to alter? or any other solution to this error message.

thanks in advance,
Kev



RE: Permission denied: 'CreateObject'

It sounds as if the IUSR account is not allowed to execute the exe file associated with the application object.

You might have to set permissions on the EXE file or mabye on the folder the application resides in.

The server looks at the ("QuickTest.Application") and looks in the registry to see what application it is associated with then tries to execute it so it seems to me that it would be permissions related to the application.
You may need to modify the Everyone permissions on that file/folder.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
I have given all the permissions access but still getting the same problems.

I have:
- set the permission on my application .exe (everyone full rights)

- set the permission on the folder where the application resides (everyone full access)

As i said earlier, i can open qtp using vbscript. I have opened task manager to see the processes that opening up. I have a first process which is related to the application that is opening up (qtauto~1.exe). Another process then comes up (qtp.exe). And after approximately 10seconds, qtauto~1.exe automatically closes down.

However, when I try to open the application through asp, I 'm getting the error which I have explained earlier. But I have noticed in tast manager that it opens up the qpauto~1.exe process but not qtp.exe.

I have checked the permission on qtp.exe and the application folder and i have given everyone group full control.

Any ideas why I'm not able to open the application in asp when it actually works using only vbs.

thanks in advance,
kev


anymore ideas?
thanks

RE: Permission denied: 'CreateObject'

Set the IUSR account to the same permissions as well.

When you run code from a VBS file it is executing under the permissions of your current logon ID but when you do it from the web server it executes under permission of the IUSR_machinename account.
I suggested the Everyone account because I found references to that error on a server.createobject for a different type of app and the fix was said to be setting Everyone to full rights.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

One other possibility.
The installation of the application may include DLL files in other folders and access to those files is being prevented causing the error.  Not an easy thing to track down most times though.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
I have checked the permissions and I'm running out of ideas of which file/folder i need to grant permission..I have google the error message and I tried all the proposed solution but in vain. I changed most folder/file permissions to allow everyone full control. However, it may be possible that there are some dlls files in other folders that need full control permissions, which i have omitted. Do you know a tool in which i can give full access to my c: drive so that it propagates to all directories and files?

Otherwise, I'm thinking of a workaround..How about having a html file calling a vbs file as I know that from a vbs file I can successfully launch my application? So, The html file would be located on a webserver and I would then place the vbs file outside the webserver so that it doesn't use the 'IUSR_machinename account'. What do you think of this workaround? Is it feasible?

When I think about it, I maybe don't need server side scripting as all i want to do is to launch an application on the server and this can be achieved using the location property in the createobject function.

example:
Set qtApp = CreateObject("QuickTest.Application","hostname")


If anyone has any other ideas in how I can implement this or solve the permission issue, please let me know,

thanks,
Kev

 

RE: Permission denied: 'CreateObject'

Launching the VBS file from your web app will not work as it will launch under the permissions of the IUSR account.  The only way for it to work with client side permissions is executing the VB code from client side.

However, you could use a .HTA file in order to launch the connection.  HTA (HTML Applications) which has the ability to run client side just like the VBS file but you can use HTML for all your formatting.  The code is almost identical to your VBS.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

kev05,
Try this.
Save this code into a file with the extension .HTA

CODE

<html>
<head>
   <HTA:APPLICATION
   ID = "oApp"
   APPLICATIONNAME = "QuikTest Remote"
   BORDER = "thick"
   CAPTION = "yes"
   ICON = ""
   SHOWINTASKBAR = "yes"
   SINGLEINSTANCE = "yes"
   SYSMENU = "yes"
   WINDOWSTATE = "normal"
   SCROLL = "yes"
   SCROLLFLAT = "yes"
   VERSION = "1.0"
   INNERBORDER = "yes"
   SELECTION = "no"
   MAXIMIZEBUTTON = "yes"
   MINIMIZEBUTTON = "yes"
   NAVIGABLE = "yes"
   CONTEXTMENU = "yes"
   BORDERSTYLE = "normal"
   >
<title></title>
<script language="vbscript">

Sub LaunchApp

  Dim qtApp
  Dim qtTest
  Dim qtResultsOpt
  Set qtApp = CreateObject("QuickTest.Application")
    qtApp.Launch
    qtApp.Visible = True

End Sub

</script>
</head>
<body>
</body>
</html>

The file can be launched from the local desktop and it executes with local permissions.
Your VBS code should work inside this file but you have all the capabilities of an HTML page with VBScript and Javascript code as well.

From your web page you can put a link to the file or you can place it directly on their desktops.  If you have a link to it, clicking on it will try to download the file which will generally result in an ActiveX warning message unless the security level is set lower but it will give them the opportunity to Open or Save the file.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

As a test, try using the IIS Admin tool to disable Anonymous Access to your .ASP page.  That should force your script to execute under the security profile of your account instead of as IUSR_XXX.  You can debug it under this test mode to make sure you get everything else besides the permissions fixed.... once it works in this mode go back to Anonymous and you can be relativly sure any remaining problems are related to permissions.

RE: Permission denied: 'CreateObject'

(OP)

Hi theniteowl / Sheco,

I'm currently back home, so i will try this first thing on monday morning.

I am now using the hta file and with it I can successfully open the 'quicktest' application remotely. I have basically put the hta file in the web server in which qtp is also installed.

I'm accessing the hta file through an IE browser. As you said, when I open up the hta file, i get the .ActiveX warning message' which is all fine - I accept it and then the application actually open on the quicktest machine, which is all great.

The application then opens up the test but when it tries to run the test, I'm getting a PERMISSION ERROR! arghhh. :(


The line in which i get the error is:

qtTest.Run qtResultsOpt ' Run the test



By the way, in order to run the application remotely, I have included the location in the argument of CreateObject function:

Set qtApp = CreateObject("QuickTest.Application","Server")


My observations and the test I have carried out are:

- when i run the hta file from the webserver itself without using the location argument - it does work (the script can be run)

- so, the issue i believe is  a permission issue..it seems that I can create object, open the application, open the test but not able to run it. What permission do you believe I need to look into? When I access my Websever through an hta file, which account does it actually use? It's strange that I can open the application, open up the test but only can't run it...

- I have tried using .asp file but I'm still getting the error not able to create the object..though, i have looked into the task manager for the open processes and it seems that a quicktest process is actually opening but the application is not visible. Is there no way to open the application and make it visible by creating an application object??

- I have also tried the following: I have create a shared drive on my server and put the hta file in there. I then opened that file on the client and I'm also getting the above issue..permission issue when trying to run the application. The solution would be i guess to try the hta as if I was actually sitting on the server..it would then work fine. Any ideas on how do that or if it is actually possible to achieve?

- apart of that, if you have any more suggestions.please let me know..thanks so much again.


theniteowl - thanks again..especially for the hta suggestion
Sheco - thanks..i will need to try that on monday morning.


Looking forward for any suggestions / solutions,
thanks,
Kev

RE: Permission denied: 'CreateObject'



- Try looking at the IWAM_xxxxx account
- Ensure that you have enabled "Scripts and Executables" in the Execute Permissions / App settings of the website.  
- Also check the Application Pool identity user (for IIS6.0)

You may want to try an alternative execution method - through Windows Script Host in the ASP page and executing the exe file directly - it's unlikely to make any difference, but worth testing just in case. e.g.

Dim WShell, iRetCode
set wshell = server.createobject("wscript.shell")
iRetCode = wshell.run("C:\YourExe.exe", 0, True)
set wshell = nothing

You probably won't want to stay with this method (as it is limited and can be leaky), but it may help indicate where the problem is.

Hope that helps

A smile is worth a thousand kind words. So smile, it's easy!

RE: Permission denied: 'CreateObject'

If the HTA file is on the server and you try to execute it your option is only to save or execute the file.  The file is downloaded to your PC either to the location you selected to save it or wherever your browser downloads temporary files so either way the file is downloaded and executed from your PC, not from the server.  
So the permissions required are those of your logon ID and has nothing to do with the web servers access or even the folder that the HTA file sits in at the server.
So it is the permissions your ID has for whatever files/folders you need to access.

I am not at all familiar with QuickTest so when you say you get QuickTest to launch but when you talk about opening the test I do not know what you are refering to.  Is this just code you use to pass information to/from QuickTest?
It might be that you can launch the application but as soon as the app tries to write anything it fails because your ID does not have write or create access but does give you read and/or execute.

If I had a better idea of what the application is and what you have to do I might have a better idea of how to solve the problem.  

Also, do you have this QuickTest application installed on the PC you are working from?  Because if you are not specifying the machine for it to launch from it will default to the machine you are logged into where you will not have permission issues to launch the app but it will fail when someone else tries to execute it.  

I do not think you will be able to see the application even if you go to the server console as it would be running as a process under your logon ID as a remote connection not the same as if you were logged directly onto the server and running it there.  
If on the server you hit Ctrl-Alt-Del you can see the application showing under the Task Manager but no visual evidence of the application.

If you were using this type of approach to launch a program on your own computer you could set the visible property so that you can see it or not as you please but when it is executing on a different machine it only runs as a process.

Another thing to watch out for.  If you open the app on the server make sure you close it again when you are done.
I have had apps open a process and not close then when you run it again it opens another one and then another, etc.
Eventually my web server refused to allow any more pages to load.  Closing the processes from the Task Manager did not fix it, neither did stopping and restarting the web services.  I had to re-boot the machine to get it working again.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
Hi,

- I don't believe it is a IIS permission issue as I did put the script in a share drive and I also got the permission denied issue

- I have used Filemon to debug any permissions with one of our developer but he said that the permission issue is not the server. We didn't get any permissions errors in our logs. So the permission issue must be on the machine which is accessing the script and trying to run it. So, which folder and file shall I look into?

- Also, could it be a DCOM configuration settings on the server? I have checked the DCOM settings of 'QuickTest' and I have given 'everyone' and 'all domain users' full rights.

- I have also checked the folder in which the .exe is located on the server and I have again given 'everyone' and 'all domain users' full rights.

- theniteowl: to answer your questions, when I refer to opening the test is similar to loading the test. First of all, the application QuickTest opens, it then loads the script up and finally run the script. Yes, I have also QuickTest on the client machine in which I'm running the script. But other users wont' obviously have QuickTest on their machine.

- theniteowl:  You said that my ID does not have write or create access but does give you read and/or execute. I have checked in which group my ID is in..and its in the administrator group. Shall i add any other groups?


- theniteowl: I'm using the location argument in the CreateObject function so that I can launch the script remotely. I can actually see the application on the server. So not only as a process, the application opens up and the test script loads up to but I only get the permission error once I try to run the test remotely.

- Finally, do you guys believe it could be QuickTest software is not allowing us to remotely run a test. They might have put some security in the software so that we can't kick a script off remotely.

I'm completely running out of ideas. I have checked nearly all permissions issues. So if you guys have any more ideas, please let me know,

thanks so much again,
looking forward to hearin from you,
cheers,
Kev

RE: Permission denied: 'CreateObject'

Everything varies depending on how you are launching and in what security context.

If you use server side code and server.createobject then it is launching on the server side in the context of the IUSR account.  If you launch it client side then you launch under the context of the clients logon ID security and access to everything is altered.

I think your best test is to log onto a PC that does not have that software installed but with an ID that has admin rights on the server so you know where the app is launching from and under what permissions.

If the method you use to launch the app is run client side but specifying the server location to execute it, then I would think it is using LOGON ID permissions to instantiate the application.  How then does the test script get called?
Is it possible to launch the test script via the command line calling the application?

What/where is the output of the script?  Is it on the web server or in another location?  It could be that the application is trying to create a file for the output and the application does not have permissions to the folder it is writing to under the current security context.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
theniteowl,

I have tried what you suggested me and this is what I get:

I have asked one of my collegue who doesn't have quick test installed on his machine and he got the below error message:

ActiveX component can't create object: 'QuickTest.Application'

I have added my collegue in the administrator on the server (where quick test is installed) and also in the quicktest DCOM settings.


here is how i'm opening the test:
--------------------------------
qtApp.Open "T:\dummy", True ' Open the test in read-only

here is how i set the results location:
-----------------------------------------
Set qtResultsOpt = CreateObject("QuickTest.RunResultsOptions") ' Create the Run Results Options object
qtResultsOpt.ResultsLocation = "C:\Res1" ' Set the results location

here is how i run the test:
----------------------------
 qtTest.Run qtResultsOpt ' Run the test


the T drive is a shared folder which everyone has access. The test script is stored there. In both client and server, i have mapped the T drive to the shared folder. By the way, I have tried to access the script from the server C drive which is shared. I have checked the sharing permission and security permission...but didn't seem to help.

As far as the results are concerned, they are stored locally on the client. in the above example, the results of the run is stored in C:\Res1.

I have also tried saving the results on the server and a shared folder and checked permission access but it didn't work either.

I believe what is interesting is that a user who doens't have quicktest installed on his machine is getting a different error message.

Looking forward to hear from any one,
and a special thanks to theniteowl!

cheers,
kev


RE: Permission denied: 'CreateObject'

When you ran this on your own machine you got the app to open right?  That may be because the app was installed on your machine and launching locally rather than actually running from the server.

Can you trim your code to just opening the app without executing the test or outputting a file to simplify it and see if it makes that critical first step?
Doing this from a machine the app is not installed on of course.
And to eliminate concerns over rights you can log into the machine under your own ID.  It's the best test to narrow down rights and application issues.

You said you could test before with a VBS file.  Try that file on this other persons PC as well and see if it works from there.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
Hi theniteowl,

-Yes, when i ran the script on my machine itself, i got the app to launch. It seems to be because I already have the software installed.

- i have as u said trimmed the code so that I just open the application and it seems that I can't launch qtp on the remote quicktest machine server if i don't have quicktest installed on the client. i have also tried the same test with excel and got the same result.

Any ideas on that?
thanks again so much,
kev

RE: Permission denied: 'CreateObject'

I'm not familiar with QuickTest.  Most apps only run relative to their installed environment and need access to their registry entries and various files installed on the system and so do not run remotely.
If QuickTest is specifically designed to allow it to execute remotely from a machine that does not have an installation for it then it's just permissions problems you are running into.

Let me ask you this though.  Does the app have to operate visibly?  Can you launch an instance of the application passing a command line value to tell it which test to run and where to send the output and have it run without manul intervention?

If it will work that way then you can launch a server-side instance of the app through a shell object and echo any text responses back to your application screen.

Here is a sample code I found somewhere that uses a shell object to execute a ping from command line and echo it back to the web page.

CODE

<%
  Response.Buffer = true

    url = "www.espn.com"
 
    Set objWShell = CreateObject("WScript.Shell")
    Set objCmd = objWShell.Exec("ping " & url)
    strPResult = objCmd.StdOut.Readall()
    set objCmd = nothing: Set objWShell = nothing
 
    strStatus = "offline"
    if InStr(strPResult,"TTL=")>0 then strStatus = "online"
 
    response.write url & " is " & strStatus
    response.write ".<br>" & replace(strPResult,vbCrLf,"<br>")
%>

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'


niteowl - for your perseverence if nothing else you deserve a star..  so here you go!

A smile is worth a thousand kind words. So smile, it's easy!

RE: Permission denied: 'CreateObject'

Thanks damber.
I am beginning to think I will have to research QuickTest to see what it can do.  :)

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
hehe! true, thanks so much niteowl - i have given you a 2sd star.

Thanks for all. I will now investigate whether I can run quicktest from the command line.

Anyway, i will keep u guys updated,

thanks again,
kev

RE: Permission denied: 'CreateObject'

(OP)
hi the niteowl,

i threw this issue to mercury support and they also have the same issue. However, they said they did manage to make it work using W2K machines - so it seems that XP SP2 has added security features such as re-enforcing permissions, which is preventing us to run the automated test script remotely.

Any ideas which specific XP SP2 permission feature could cause this to happen?

thanks again,
kev

RE: Permission denied: 'CreateObject'

Possibly heightened security settings in the IE6 browser that comes with XP, what are you using on the W2K machine?
Gone up to IE6 or still using 5.5?

Check your settings for executing ActiveX in the browser.
See if you can get full admin rights to an XP box for testing to eliminate folder security issues.
In my company all PCs are locked down to varying degrees based on the logon ID.  Many people are not able to write to most folders on the computer and some applications choke because they maintain a log or INI file in a folder the client does not have write or create permissions in.
It is possible your W2K environment does not have as restrictive permissions set as the XP implementation.

Paranoid?  ME??   WHO WANTS TO KNOW????

RE: Permission denied: 'CreateObject'

(OP)
Hi niteowl,

good news!

I have have been able to fix the issue. Please find below in between the asterics the solution. It was basically DCOM settings.

As you have suggested, I am using an HTA file, which is working fine.

As it works fine with an hta application, I will try to implement using 'asp' now. Hope it will work...

Anyway, thanks so much for ur help,

please find below the DCOM settings that made it working.

thanks again,
Kev



***********************************************************
Part I:

Add both machines into the same domain. For the domain users logged into both machines, add these domain users to the Local Administrators group on the QTP machine. This is required for Windows to authenticate the remote user executing the tests against the DCOM objects.

Part II:

On the Testing Tool client machine configure Windows Firewall to allow Port 135 for DCOM:

1. Select Start -> Control Panel -> Windows Firewall.

2. Navigate to the Exceptions tab.

3. Configure the Remote Agent to be allowed under "Programs and Services." Configuration should be done for QTP as given below:

QuickTest Professional Remote Agent (path: <System Drive>:\Program Files\Mercury Interactive\QuickTest Professional\bin\AQTRmtAgent.exe)

4. Click on <Add Port> and add the DCOM TCP port 135 to the Exceptions list. The list of "Port Assignments for Commonly-Used Services" is provided in the URL below:

<http://www.microsoft.com/resources/documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/resources/documentation/windows/2000/server/reskit/en-us/cnet/cnfc_por_SIMW.asp>

Part III: (NOT ALL STEPS HAVE BEEN COMPLETED, SOME EXTRA USERS)

Modify DCOM Security Properties:

1. Select Start -> Run and enter dcomcnfg.

2. Navigate to Console Root -> Component Services -> Computers -> My Computer.

Note: If Windows Security Alert dialog window appears, click on <Ask me later> or <Unblock>.

3. Right-click on My Computers and select "Properties."

4. Navigate to the Default Properties tab.

5. Make sure the Default Impersonation Level is "Identify."

6. Click <Apply>.

7. Navigate to the Defualt COM Security tab.

8. Under Access Permissions, click on <Edit Limits>. The Access Permission dialog window appears.

9. Click on <Add>. The Select Users or Groups dialog windows appear.

10. Click on <Advanced>.

11. Click on <Find Now>.

12. Add the following groups and users from the local machine

Administrator

Administrators

Authenticated User

Anonymous Logon

Everyone

Interactive

Network

System

13. Click <OK>.

14. Add the following groups and users from the domain:

<tdomain user logged into the QTP box>

<domain user logged into the other machine running the VBS>

15. Click <OK>.

16. Give "Local Access" and "Remote Access" permissions to the groups and users.

17. Click <OK>.

18. Under Access Permissions, repeat steps 9-17 for <Edit Default>.

19. Under Launch and Activation Permissions, click on <Edit Limits>. The Launch Permission dialog window appears.

20. Repeat steps 9-15.

21. Enable "Local Launch," "Remote Launch," "Local Activation," and "Remote Activation" permissions to the groups and users.

22. Click <OK>.

23. Repeat steps 20-22 for <Edit Default>.

Part IV: (for QTP only)

1. While still in the Component Services window, navigate to Console Root -> Component Services -> Computers -> My Computer -> DCOM Config.

2. Look for the following.

AQTRmtAgent

QuickTest Professional Automation

TlpRmtServer

3. For each of these DCOM applications, right click and select <Properties>.

4. Under the Identity tab, select <The Interactive User>. This will allow the DCOM application to authenticate the process against the logged in Windows user and run the process in that security context.

5. Next, go to the Security tab.

6. For both the <Launch and Activation Permissions> and <Access Permissions>, select <Use Default>. This will use the Default security settings as we did in Part III.

7. Click Apply, then OK to commit the changes.

***********************************************************

RE: Permission denied: 'CreateObject'

Excellent!

It looks like the primary issues were just related to restrictions in the XP firewall?

The instructions show opening security wide open.
I suspect those instructions are just to make sure that it works under the widest possible circumstances.  You can probably trim much of that out with a bit of testing so that you can keep it restricted to just specific people if needed.

Final security can always be controlled at the server level where the application resides regardless of what security settings are on the end-user PC.

For running from ASP, are you trying to use server.createobject?  That will involve the IUSR account for permissions.  Using creatobject on the client-side should use the clients permissions but will trigger ActiveX warnings.

Glad it's working for you.

Paranoid?  ME??   WHO WANTS TO KNOW????

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close