×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

3550 / QoS / service-policy

3550 / QoS / service-policy

3550 / QoS / service-policy

(OP)
So...

In my world, most of my connections run across routers.  I have my class/policy maps setup and assigned to my interfaces using service-policy commands.

A few of my campuses are setup via "transparent lan" point-to-point fibre connections with ethernet handoff.  I'm connecting them via 3550 routing switches...

How can I set priority and bandwidth on the 3550s (EMI) like I would with a router?  I can't seem to find the commands I am used to...

example on a router:

class-map match-all LC-Video
 match access-group name LC-VideoEndpoints
class-map match-any voice
 match ip dscp ef
 match ip precedence 5
class-map match-any sig
 match ip precedence 3
 match ip dscp af31
 match ip dscp cs3
 match  precedence 3
!
!
policy-map voip
 class voice
  priority percent 33
 class sig
  bandwidth percent 5
 class LC-Video
   police 192000 conform-action transmit  exceed-action drop
 class class-default
  fair-queue

...

then on my external interface...

service-policy output voiip

In my 3550s I don't have the same options.

Help?

--DW

RE: 3550 / QoS / service-policy

Generally with switching platforms you classify your traffic on ingress ports and then schedule it on egress ports.  Classification is done using class-maps like you already have, the policy-map though simply sets DSCP or CoS values and optionally applies a policer to out of profile traffic.  The scheduling is generally done by  mapping DSCP or CoS values to queues.  With the 3550 you have by default 4 WRR queues, optionally the 4th can be configured as a strict priority queue.  By default each queue has an equal weight and each buffer space for 100 packets.  You can tune the weights of each queue to 'share-out' the available bandwidth and enable the priority queue for Voice.

With the config below fastethernet 0/1 allocates 5% to Q1, 25% to Q2 and 70% to Q3 with the wrr-queue bandwidth command.  Q4 is the priority queue (configured with priority-queue out) so the 4th weight is ignored.  CoS 1 is mapped to Q1, CoS 0 is mapped to Q2, CoS 2, 3, 4, 6 & 7 are mapped to Q3 and CoS is mapped to the strict priority queue (Q4).

interface FastEthernet0/1
 wrr-queue bandwidth 5 25 70 1
 wrr-queue cos-map 1 1
 wrr-queue cos-map 2 0
 wrr-queue cos-map 3 2 3 4 6 7
 wrr-queue cos-map 4 5
 priority-queue out

On trusted interfaces the DSCP value is generally trusted - these are usually switch uplinks or connections to routers etc.   On user/server access ports service policies are usually applied so ingress traffic is classified according to policy.

HTH

Andy

RE: 3550 / QoS / service-policy

(OP)
ADB100--

That was what I was looking for.  It was the wrr-queue statements.  That's what I was going with, but I thought surely I was missing something.

How would I apply a service-policy to an interface?

For instance, let's say I want all of traffic from 192.168.1.250 to be marked as DSCP 46

normally, I would have some sort of access-list which looks for that ip address.

Then a class-map matching that access-group

Then a service-policy that contained the class and then the "set ip dscp 46" command.

I did that here too on my 3550 but I cannot apply the service-policy to an interface.

What did I miss?

RE: 3550 / QoS / service-policy

Its the same as a router.  I have a 3550 with service policies applied to each access port classifying the ingress traffic from Voice/Data ports as follows:

ip access-list extended VVLAN-ANY
 permit ip 10.1.100.0 0.0.0.255 any
ip access-list extended VVLAN-CALL-SIGNALLING
 permit tcp 10.1.100.0 0.0.0.255 any range 2000 2002 dscp cs3
 permit tcp 10.1.100.0 0.0.0.255 any range 2000 2002 dscp af31
ip access-list extended VVLAN-VOICE
 permit udp 10.1.100.0 0.0.0.255 any range 16384 32767 dscp ef
ip access-list extended DVLAN-ANY
 permit ip 10.1.10.0 0.0.0.255 any
!
class-map match-all DVLAN-ANY
  match access-group name DVLAN-ANY
class-map match-all VVLAN-VOICE
  match access-group name VVLAN-VOICE
class-map match-all VVLAN-ANY
  match access-group name VVLAN-ANY
class-map match-all VVLAN-CALL-SIGNALLING
  match access-group name VVLAN-CALL-SIGNALLING
!
policy-map IPPHONE+PC
  class VVLAN-VOICE
   set dscp ef
    police 128000 8000 exceed-action drop
  class VVLAN-CALL-SIGNALLING
   set dscp cs3
    police 32000 8000 exceed-action policed-dscp-transmit
  class VVLAN-ANY
   set dscp default
    police 32000 8000 exceed-action policed-dscp-transmit
  class DVLAN-ANY
   set dscp default
    police 5000000 8000 exceed-action policed-dscp-transmit
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 100
 service-policy input IPPHONE+PC
 wrr-queue bandwidth 5 25 70 1
 wrr-queue cos-map 1 1
 wrr-queue cos-map 2 0
 wrr-queue cos-map 3 2 3 4 6 7
 wrr-queue cos-map 4 5
 priority-queue out
 spanning-tree portfast
!

HTH

Andy

RE: 3550 / QoS / service-policy

A couple of things in global config as well:

mls qos map policed-dscp  0 24 to 8
!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos map ip-prec-dscp 0 8 16 24 32 46 48 56
!
The first line dictates what the service-policy command 'policed-dscp-transmit' does, the second 2 lines set the CoS & IP Precedence to DSCP maps.

HTH

Andy

RE: 3550 / QoS / service-policy

(OP)

I can't get my interfaces to accept the service-policy input command.  I type it in, it appears to accept it, but it doesn't show up in the "show run"

I'll try a few things then open a TAC case if I can't get it.

Thanks.

RE: 3550 / QoS / service-policy

I would check your IOS, is 'mls qos' enabled in global config and you haven't got any 'mls qos trust' statements on the interfaces as well.

IOS for the 3550 is free as long as you aren't upgrading to EMI.

Service policies won't attach if there is a problem with them but I seem to remember you get a message on the console saying why (if you are telnet'd in try 'term mon' to see the messages).

HTH

Andy

RE: 3550 / QoS / service-policy

(OP)
I got it.  The service-policy input worked this time.

I'm thinkin I had a brain fart :)

Thanks,

--DW

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close