Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


alt_disk_install problem

alt_disk_install problem

alt_disk_install problem

I am trying to do an alt_disk_install (migration) of a 4.3.3 system to 5.1 ML 07. The original OS disks (hdisk0 and hdisk1) were only 4 GB and couldn't hold much more data, so we had to add two 18 GB disks to the system. I mirrored the OS to one of the 18 GB disks, did a bosboot   -ad hdisk2, and broke the rootvg mirror, taking hdisk0 and hdisk1 out of the VG.

This left hdisk2 as the sole disk in rootvg. It has all the necessary LVs, including hd5. The command bootinfo -d gives the result hdisk0.

I started the alt_disk_install and got this error message at the beginning:

0301-168 bosboot: The current boot logical volume, /dev/hd5, does not exist on /dev/hdisk0.

I called IBM and they said it would be OK, because I could see that NIM had created alt_hd5.

Two hours later, at the end of the alt_disk_install process, I got this message:

Creating client boot image.
bosboot: Boot image is 17108 512 byte blocks.
Writing boot image to client's alternate boot disk hdisk3.
dd: 0511-053 The write failed.
: There is a request to a device or address that does not exist.
0505-184 nimadm: Error writing client boot image.
Cleaning up alt_disk_migration on the NIM master.

Does anyone have any ideas? Should I have used this bosboot command: bosboot -ad /dev/hdisk2? Should I boot off hdisk2 before I attempt the alt_disk_install again so the system will see that hdisk2 is bootable?

I've sent this info into IBM, but am hoping I can get a quick answer from this forum.

Thanks for any help you may give me.

RE: alt_disk_install problem

after moving hd5 boot image to another disk, I always do

bosboot -a -d /dev/<newdisk> -l /dev/hd5
bootlist -m normal <newdisk> (or use diag command and also alter service mode bootlist)

A reboot is not really necessary, but it will give you proof that all is well.



RE: alt_disk_install problem

I am sorry for you, bi, but you cannot migrate the OS via alt_disk_install, because this is a major Release number. You will always fail on that. I had an official call to the IBM support in this matter and got the answer, that only minor releases ( e.g. 5.1 -> 5.2 ) can made with alt_disk_install.

YOu have to find another way to migrate....



Advanced Interactive eXecutable

RE: alt_disk_install problem

Thanks, p5wizard and madmurdock.

I ran bosboot -a -d /dev/hdisk3 -l /dev/hd5 and got the same initial error.

I have successfully updated a 4.3.3 test system several times to 5.1 using alt_disk_install, so I know it works.

RE: alt_disk_install problem

I agree.  I did an alt_disk_install to 5.1 from 4.3.3.

You removed hdisk0 and hdisk1 from rootvg?
You ran `bosboot -ad /dev/hdisk2`?  
Try `bosboot -ad /dev/ipldevice`
You ran `bootlist -m normal /dev/hdisk2`?
You ran `chpv -c /dev/hdisk0`?
You ran `chpv -c /dev/hdisk1`? (I think chpv -c clears the disk of boot info.  Not in front of an AIX system right now.)
You are trying to create the alt_install on hdisk3?
What does and `lspv` show?
What does `bootlist -m normal -o` show?

RE: alt_disk_install problem


With chpv and bootlist ignore the /dev and just use the disk name:

bootlist -m normal hdisk2

RE: alt_disk_install problem

Thanks, kHz. To answer your questions:

After I removed hdisk0 and hdisk1 from rootvg, I ran a chpv -c hdisk0 and chpv -c hdisk1.

I have run bosboot -ad hdisk3 and then bosboot -ad /dev/hdisk3 and bosboot -a -d /dev/hdisk2 -l /dev/hd5.

I will try the bosboot -a -d /dev/ipldevice after the current alt_disk_migration completes. (IBM asked me to run it again in verbose and debug modes.) Should I include the hdisk in the bosboot -a -d /dev/ipldevice command?

I ran bootlist -m normal hdisk2.

Here is the output of lspv:

hdisk0        00095230bf1d1f00    None
hdisk1        00095230459a0f62    None
hdisk2        000931169aef65de    rootvg
hdisk3        000931162eb26092    altinst_rootvg (I'm in the middle of an alt_disk_install right now)

# bootlist -m normal -o

And here is an lsvg -l for altinst_rootvg:

# lsvg -l altinst_rootvg
alt_hd5 boot   1     1     1  closed/syncd  N/A
alt_hd6 paging 256   256   1  closed/syncd  N/A
alt_hd8 jfslog 1     1     1  open/syncd    N/A
alt_hd4 jfs    31    31    1  open/syncd    /alt_inst
alt_hd2 jfs    198   198 1  open/syncd    /alt_inst/usr
alt_hd9var jfs 18    18  1  open/syncd   /alt_inst/var
alt_hd3 jfs    16    16  1  open/syncd    /alt_inst/tmp
alt_hd1 jfs    2     2   1  open/syncd    /alt_inst/home
alt_hd10opt jfs 17    17 1 open/syncd    /alt_inst/opt
alt_lv01 sysdump 15  15  1 closed/syncd  N/A

And from rootvg:

# lsvg -l rootvg
LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT
hd5 boot       1     1     1    closed/syncd  N/A
hd6 paging     256   256   1    open/syncd    N/A
hd8 jfslog     1     1     1    open/syncd    N/A
hd4 jfs        43    43    1    open/syncd    /
hd2 jfs        145   145   1    open/syncd    /usr
hd9var jfs        18    18    1    open/syncd    /var
hd3    jfs        16    16    1    open/syncd    /tmp
hd1    jfs        2     2     1    open/syncd    /home
lv01   sysdump    15    15    1    open/syncd    N/A

And bootinfo -B hdisk2 gives the result of 1. (This proves the disk can be booted from based on its hardware location.)

RE: alt_disk_install problem

A `bosboot -ad /dev/ipldevice` will take care of all devices.  And you woudln't need to know which device it specifically is, but no you don't include the hdisk in the command.

It would be interesting to see if the alt_install would work if using hdisk0 or hdisk1.

RE: alt_disk_install problem

bosboot -ad /dev/ipldevice gives me this error message:

0301-168 bosboot: The current boot logical volume, /dev/hd5,
        does not exist on /dev/hdisk0.

I think I will remirror to hdisk0 and try it again.

RE: alt_disk_install problem

I finally got alt_disk_install to work. This is what I did:

I brought hdisk0 back into rootvg and did the alt_disk_install using just that disk in rootvg. That solved the first error message I got.

The second error message I got (dd: 0511-053 The write failed. : There is a request to a device or address that does not exist.) was caused because the boot logical volume (hd5) in AIX 4.3 is about 8 MB and in AIX 5.1 it is about twice that size. When the altnernate logical volumes were created, the alternate hd5 was given only one physical partition. Because the disk size of hdisk0, which was being cloned to hdisk2, was only 4 GB, the PPs were only 8 MB. I had to first increase the size of hd5 in rootvg to 2 PPs and then do the alt_disk install.

Thanks to everyone for their input.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close