×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

tar: tape read error

tar: tape read error

tar: tape read error

(OP)
When I want to list the table of a tape writed with a tar command like this:
tar -tvf /dev/rmt/1n

 this message appears:

tar: tape read error

the tape was written successfully because the first time I used the same command as now:
tar tvf /dev/rmt/1n, 2 times and finally tar tvf /dev/rmt/1 but always show the message tar: tape read error.

To create the tape I used:
tar cvf /dev/rmt/1n disk1
tar cvf /dev/rmt/1n disk2
tar cvf /dev/rmt/1 disk3

Anybody can help me?

Thanks,

RE: tar: tape read error

If you do mt -f /dev/rmt/1n fsf 2 (to position the tape at the bebinning of the third save (the first being position 0)), then try the tar tvf, does it work?

RE: tar: tape read error

(OP)
Hi KenCunningham, when I do "mt -f /dev/rmt/1n fsf 2", this message appears:
/dev/rmt/1n fsf 2 failed: I/O error
Then I have tried with "mt -f /dev/rmt/1n fsf 1" and it works OK, but when I do "tar tvf /dev/rmt/1n", this message appears: tar: blocksize = 0.
Thanks.

RE: tar: tape read error

Inma,
You could have a bad or dirty tape.  Clean you tape drive prior to doing your tar again.  Another thing... Are these tapes 8mm?  If so, are the tapes 160m?  A few years ago, I had alot of problems with the 160m tapes.  Would get no errors when I wrote to the tapes...  Would get the read error when I tried to read them...  112m tapes would work with out any problems.  Sun came in and replaced the 8mm drive.  Still had intermittent problems.  Now I only use the 112m tapes.

RE: tar: tape read error

(OP)
Thanks Bfitzmai for your answering. I had cleaned the tape drive.
I am using a hp dds-2 tape, 4 mm, compressed capacity: 8GB, that was written in a DDS-2 tape drive of Sun (Solaris 5.5)and "tar cvf /dev/rmt/1n" for some files.
Now, I want to read it in a DDS-3 tape drive of Sun (Solaris 5.8) and I use "tar tvf /dev/rmt/1n" after rewind it, and show this messages: tar: tape read error

I do "tcopy /dev/rmt/1" and this message appears:
file 1: eof after 0 records: 0 bytes
eot
total length: 0 bytes.

Inma


RE: tar: tape read error

Hmm. I've had problems with incompatibilities between DDS2 and DDS3/4 before - maybe that's the case here too. Can the tape still be read on the drive it was written on?

RE: tar: tape read error

(OP)
Hi KenCunningham, thanks for your reponse.
Now I haven't the drive where the tape was written because it was broken up.

I'll try to find another one.

Thanks again.
Inma

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close