×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

First Install of Zenworks 6.5

First Install of Zenworks 6.5

First Install of Zenworks 6.5

(OP)
Hello,

My boss man gave me the task of installing, setting up and running zenworks on our Netware 6.5sp3 server. I have followed the site documents on how to install, But when i run startinv from command line it starts but it cant connect to the Database.  My question is,  How do i know If the database is really there? It isnt clear to me on where zenworks puts it.


Thanks

Joedy

RE: First Install of Zenworks 6.5

It's a sybase database by default that stores teh information, however, inventory has two parts to it.

There is the Sybase database that will produce a screen on your server named "ASA 8.0.2 (4339)"  Then there is the "Zenworks Inventory Service".  Inventory on workstations are collected using a local DLL that produces a file that gets sent to the Inventory service that then gets inserted into the database.  This may seem like a bit more than needed in a single site enviroment, but when you have multipule sites with servers at each site, youwould then use the roll up features so you only have to maintain one database, all servers would send thier inventory to this one database.

To get it to work, you need to setup your policies.  First would be the server policy, then a container package, then a Service Location Package, and then to collect inventory from a workstation, you would need a workstation package.  The database will be setup, but there will be no data until a workstation send in something.  The workstations will not do this until the Agent is deployed (see FAQ for help there), and the workstation has been imported.

Zenworks is not a simple out of the box "Hey look I got inventory now"  There is a lot to it because ZEN will run on NetWare and Windows and now Linux.  It will run with or with out the Novell client as well.  The inventory can use SQL and Orical databases as well as the default Sybase.  So there are many things to configure.

If you have ZERO experience with Zenworks, you can fight and fight and fight to learn it, may take 3 or 4 months, maybe less if you are a quick study, then you have your deployment.  Your best bet is to find a partner who will help guide you in your deployment and train you on how to use the software.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt        Certified nut case   
Senior Network Engineer
 http://www.kiscc.com     &n

RE: First Install of Zenworks 6.5

(OP)
I have the packages setup but , i guess my problem is i have no clue what im doing and my boss doesnt either. so im completly in the dark. thanks for the responce ill see what i can com up with

RE: First Install of Zenworks 6.5

Oh yea, I forgot, to connect to the database, you MUST have the ConsoleOne snapins and you MUST be useing 1.3.6c

Then you also have to specify the database to be access each time you open consoleone and want to access the ZFD database.  Tools - Zenworks Inventory - Configure DB   Then choose the database object.

You will then be able to view basic inventory information.

To build reports, you will need to install the Sybase drivers onto your admin PC.  These files are located on one of the Companion CDs (1 I think).  There are instructions on how to install these in the zip file.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt        Certified nut case   
Senior Network Engineer
 http://www.kiscc.com     &n

RE: First Install of Zenworks 6.5

(OP)
I have Server Package, Workstation package, Inventory Database,Inventory Service. not that i know what they do..

RE: First Install of Zenworks 6.5

(OP)
when i startinv shouldnt that connect to Inventory database?

RE: First Install of Zenworks 6.5

yes, but is the database even running?

The command to start the database is SYS:\SYSTEM\mgmtdbs.ncf

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt        Certified nut case   
Senior Network Engineer
 http://www.kiscc.com     &n

RE: First Install of Zenworks 6.5

(OP)
when i run mgmtdbs.ncf

bldg:\zenworks\database\inv\db\mgmtdb.db is not a valid database file
bldg:\zenworks\database\nal\db\nal.db is not a valid database file...


is there a config file that i need to setup as well?

RE: First Install of Zenworks 6.5

(OP)
i dont even have those files on the volume

RE: First Install of Zenworks 6.5

(OP)
i moved \zenworks\database\inv\db\mgmtdb.db  
to sys:\zenworks\database\inv\db\mgmtdb.db as well as the other one, edited the mgmtdbs.ncf to show that is where they are

ran mgmtdbs.ncf again, and it started.  i then ran startinv and it connected as well.
in C1 I did tools> Zenworks Inventory > Configure DB and that went as well.

I guess thats what its suppose to do ?


Thanks for your clear help so far, Its been much needed.


Joedy

RE: First Install of Zenworks 6.5

yup, now you just need to register worksation and start collecting inventory

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt        Certified nut case   
Senior Network Engineer
 http://www.kiscc.com     &n

RE: First Install of Zenworks 6.5

(OP)
this is painful...

I see what I need to do for registering a workstation, but i dont see any of the files that it says to use:

WSRights.exe,WSREG.EXE,

and nwadmin doesnt say anything about zenworks.

can you hold my hand a little bit longer?


Thanks

Joedy

RE: First Install of Zenworks 6.5

You have to use ConsoleOne to manage ZENworks. Additionally, you have to have the ZENworks snapins installed into ConsoleOne for you to have access to any of the ZENworks controls.

Marvin Huffaker, MCNE
http://www.redjuju.com

RE: First Install of Zenworks 6.5

(OP)
i have it setup in ConsoleOne, i just cant figure out the registering part now.. im all over novell.com saying use the files listed above, but i cant find them nore know how to use them

RE: First Install of Zenworks 6.5

(OP)
under tools Zenworks Utilities i have Install Agents


but it says  The user logged into the workstation must be a member of the domain admin group. we dont have a domain admin group.

RE: First Install of Zenworks 6.5

errr, um alrighty ......

Well, if you do not have a Windows inActive Directory (aka Domain on steroids), then the Agent deployment tool will not work for you.

If you check the FAQ for this forum, you will find a post I did on scripting using Auto IT.  Below is the code I have used to deply the agent to 5000+ workstations in about 13 companies so far.  Only real change I make is the file location.  Just place this into a text file, using AutoIT to compile the EXE and place it into your login script.

CODE

;
;     Read the workstation registry to detect if the ZFD Agent is already installed.

$ver = RegRead ( "HKLM\SOFTWARE\Novell\ZENworks\ZfD\Agent\Workstation Manager", "Version" )
If $ver = "6.5.1.41208" Then
    SplashTextOn ( "Notice", "Agent installed and current", 200, 50 )
    Sleep (4000)
    SplashOff()
    Exit
Else
    SplashTextOn ( "Help Desk", "PC Help Desk x7208 - PC software maintenance, do not interrupt this program...", 350, 170, -1, 0, 1,"Courier New Bold", 22, 800 )
    RunWait ( "msiexec.exe /i P:\install\ZFDAgent\ZfDAgent.msi /qb-! STARTUP_APPEXPLORER=1 ADDLOCAL=ALL LOGIN_PASSIVE_MODE=0 NAL_SINGLE_TREE=1" )
EndIf

SplashOff()

For now, just install the agent onto a PC so you can start testing stuff.  Besure your internal DNS server resolves "zenwsimport" to the IP address of the server runnning the import agent.  Also be sure your server policy is setup providing the rights to the correct container you want the workstation objects to be created in.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt        Certified nut case   
Senior Network Engineer
 http://www.kiscc.com     &n

RE: First Install of Zenworks 6.5

(OP)
sorry, but where is the agent?   i have run the Desktop management agents install from the dekstop management cd.
installed everything that i could it gave me Application Explorer and Application Window but from what i read on novell  i need to run WSREG.EXE to get the agent working.

confused...


Thanks,

Joedy

RE: First Install of Zenworks 6.5

Agent should be at SYS:PUBLIC\ZENWORKS\ZFDAGENT\(language) on the server you installed Zenworks on.  It's generally recommended not to use the agent off of the original media because it is not the most recent. You should be using the agent out of Zen 6.5 SP1(a or b).

When you're talking about WSREG, you are talking about 'importing' the workstation into NDS. This creates a Workstation object that can then be managed by various components.   It's not required for certain things.

The WSREG.EXE is actually from an older version of ZEN, I believe 3.x and was used to manually import workstations.  If you want to use the one from ZEN 6.5, it's ZWSREG.EXE located in Program Files\Novell\Zenworks. You shouldn't need to do this though -- i mean, it's not necessary (see next paragraph)

Typically you create an auto workstation import policy so you don't have to import the workstations manually.  This is done via a Server policy package. Managed in Console One.  If you don't understand what I am talking about, you should go to Novell's site and read some manuals. The technical stuff is there if you look for it. An Auto Import policy is one of the most basic components you setup.

Marvin Huffaker, MCNE
http://www.redjuju.com

RE: First Install of Zenworks 6.5

(OP)
I understand what your saying, i have all the packages. found a new problem...

DB Location Policy not configured properly...
[7/28/05 09:58:33.000] ZENInv - Server Config: Inv Server not configured properly. Error code: 610
[7/28/05 09:58:33.000] ZENInv - Server Config: Error Type 15 Error 610


I love Zenworks and Novell ...

RE: First Install of Zenworks 6.5

You haven't configured the Server policy or the Inventory policy to tell the system were the database is located, once done you will be able to do this.

Instructions on how to do this are detailed very well in the manual.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+
Brent Schmidt        Certified nut case   
Senior Network Engineer
 http://www.kiscc.com     &n

RE: First Install of Zenworks 6.5

(OP)
i have followed the documentation to a T.
Server Package is pointing to Inventory Database : Inventory.Server and on the Inventory Database i have setup default from what the doc. says to do.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close