Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Dbinstall problem with v9.2.3 on Mac OS X

Dbinstall problem with v9.2.3 on Mac OS X

Dbinstall problem with v9.2.3 on Mac OS X

I installed Mimer SQL 9.2.3C on Mac OS X 10.2.8.

If I try to start the Dbinstall tool the icon flashes in the dock for a second and that's it. So I cannot create a database. Any ideas?
As a last resort I could create and modify the SQLHOSTS file and others (?) manually. But I hope there is a more comfortable way.

I know that this version is developed for Mac OS X 10.3. Does anybody know why it shouldn't work with 10.2.x?

Thanks in advance.

RE: Dbinstall problem with v9.2.3 on Mac OS X

There is a known problem with the beta-version of Database Installation GUI app when used on Mac OS 10.4 that could fit your description for 10.2.

The workaround is to run the "dbinstall" command from a terminal app window as the root user. See details in the article http://developer.mimer.se/howto/howto_39.htm, section "Creating an Initial Database". For managing the database, the Database Admin GUI app should work as expected.

The problem is investigated by Apple and Mimer and will be solved in the next version.

Regards Per.

RE: Dbinstall problem with v9.2.3 on Mac OS X

Thanks for your suggestion.

I tried the command line mode as root user. Unfortunately dbinstall aborts with the following errors. Maybe somebody can help:

1. After defining the database name:

dyld: /Applications/MimerSQL-9.2.3C/bin/mimcontrol Undefined symbols:

There is an entry in the mimcontrol.crash.log file:

Exception:  EXC_BREAKPOINT (0x0006)
Code[0]:    0x00000001Code[1]:    0x8fe01280

Thread 0 Crashed:
 #0   0x8fe01280 in halt
 #1   0x8fe106b4 in link_in_need_modules
 #2   0x8fe12a24 in _dyld_bind_fully_image_containing_address
 #3   0x900052b4 in _dyld_bind_fully_image_containing_address
 #4   0x9000520c in sigaction__
 #5   0x00005848 in setup_exec_env
 #6   0x000024d4 in main
 #7   0x00001f98 in _start (crt.c:267)
 #8   0x8fe19154 in _dyld_start

But dbinstall accepts the database name and creates a directory. The database name contains characters only.

2. After defining the SYSADM password dbinstall starts the System Databank Generation. It tries to generate SYSDB, TRANSDB, LOGDB and SQLDB. Then:

* MIMER error when allocating memory pools:  -21109
* OS memory allocation error
sysconf: [EINVAL] Invalid argument

dbinstall: error: sdbgen failed (2)

dbinstall aborted

Dbinstall doesn't generate any database. The database directory remains empty.
I tried to start sdbgen manually. It produced the same error.
Referring to the Internal Mimer SQL Return Codes page the error occurs when creating memory pool in database server. Maybe a bug?

Well, is there a way to avoid it? And what is the invalid argument? I choosed the default values for the system databases. So I don't know which value of which argument should be invalid. Does dbinstall or sdbgen create a detailed log file? I found some entries in the system.log only:

<datetime> <machine> /usr/libexec/fix_prebinding: /Applications/MimerSQL-9.2.3C/bin/sdbgen could not be launched prebound.
<datetime> <machine> /usr/libexec/fix_prebinding: /Applications/MimerSQL-9.2.3C/bin/sdbgen couldn't be prebound in the past, and probably can't be prebound now.
<datetime> <machine> /usr/libexec/fix_prebinding: <datetime>: prebinding for sdbgen done.

I would be glad if somebody has a hint.


RE: Dbinstall problem with v9.2.3 on Mac OS X

Thank you. So it looks like I have to upgrade my OS.

Or has anybody else experience with a working Mimer SQL installation on Mac OS X 10.2?


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close