Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


Installing OpenServer 5.0.0 with IDE CD

Installing OpenServer 5.0.0 with IDE CD

Installing OpenServer 5.0.0 with IDE CD


I'm struggling to install 5.0.0 on a Compaq ProSignia 200 server.  It has a SCSI hard drive, and IDE CD-ROM (master on primary).  I've created the Compaq EFS disks, and have now just tracked down the SCO CD and boot disk.  I boot off the SCO boot disk, and at the boot prompt I type variations along the theme of:

defbootstr link="cha wd" hd=Sdsk Srom=wd(0,0,0)

This appears to load cha (for the SCSI controller) when I insert the Compaq BTLD disk.  However, it then asks for the wd volume, and no matter what disk I insert it says it can't find it (probably not surprisingly)! Basically, I don't know how/where to get the wd btld.  I looked at oss451b on the SCO website, and I think I've correctly created a floppy with this on, but it's not having the required effect!  Is there anywhere I can download the correct disk image. I'm struggling a bit with this, and I'd really appreciate some help!


RE: Installing OpenServer 5.0.0 with IDE CD

It's a long shot, but have you tried booting without telling the O/S that you want to add a "wd BTLD"?

defbootstr link="cha wd" hd=Sdsk Srom=wd(0,0,0)

To this:
defbootstr link="cha" hd=Sdsk Srom=wd(0,0,0)

I'll look through my old notes when I get to the office to see if I can find clues on that old version.  Most of the systems we installed back then had SCSI CD-ROM drives, or used Cartrige Tape drives.  Boy, those days are happily gone (for most of us...).

RE: Installing OpenServer 5.0.0 with IDE CD

The oss451b must be applied AFTER the 5.0.0d supplement.

Hope This Helps, PH.
Want to get great answers to your Tek-Tips questions? Have a look at FAQ219-2884 or FAQ222-2244

RE: Installing OpenServer 5.0.0 with IDE CD

Thanks.  I tried without specifying the wd btld.  However, when I got to selecting the installation source I could only select 'cha' as the SCSI adaptor type (not wd) for the SCSI CD-ROM option.  

I managed to make a disk image of oss463b.btld.Z from the SCO site, but I think this is for 5.0.4.  WHen it linked to the kernel and I said to replace, it then gave an error about the symbol table being used, and failed.

The oss451b.Z on SCO doesn't have the '.btld' extension, and I wonder if it's only in a format that can be installed on a live system (ie not at install/boot time). When I insert this disk when it asks for the wd volume it says it can't find it.

Things aren't easy working on 10-year old technolgy!

RE: Installing OpenServer 5.0.0 with IDE CD

Do you have the ATAPI BTLD floppy?  It should have been included with the original media.  

I found the following documentation (which I will paraphrase):

To install using ATAPI BTLD, boot from your installation boot disk and enter the following at the Boot: prompt:

Boot:  defbootstr ahslink=ATAPI Sdsk=cha(0,0,0,0)

When prompted, insert the ATAPI BTLD disk after the kernel has been loaded from the Boot Disk.

After the ATAPI driver has been loaded from the BTLD disk, you are prompted to replace the "wd" driver.  Enter "r" to replace the driver.

When "Identify installation media device" is displayed, choose "SCSI CD-ROM" for media type.
Select "wd" for SCSI host adapter type.
Select Host Adapter #0 (IDE Primary)
Select SCSI ID #0 (Master Device)
Select SCSI LUN #0
Select SCSI BUS #0

The only thing the above doesn't account for is getting the Compaq "cha" driver linked.  So, you may have to play with that initial boot command.  Something like:

defbootstr ahslink="ATAPI cha" Sdsk=cha(0,0,0,0)

If you don't have the ATAPI BTLD, I can send you a "dd" image of it.

RE: Installing OpenServer 5.0.0 with IDE CD

Thanks again Motoslide!

I'm off-site now, but I'll be back tomorrow - and the next day - and....

I'd really appreciate it if you would send me the dd image. Do you need my email address?

This evening I found a SCSI CD-ROM drive, and thought that may simplify things.  I set it ID 5, but still couldn't start the installation process!  I'm not sure if it's something to do with cha (although it says it links, when the installation boot process briefly shows the hwconfig-type info, it shows a tape drive on ID2 even though there's no tape in the system, and I'm not even sure that the Unix kernel is seeing the hard disk.)

However, if you'll send the ATAPI dd image, I'll try that and see how I get on.

Thanks again

RE: Installing OpenServer 5.0.0 with IDE CD

I'll drop it onto one of our FTP servers which has outside connectivity (and anonymous access)

198 dot 107 dot 49 dot 76

Look in the "incoming" folder for atapi.btld.
You'll have to create the floppy using "dd"
# dd if=atapi.btld of=/dev/fd0135ds18 bs=18k

The SCSI CD-ROM should have worked.  ID=5 is the default.  And, the tape drive you saw at ID=2 is pre-configured in the Kernel.  It's not an indication that it was physically "seen" by the O/S (or hdwr).

Good Luck.  I wish I had these 5.0.0 Release Notes in electronic format.  

RE: Installing OpenServer 5.0.0 with IDE CD

You can still access the "official" stuff on SCO's FTP server.  I'd recommend going there!!


You'll find docs there as well.  Look around.

RE: Installing OpenServer 5.0.0 with IDE CD

Hi Motoslide

Thanks for doing all that!  It’s been quite a learning curve, and working with old hardware/software has thrown the usual spanners in the works!  For example, it seems that the SCSI CD-ROM I was using is faulty (it didn’t work in the original system), plus it turned out that the Compaq cha btld disk I’d created was corrupted, plus one of the two 50-pin SCSI drives I’d sourced was very ill – badtrk reported hundreds of bad blocks.

I’ve come at a solution in a different way (I think you originally suggested that).  I’m still working on a ‘test’ system before I go live with the changeover, but I managed to re-link the kernel with the Compaq cha controller driver.  I then put the test hard drive in the Compaq, removed the SCSI CD-ROM settings, and added your wd driver and got the CD-ROM to work etc.  I’ve been adding and/or installing all the other hardware drivers (network card, tape etc).  I think the only sticky wicket may be printers/comms ports.  The old server has an EISA DigiBox, (no EISA slots on the Compaq) but nowadays we’re only running one printer through it.  I think I’ll remove the Digi software, and try to get the printer working directly through COM2.

Thanks again for all your help.  I really appreciate you taking the time to do it.


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close