×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Client is not authorized because of anonymous logon

Client is not authorized because of anonymous logon

Client is not authorized because of anonymous logon

(OP)
I'm recieving the following error in MTS:

Client is not authorized to make the call.  User: NT AUTHORITY\ANONYMOUS LOGON (Package: Reserva 20) (ProgId: Broker.Messages) (CLSID: {B8701170-993F-11D4-8D22-0000B4C055E6}) (Interface: Messages) (IID: {052E5C1A-F23B-11D4-9205-0050DAC42F6B})   (Microsoft Transaction Server Internals Information: File: i:\viper\src\runtime\security\csecobj.cpp, Line: 1209)

The client machines are connected to the MTS server through a VPN.  The problem is that the majority of the clients are not beign authenticated by the NT server, they appear as anonymous on the network not with their nt logins.  All 100 clients have the same nt account and all are always connected to the VPN.  

Has anyone seen this or has any suggestions.  

Thank You in advance!

RE: Client is not authorized because of anonymous logon

It seems that MTS works well on a same domain(LAN).

Regards!

zallen@cmmail.com
Long live of freedom!

RE: Client is not authorized because of anonymous logon

1. You could set NT Challenge/Response to ensure all users are identified. This may or may not be possible depending on your configuration.

2. You could disable security checking on the MTS package

3. It could be DCOM authentication. Try using DCOMCNFG to alter Default Properties.Default Authentication Level to None.

Hope this helps.

K

RE: Client is not authorized because of anonymous logon

(OP)
I actually found what was causing the problem.  
The application that uses the MTS components is started by the NT Scheduler.  The NT Scheduler service was configured to log on as the System account, so the app was started with the System Account which for "security" reason authenticates as blank ("") to other servers, thus the MTS call arrived as anonymous.  The problem was resolved by configuring the Scheduler services to log on as a specified user.

E

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close