I have a web server that is running without a firewall in front of it right now. It has Public IP. After I configured the web server with private IP behind firewall, from the outside I get that the web page is under construction. The following is my config.
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.10.10 inside_web_server
access-list acl_in permit icmp any any any
access-list acl_in permit icmp any host 192.128.67.131
access-list acl_in permit icmp any host 192.128.67.132
access-list acl_in permit icmp any host 192.128.67.174
access-list acl_in permit tcp any host 192.128.67.174 eq www
access-list inside_outbound_nat0_acl permit ip any 192.168.10.48 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any 192.168.10.48 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 200.128.67.131 255.255.255.0
ip address inside 192.128.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ExotracVPN 192.168.10.50-192.168.10.59
pdm location inside_web_server 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 200.128.67.174 inside_web_server netmask 255.255.255.255
0 0
static (inside,outside) 200.128.67.131 192.168.10.11 netmask 255.255.255.255
static (inside,outside) 200.128.67.132 192.168.10.12 netmask 255.255.255.255
access-group acl_in in interface outside
route outside 0.0.0.0 0.0.0.0 200.128.67.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.10.0 255.255.255.0 inside
snmp-server location Brooklyn
snmp-server contact Jon Donchey (201) 538-6656
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPN address-pool VPN
vpngroup VPN idle-time 1800
vpngroup VPN password ********
telnet inside_web_server 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:d824404f708da66c9c3408dee0e47885
: end
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.10.10 inside_web_server
access-list acl_in permit icmp any any any
access-list acl_in permit icmp any host 192.128.67.131
access-list acl_in permit icmp any host 192.128.67.132
access-list acl_in permit icmp any host 192.128.67.174
access-list acl_in permit tcp any host 192.128.67.174 eq www
access-list inside_outbound_nat0_acl permit ip any 192.168.10.48 255.255.255.240
access-list outside_cryptomap_dyn_20 permit ip any 192.168.10.48 255.255.255.240
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 200.128.67.131 255.255.255.0
ip address inside 192.128.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ExotracVPN 192.168.10.50-192.168.10.59
pdm location inside_web_server 255.255.255.255 inside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 200.128.67.174 inside_web_server netmask 255.255.255.255
0 0
static (inside,outside) 200.128.67.131 192.168.10.11 netmask 255.255.255.255
static (inside,outside) 200.128.67.132 192.168.10.12 netmask 255.255.255.255
access-group acl_in in interface outside
route outside 0.0.0.0 0.0.0.0 200.128.67.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.10.0 255.255.255.0 inside
snmp-server location Brooklyn
snmp-server contact Jon Donchey (201) 538-6656
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPN address-pool VPN
vpngroup VPN idle-time 1800
vpngroup VPN password ********
telnet inside_web_server 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:d824404f708da66c9c3408dee0e47885
: end