Phobos1821
MIS
I am currently testing in the lab a new configuration I am proposing for my network. I cannot get this to work for the life of me, and I do not know why. Here is the scenario, and any help would be greatly appreciated.
I have 2 Cisco 2950T switches w/Gigabit uplinks. One cisco 3750 Gigabit Layer 2/3 Switch Router. They are connected in star fashion with the 3750 being the center of the star.
I have defined 3 VLANS (1,10,20).
VLAN10 = 192.168.2.X
VLAN20 = 192.168.3.X
VLAN1 = 192.168.1.X
I have the 2950's set to 802.1Q trunking to the 3750. The 3750 has IP routing enabled. I have created two additional VLAN interfaces for the 3750. Native VLAN for the switches is VLAN1. Forwarding all VLAN traffic.
Now I have three test computers. Two are plugged into different 2950's, and one is plugged into the 3750. From the switches CLI I can ping any ip address. From the actual computers themselves I am having a problem.
Computer 1 = VLAN1 (3750)
Computer 2 = VLAN10 (2950)
Computer 3 = VLAN20 (2950)
Computer 2 & 3 can ping any address on VLAN10 & VLAN20. But nothing on VLAN1. The computer on VLAN1 cannot ping anything on either VLAN10 & VLAN20. So there is a problem with routing between a member of VLAN1 & any other VLAN. Please help me figure this out.
Here are the sample configuration abbreviated.
3750
----
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no mdix auto
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
no ip mroute-cache
!
interface Vlan10
ip address 192.168.2.2 255.255.255.0
!
interface Vlan20
ip address 192.168.3.2 255.255.255.0
!
SHOW IP ROUTE information
-----
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, Vlan1
C 192.168.2.0/24 is directly connected, Vlan10
C 192.168.3.0/24 is directly connected, Vlan20
2950 Configuration
------
!
interface FastEthernet0/1
switchport access vlan 10
no ip address
!
interface GigabitEthernet0/2
switchport mode trunk
no ip address
!
interface Vlan1
ip address 192.168.1.19 255.255.255.0
no ip route-cache
!
I have 2 Cisco 2950T switches w/Gigabit uplinks. One cisco 3750 Gigabit Layer 2/3 Switch Router. They are connected in star fashion with the 3750 being the center of the star.
I have defined 3 VLANS (1,10,20).
VLAN10 = 192.168.2.X
VLAN20 = 192.168.3.X
VLAN1 = 192.168.1.X
I have the 2950's set to 802.1Q trunking to the 3750. The 3750 has IP routing enabled. I have created two additional VLAN interfaces for the 3750. Native VLAN for the switches is VLAN1. Forwarding all VLAN traffic.
Now I have three test computers. Two are plugged into different 2950's, and one is plugged into the 3750. From the switches CLI I can ping any ip address. From the actual computers themselves I am having a problem.
Computer 1 = VLAN1 (3750)
Computer 2 = VLAN10 (2950)
Computer 3 = VLAN20 (2950)
Computer 2 & 3 can ping any address on VLAN10 & VLAN20. But nothing on VLAN1. The computer on VLAN1 cannot ping anything on either VLAN10 & VLAN20. So there is a problem with routing between a member of VLAN1 & any other VLAN. Please help me figure this out.
Here are the sample configuration abbreviated.
3750
----
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no mdix auto
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
no ip mroute-cache
!
interface Vlan10
ip address 192.168.2.2 255.255.255.0
!
interface Vlan20
ip address 192.168.3.2 255.255.255.0
!
SHOW IP ROUTE information
-----
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, Vlan1
C 192.168.2.0/24 is directly connected, Vlan10
C 192.168.3.0/24 is directly connected, Vlan20
2950 Configuration
------
!
interface FastEthernet0/1
switchport access vlan 10
no ip address
!
interface GigabitEthernet0/2
switchport mode trunk
no ip address
!
interface Vlan1
ip address 192.168.1.19 255.255.255.0
no ip route-cache
!