Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Video Conferencing Qos

Status
Not open for further replies.

rflanary

IS-IT--Management
Apr 21, 2006
89
US
Hi All,

I need to figure out Qos for Video. I am scratching my head on this. There are so many options. Basically i need to configure Qos in order to prevent choppy video. I assume i will need to configure it on the end point and my main router. Do I need to configure it on the main switches as well? Do I need to configure Qos on each sub interface? I have a frame relay network need to do this for 3 sites. 2 sites have a T1 and the other 512k back to our main office over a T1 back bone connection.

Any help would be appreciated.

 
If it is configured on the router, then the router will manage the amount of bandwidth you set for video---if it takes priority out of the router, then as far as I know, this is all you need.

Burt
 
you will need to set this on all your wan connections...
at both ends.
 
Yes but i dont know how to Apply Qos? Can anyone provide me some examples?
 
Thanks

What do these numbers mean?

class Video-Conf
priority 450 30000
 
From the sounds of what you are trying to do, you might want to pick up the QOS Exam Cert guide from Ciscopress. I'm in the middle of it now and it's a really good read, and helps explain a lot of things.

Hopefully this can explain the numbers better than I could here:
 
I have been trying to apply this config to one of my 2600 routers.

class-map Video-Conf
match access-group 102
class-map Streaming-Video
match access-group 103
!
policy-map QoS-Policy
class Video-Conf
priority 450 30000
class Streaming-Video
bandwidth 150
class class-default
fair-queue
!
! -- Video-Conf Traffic
access-list 102 permit ip any any dscp cs4
access-list 102 permit ip any any dscp af41
!
! -- Streaming Traffic
access-list 103 permit ip any any dscp cs1
access-list 103 permit ip any any dscp af13


map-class frame-relay cisco
frame-relay cir 1544000
frame-relay mincir 1544000
service-policy output QoS-policy
!


when i apply

frame-relay class cisco

to the framerelay serial interface. I get an error Qos Policy not set. Any Ideas?
 
you are trying to attach the class to the dlci right?
do you have frame-relay traffic shaping enabled?
 
there is no sub interface. Config is below.

Building configuration...

Current configuration : 3143 bytes
!
! Last configuration change at 15:35:01 CDT Sun Aug 5 2007
! NVRAM config last updated at 15:41:28 CDT Sun Aug 5 2007
!
version 12.3
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname XX
!
boot-start-marker
boot-end-marker
!
logging buffered 10000 debugging
enable password misoup
!
memory-size iomem 20
clock timezone Central -6
clock summer-time CDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 172.18.10.1 172.18.10.45
ip dhcp excluded-address 172.18.10.90 172.18.10.110
ip dhcp excluded-address 172.18.10.179 172.18.10.181
!
ip dhcp pool pool1
import all
network 172.18.10.0 255.255.255.0
dns-server 172.16.3.16 172.18.14.100
default-router 172.18.10.1
netbios-name-server 172.16.3.16 172.18.14.100
lease 0 0 15
!
!
!
!
class-map match-all Streaming-Video
match access-group 103
class-map match-all Video-Conf
match access-group 102
!
!
policy-map QoS-Policy
class Video-Conf
priority 450 30000
class Streaming-Video
bandwidth 150
class class-default
fair-queue
!
!
!
interface Ethernet0/0
ip address 172.18.10.1 255.255.255.0
ip route-cache flow
full-duplex
no cdp enable
!
interface Serial0/0
bandwidth 1544
ip address 172.16.6.6 255.255.255.252
encapsulation frame-relay
ip route-cache flow
logging event dlci-status-change
service-module t1 timeslots 1-24
frame-relay class cisco
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Ethernet0/1
no ip address
shutdown
full-duplex
!
router eigrp 100
network 172.16.0.0
network 172.18.0.0
no auto-summary
!
ip http server
ip flow-export version 5
ip flow-export destination 172.16.3.75 2055
ip classless
!
!
!
map-class frame-relay cisco
frame-relay cir 1544000
frame-relay mincir 1544000
logging trap debugging
logging source-interface Ethernet0/0
logging 172.16.3.75
access-list 102 permit ip any any dscp cs4
access-list 102 permit ip any any dscp af41
access-list 103 permit ip any any dscp cs1
access-list 103 permit ip any any dscp af13
snmp-server community BRASNMP RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps cnpd
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps config-copy
snmp-server enable traps envmon
snmp-server enable traps bgp
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-messe
snmp-server enable traps ipmulticast
snmp-server enable traps msdp
snmp-server enable traps rsvp
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps rtr
snmp-server enable traps syslog
!
line con 0
password mlowe
login
line aux 0
line vty 0 4
password mlowe
login
!
ntp clock-period 17208493
ntp server 172.16.6.5
ntp server 207.46.130.100
!
end
 
ive always done it with the subinterface...


just to clarify too

policy-map QoS-Policy
class Video-Conf
priority 450 30000
class Streaming-Video
bandwidth 150
class class-default
fair-queue

basically that will reserve 450kb and 30000 burst bytes for video-conf. it is also the llq so it will be treated as priority traffic..
you then have streaming-video reserving 150kb of your bandwidth. it is not priority but will always have that bandwidth available..
the rest of your traffic will fall into the default class and will have access to the whole t1 until one of the other classes needs bandwidth and backs it off...


now do you want to try this (im not infront of the router to test this so watch for errors)

interface Serial0/0
bandwidth 1544
no ip address
encapsulation frame-relay
ip route-cache flow
frame-relay traffic shaping
logging event dlci-status-change
service-module t1 timeslots 1-24
frame-relay lmi-type ansi

ip address 172.16.6.6 255.255.255.252
bandwidth 1544
interface serial 0/0.1 point
frame-relay interface-dlci 16
frame-relay class cisco

map-class frame-relay cisco
frame-relay cir 1544000
frame-relay mincir 1544000
frame-relay bc 15440
service-policy output QoS-Policy
 
Thanks.

Is it best practice to apply a subinterface? Even though there is only 1 interface.



I just want to be able to use video conferencing without the choppy video or voice. I dont care one way or another about other traffic. What would you recommend?

 
Well, I agree with plshlpme---with the subinterface config, you let the router know that it is indeed a point-to-point link.

Burt
 
ive always used sub interface so honestly im not sure if some of these commands dont apply the same under the physical interface possibly...

so with the above policy map.. you need to figure out how much bandwidth that you need to reserve for your video.. and then in the class maps you are looking for specific dscp values.. you will need to ensure that your video sources are tagging those dscp values so that the router can pick it and apply the pllicy to it correctly.

it will likely be a bit of try and tweak until you find the happy place for your requirements...

when you do a
sh policy-map int s0/0.1

look at the video class stats to make sure packets are being processed..

for example if you are seeing 0 conformed. then its not detecing the traffic properly for that class ( if you know video is going through) and if you see exceeds and drops then you need to increase the amount of bandwidth reserved.
 
The way I have my frame connection on my home lab set up is...
interface Serial0/1
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 192.168.1.2 102 broadcast
and the other router...
interface Serial0/1
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 192.168.1.2 102 broadcast

Burt
 
Thanks,

I have a few LAN TO LAN VPN Connection. What is required to apply QOS to VPN?
 
All of routers do not have sub interfaces except for my core router. Would there be any performance gain if i used sub interfaces?
 
well if the vpn goes over the internet.. your qos wont work as well.. once it leaves your router and goes over the net your not guaranteed anything..

you could put the same type of policies on those vpn interfaces as well.. but i doubt it would work that well because you cant control what happens to it once it leaves your router...
with a point to point or carrier leased line the control is there as the connections are private.
 
well ususally its just a good idea to keep the configs the same at both ends for troubleshooting purposes..

that way you can be sure your traffic is being treated properly at both ends..

like i said before i dont know if it would be treated differently using the physical interface withough traffic shaping etc..

for your 512k link do you have frame-relay fragmentation enabled? or do you have a full t1 port speeds rate-limited to 512 cir?
 
The 512k link is a local loop and is not a full t1 it is a fractional t1 limited to 512k. When you say frame-relay fragmentation enabled what does that mean?

How do i enable it?
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top