Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations bkrike on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Simple ip route question

Status
Not open for further replies.

lfournier

IS-IT--Management
Apr 14, 2003
16
CA
Before I begin, please forgive me. I don't have much occassion to change anything on our router and am definately a newbie. I have a problem which I believe is fairly simple and yet I cannot get it to work.

We currently have a Cisco 2621, with a T1 on our serial interface. We have recently cancelled our T1 and put in an ADSL line. I want to have the router send packets to the ADSL line instead of the T1. Currently the ip route config looks like this.

ip route 0.0.0.0 0.0.0.0 serial0/0

I did a no ip route 0.0.0.0 0.0.0.0 serial0/0

then I added a new route. The ADSL router from our ISP is connected to Fastethernet0/1 on my router. So I tried both of the following entries

ip route 0.0.0.0 0.0.0.0 fastethernet0/1
and
ip route 0.0.0.0 0.0.0.0 x.x.x.x (IP address of fe0/1)

doing this caused me to lose internet connectivity. I wasn't able to clear the routing table although I tried several different commands and reloaded the router.

In doing some further reading I got the idea that it might not have worked because the T1 was still connected and it was still trying to pick the Serial interface over the Fastethernet interface.

So basically my question is how do I get outgoing packets to go to the new ADSL connection?

Thanks so much in advance for any hints or tips you can provide.

Louanne
 
It doesn't matter if the T1 is connected if you have removed the route. Do a 'sh ip route' to see what the default route now is.

There could be a million and one other reasons for it not working.

Chris.

**********************
Chris A.C, CCNA, CCSA
**********************
 
When I do a show ip route I see a number of configured routes. Nothing says default but at the bottom it says
0.0.0.0/0 is directly connected, fastethernet0/1.

Thanks for your help.

Louanne
 
If using staic ip address then I would set ip route as follows:
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx (x=next hop address)ip address of the isp device.
Usually never a good idea to aim a default address to an interface as this will create a huge arp table. Always use physical address whenever possible. Also if router is doing nat then the nat overload was probably set to nat on serial interface...prob need to set to ethernet interface....could tell for sure if you posted config.
 
Thanks for your help. Below is posted my router config. I believe the NAT is being done on our PIx.

Using 1063 out of 29688 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CanadaEdge
!
!
!
!
!
ip subnet-zero
no ip source-route
no ip finger
!
!
!
!
interface FastEthernet0/0
ip address 216.191.146.81 255.255.255.248
no ip directed-broadcast
speed auto
half-duplex
!
interface Serial0/0
ip address 216.191.69.10 255.255.255.252
ip access-group 105 in
no ip redirects
no ip unreachables
no ip directed-broadcast
no ip proxy-arp
no ip route-cache
no ip mroute-cache
no fair-queue
no cdp enable
!
interface FastEthernet0/1
ip address 216.191.220.146 255.255.255.248
ip access-group 105 in
no ip directed-broadcast
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
 
OK...if fast ethernet IP is 216.191.220.146 the your isp router is probably 216.191.220.145...is so then ip route should be:
ip route 0.0.0.0 0.0.0.0 216.191.220.145
What does ethernet 0/0 connect to?
 
Fastethernet0/0 connects to our lan. I will try putting in the next hop. Do I have to remove the serial entry for this to work? Also is there a way for me to test connectivity through the new router. I mean is there a way to test whether the new router is working without disconnecting the T1?

Thanks!!!

Louanne
 
You said something about a pix and I am trying to put together the topology. Does your ISP router connect the the 2621, the 2621 to the pix, the pix to the lan?
 
Physically the topology is this:

My Pix connects to My router, which then connects to the ISPs router. Going into the My router I have the T1 in the CSU/DSU and the ADSL in Fastethernet0/1.

Is that what you were looking for? I am sure PAT is being done on the PIX.

Thanks

Louanne
 
OK...

Run this by you and see if it makes sense.

Originally you needed the router to make the Wan T1 connection on the serial and then the static 8 block was on fastethernet0/1 which connected to PIX ethernet on same ip routeable subnet. Now have ISP device doing this. Think you probably no longer need the 2621. If the ISP equipment ethernet is using the first useable ip of your static 8 block the the second useable ip of the 8 block would then be assigned to the PIX. Connect the 2 directly, change default route in the PIX, and eliminate the 2621.
 
Ahh I know that would have been so easy. But I have the requirement to keep both our pix and our router. This is why it is all so confusing. Is there something I can change in the pix? I basically wanted the isp router to just be a kind of passthrough for the internet connection and everything security wise handled by our router and pix.

Louanne
 
OK...
Only way possible I see to do this is to put a WIC-1ADSL in the 2621 router and eliminate the ISP device. Your PIX must remain IP routeable and would need the address changed to the new 8 block and the default route changed as well. So you would have 2621 connect to ISP via Wic-1ADSL, 1st useable on fastethernet 0/1 connected to pix ethernet which is assigned 2nd ip routeable.
 
I think I am in trouble then..grin. There is no money to buy new parts. So could I keep the pix, my router and their router if I change IP routes on both the pix and the 2621? I hate to bother you further with how to do this since you have been so helpful already but I am totally stumped.

Louanne
 
OK....You will need more help than I can provide. You need to contact your ISP and tell them you need for their router to be setup as a bridge/modem. You can then setup a dialer interface to connect to ISP through the fastethernet0/1 interface. You would then assign the 1st useable ip of the 8 block on fastehernet0/0. 2nd ip routeable address on PIX connected to 2621. Change PIX address and default route and should be good to go. This will allow you to keep current hardware.
 
Thanks so much for your help. I will give this a try.

Louanne
 
Here is an example of what the config might look like and may be helpful in setting it up. May need a tweak here or there.

!
hostname 2621
!
ip subnet-zero
no ip domain-lookup
!
vpdn enable
no vpdn logging
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
interface FastEthernet0/0
ip address 216.191.220.145 255.255.255.248
no ip mroute-cache
!
!
!
!
interface FastEthernet0/1
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address xxx.xxx.xxx.xxx 255.255.255.252 (ISP WAN Address)
ip mtu 1492
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap
ppp pap sent-username XXXXX password XXXXXXXXXX
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX (next hop router)
!
line con 0
exec-timeout 0 0
transport input none
line vty 0 4
login
password ww
!
end
 
Thanks so much for that. You were a great help!!

Lou
 
No problem....have email alert on this if you need any more help....

By the way you do realize that you will need to change the IP address on every client and the PEER information for VPN site to site connections???

Can really understand why going backwords on internet connection other than cost difference.....DSL no were near as reliable as T1.....and sharing bandwidth with other customers....
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top