Stallion417
IS-IT--Management
Hi all,
I have configured a 1721 Cisco for VPDN. Next I added the VPDN users. When a user makes a dialup connection and connects into VPDN, router gives an IP address. That makes a static IP dialup connection to outside user. This IP table clears when router goes off.
I would like to know how can I manage users' IP addresses. Can I use DHCP Server on my router with reserved IP addresses by username? What do you suggest?
**(Router config follows)**
Current configuration : 2380 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname elite-gw
!
enable secret 5 $1$LgkL$x40Lm7jtToyyVKTeoIxfB0
!
username eliteotenet password 0 xxxxx
username otenetelite password 0 xxxxx
username user1@domain.gr password 0 domainpas1
username user2@domain.gr password 0 domainpas2
username user3@domain.gr password 0 domainpas3
aaa new-model
!
!
aaa authentication login local-list local
aaa authentication login none-list none
aaa authentication login oldstyle line
aaa authentication ppp default if-needed local
aaa session-id common
ip subnet-zero
!
!
!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol any
virtual-template 1
terminate-from hostname otenetelite
local name eliteotenet
!
no frame-relay address registration ip
!
!
!
!
interface BRI0
no ip address
no ip mroute-cache
shutdown
!
interface FastEthernet0
ip address 192.168.5.17 255.255.255.240
no ip mroute-cache
speed auto
!
interface Serial0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0.1 point-to-point
ip address 192.168.100.82 255.255.255.252
no ip mroute-cache
frame-relay class internet
frame-relay interface-dlci 16
!
interface Serial0.2 point-to-point
ip address 62.103.180.160 255.255.255.252
frame-relay class vpdn
frame-relay interface-dlci 17
!
interface Serial1
bandwidth 128
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 140
!
interface Virtual-Template1
bandwidth 256
ip unnumbered Serial0.2
ip mroute-cache
peer default ip address pool elitepool
ppp authentication chap pap
!
ip local pool elitepool 192.168.100.1 192.168.100.50
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.100.81
no ip http server
!
!
!
map-class frame-relay internet
frame-relay cir 128000
!
map-class frame-relay vpdn
frame-relay cir 256000
!
radius-server authorization permit missing Service-Type
!
line con 0
speed 115200
line aux 0
line vty 0 4
password xxxxxxxx
!
end
THANX
I have configured a 1721 Cisco for VPDN. Next I added the VPDN users. When a user makes a dialup connection and connects into VPDN, router gives an IP address. That makes a static IP dialup connection to outside user. This IP table clears when router goes off.
I would like to know how can I manage users' IP addresses. Can I use DHCP Server on my router with reserved IP addresses by username? What do you suggest?
**(Router config follows)**
Current configuration : 2380 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname elite-gw
!
enable secret 5 $1$LgkL$x40Lm7jtToyyVKTeoIxfB0
!
username eliteotenet password 0 xxxxx
username otenetelite password 0 xxxxx
username user1@domain.gr password 0 domainpas1
username user2@domain.gr password 0 domainpas2
username user3@domain.gr password 0 domainpas3
aaa new-model
!
!
aaa authentication login local-list local
aaa authentication login none-list none
aaa authentication login oldstyle line
aaa authentication ppp default if-needed local
aaa session-id common
ip subnet-zero
!
!
!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol any
virtual-template 1
terminate-from hostname otenetelite
local name eliteotenet
!
no frame-relay address registration ip
!
!
!
!
interface BRI0
no ip address
no ip mroute-cache
shutdown
!
interface FastEthernet0
ip address 192.168.5.17 255.255.255.240
no ip mroute-cache
speed auto
!
interface Serial0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0.1 point-to-point
ip address 192.168.100.82 255.255.255.252
no ip mroute-cache
frame-relay class internet
frame-relay interface-dlci 16
!
interface Serial0.2 point-to-point
ip address 62.103.180.160 255.255.255.252
frame-relay class vpdn
frame-relay interface-dlci 17
!
interface Serial1
bandwidth 128
ip address 10.1.1.1 255.255.255.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 140
!
interface Virtual-Template1
bandwidth 256
ip unnumbered Serial0.2
ip mroute-cache
peer default ip address pool elitepool
ppp authentication chap pap
!
ip local pool elitepool 192.168.100.1 192.168.100.50
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.100.81
no ip http server
!
!
!
map-class frame-relay internet
frame-relay cir 128000
!
map-class frame-relay vpdn
frame-relay cir 256000
!
radius-server authorization permit missing Service-Type
!
line con 0
speed 115200
line aux 0
line vty 0 4
password xxxxxxxx
!
end
THANX