Phobos1821
MIS
I'm totally confused, and my brain hurts.
This is what I am trying to accomoplish.
A few users will download very large files from the internet. When this happens, all of our bandwidth goes right out the window, all 3Mbits/sec. I'm trying to configure CBWFQ QoS policy to prevent this from happening by reserving 192kbit/sec for HTTPS traffic in the event of congestion.
I have tried this.
class-map match-all https_traffic
match protocol secure-http
policy-map traffic_shaping
class https_traffic
bandwidth 196
shape average 196000
interface Multilink1
ip address xxx.xxx.xxx.xxx
ip access-group 100 in
ip nbar protocol-discovery
service-policy output traffic-shaping
ip route-cache flow
no cdp enable
ppp multilink
ppp multilink fragment disable
ppp multilink group 1
First off, I have no way of verifying that this is working. I dont know a command which will show me if it's giving guaranteed 196kbit to HTTPS traffic in the event of total link congestion.
Also, by doing this I limit ALL bandwidth at all times to 2.1mbits /sec (By the calculation, 75% of 3088, -196 = 2120kbits/sec).
What I want is for the router to utilize 196kbits/sec in the event of congestion, but allow all 3mbit/s at all other times to anything. Is this accomplishing this?
--interfact output--
Multilink1 is up, line protocol is up
Hardware is multilink group interface
Internet address is xxx.xxx.xxx.xxx/30
MTU 1500 bytes, BW 3088 Kbit, DLY 100000 usec,
reliability 255/255, txload 23/255, rxload 146/255
Encapsulation PPP, LCP Open, multilink Open
Open: IPCP, loopback not set
DTR is pulsed for 2 seconds on reset
Last input 00:00:03, output never, output hang never
Last clearing of "show interface" counters 01:19:23
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 24
Queueing strategy: weighted fair
Output queue: 0/1000/64/15 (size/max total/threshold/drops)
Conversations 0/8/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 2583 kilobits/sec
5 minute input rate 1776000 bits/sec, 281 packets/sec
5 minute output rate 285000 bits/sec, 210 packets/sec
1457246 packets input, 1258935669 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
816687 packets output, 199816025 bytes, 0 underruns
0 output errors, 0 collisions, 7 interface resets
0 output buffer failures, 0 output buffers swapped out
This is what I am trying to accomoplish.
A few users will download very large files from the internet. When this happens, all of our bandwidth goes right out the window, all 3Mbits/sec. I'm trying to configure CBWFQ QoS policy to prevent this from happening by reserving 192kbit/sec for HTTPS traffic in the event of congestion.
I have tried this.
class-map match-all https_traffic
match protocol secure-http
policy-map traffic_shaping
class https_traffic
bandwidth 196
shape average 196000
interface Multilink1
ip address xxx.xxx.xxx.xxx
ip access-group 100 in
ip nbar protocol-discovery
service-policy output traffic-shaping
ip route-cache flow
no cdp enable
ppp multilink
ppp multilink fragment disable
ppp multilink group 1
First off, I have no way of verifying that this is working. I dont know a command which will show me if it's giving guaranteed 196kbit to HTTPS traffic in the event of total link congestion.
Also, by doing this I limit ALL bandwidth at all times to 2.1mbits /sec (By the calculation, 75% of 3088, -196 = 2120kbits/sec).
What I want is for the router to utilize 196kbits/sec in the event of congestion, but allow all 3mbit/s at all other times to anything. Is this accomplishing this?
--interfact output--
Multilink1 is up, line protocol is up
Hardware is multilink group interface
Internet address is xxx.xxx.xxx.xxx/30
MTU 1500 bytes, BW 3088 Kbit, DLY 100000 usec,
reliability 255/255, txload 23/255, rxload 146/255
Encapsulation PPP, LCP Open, multilink Open
Open: IPCP, loopback not set
DTR is pulsed for 2 seconds on reset
Last input 00:00:03, output never, output hang never
Last clearing of "show interface" counters 01:19:23
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 24
Queueing strategy: weighted fair
Output queue: 0/1000/64/15 (size/max total/threshold/drops)
Conversations 0/8/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 2583 kilobits/sec
5 minute input rate 1776000 bits/sec, 281 packets/sec
5 minute output rate 285000 bits/sec, 210 packets/sec
1457246 packets input, 1258935669 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
816687 packets output, 199816025 bytes, 0 underruns
0 output errors, 0 collisions, 7 interface resets
0 output buffer failures, 0 output buffers swapped out