Guest_imported
New member
- Jan 1, 1970
- 0
Hi !
I try to connect my network via a Cisco 801 to two different providers: one for e-mail exchange and one for surfing (the surfing provider is much cheaper, but when I use that provider, I'm automatically in the dial-up blacklist that some SMTP mailers look up, so I cannot generally use this one provider.
One interesting side note: I want to do NAT on both connections.
Now, I am quite confused with the correct NAT and dialer settings. I don't get it working. Currently I have this setup (snippet):
interface Ethernet0
ip address 192.168.233.27 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
ip nat inside
interface Ethernet0
ip address 192.168.233.27 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
ip nat inside
!
interface BRI0
no ip address
no ip directed-broadcast
ip nat outside
encapsulation ppp
!dialer rotary-group 1 ??
!dialer-group 1 ??
isdn switch-type basic-net3
interface Dialer1
description EMail only provider
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer in-band
dialer-group 1
dialer string 019161
dialer idle-timeout 30
ppp authentication pap callin
ppp pap sent-username <user> password <pw>
interface Dialer2
description MSN (zum Surfen)
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer in-band
dialer string 010880192658
!dialer-group 2 ??
ppp authentication chap pap callin
ppp chap hostname MSN
ppp chap password MSN
ppp pap sent-username MSN password MSN
ip route 194.245.74.0 255.255.255.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2
Okay, the ethernet has "nat inside", the others all have "nat outside". And still it does not work. Also, I don't have the idea where I have to specify dialer group and dialler rotary. Actually, I don't have the slightest idea what they do.
And finally, there is a global command "ip nat inside source list 1 interface Dialer1 overload" that one of the cisco tools generated. What purpose is this if the nat inside/outside stuff is already defined elsewhere?
I try to connect my network via a Cisco 801 to two different providers: one for e-mail exchange and one for surfing (the surfing provider is much cheaper, but when I use that provider, I'm automatically in the dial-up blacklist that some SMTP mailers look up, so I cannot generally use this one provider.
One interesting side note: I want to do NAT on both connections.
Now, I am quite confused with the correct NAT and dialer settings. I don't get it working. Currently I have this setup (snippet):
interface Ethernet0
ip address 192.168.233.27 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
ip nat inside
interface Ethernet0
ip address 192.168.233.27 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
ip nat inside
!
interface BRI0
no ip address
no ip directed-broadcast
ip nat outside
encapsulation ppp
!dialer rotary-group 1 ??
!dialer-group 1 ??
isdn switch-type basic-net3
interface Dialer1
description EMail only provider
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer in-band
dialer-group 1
dialer string 019161
dialer idle-timeout 30
ppp authentication pap callin
ppp pap sent-username <user> password <pw>
interface Dialer2
description MSN (zum Surfen)
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer in-band
dialer string 010880192658
!dialer-group 2 ??
ppp authentication chap pap callin
ppp chap hostname MSN
ppp chap password MSN
ppp pap sent-username MSN password MSN
ip route 194.245.74.0 255.255.255.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2
Okay, the ethernet has "nat inside", the others all have "nat outside". And still it does not work. Also, I don't have the idea where I have to specify dialer group and dialler rotary. Actually, I don't have the slightest idea what they do.
And finally, there is a global command "ip nat inside source list 1 interface Dialer1 overload" that one of the cisco tools generated. What purpose is this if the nat inside/outside stuff is already defined elsewhere?