We have an old outdated phone or voice VoIP (NBX 100) system on our network. And we are using a Cisco 3550 switch. So far everything works.
VLAN1 – Data
VLAN2 - Data
VLAN4 – Voice
Cisco 3550 IOS Commands
config t
int vlan 4
ip address 192.168.14.10 255.255.255.0
no shut
exit
int range fa0/19-20
switchport
switchport access vlan 4
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,4
switchport voice vlan 4
switchport mode trunk
exit
exit
config t
int range fa0/15
switchport
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
exit
exit
===--=-=-=--===
Cisco 3550 Switch
Cisco3550#sh run
Building configuration...
Current configuration : 6374 bytes
!
! Last configuration change at 14:29:05 UTC Mon Jun 30 2008
! NVRAM config last updated at 13:26:53 UTC Tue Jun 24 2008
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco3550
!
enable secret 5 $1$k5oV$00GvZUV3PVHRlxgLwDxXL0
enable password greatbay
!
no aaa new-model
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos min-reserve 5 170
mls qos min-reserve 6 85
mls qos min-reserve 7 51
mls qos min-reserve 8 34
mls qos
!
!output suppressed
!
interface FastEthernet0/15
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface FastEthernet0/19
switchport access vlan 4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,4
switchport mode trunk
switchport voice vlan 4
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
spanning-tree portfast
!
!
interface Vlan1
ip address 192.168.1.6 255.255.255.0
!
interface Vlan2
ip address 192.168.2.10 255.255.255.0
!
interface Vlan3
ip address 192.168.13.10 255.255.255.0
!
interface Vlan4
ip address 192.168.14.10 255.255.255.0
!
End
===--=-=-=--===
2514 Router1
Cisco2514-01#sh run
Building configuration...
Current configuration : 1587 bytes
!
! NVRAM config last updated at 08:20:05 UTC Wed Jun 25 2008
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2514-01
!
enable password 7 082454577545
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip name-server 4.2.2.1
!
interface Ethernet0
description connected to EthernetLAN
ip address 192.168.3.10 255.255.255.0
ip helper-address 192.168.1.2
!
interface Ethernet1
description connected to EthernetLAN_1
ip address 192.168.4.10 255.255.255.0
!
interface Serial0
description connected to Cisco2514-01
ip address 192.168.254.10 255.255.255.252
encapsulation ppp
!
interface Serial1
no ip address
shutdown
!
router eigrp 7
network 192.168.2.0
network 192.168.3.0
network 192.168.4.0
network 192.168.254.0
no auto-summary
no eigrp log-neighbor-changes
!
router rip
network 192.168.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.8
ip route 10.0.1.0 255.255.255.0 192.168.1.9
ip route 10.1.2.0 255.255.255.0 192.168.1.6
ip route 10.10.10.0 255.255.255.0 192.168.1.9
ip route 192.168.2.0 255.255.255.0 192.168.1.6
ip route 192.168.5.0 255.255.255.0 192.168.1.10
ip route 192.168.14.0 255.255.255.0 192.168.1.6
ip route 192.168.112.0 255.255.255.0 192.168.1.7
ip route 192.168.113.0 255.255.255.0 192.168.3.8
ip route 192.168.199.0 255.255.255.0 192.168.1.6
no ip http server
!
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password 7 1214758258D554455
login
transport input none
line aux 0
line vty 0 4
password 7 121478266D51444
login
!
end
Cisco2514-01#
===--=-=-=--===
2514 Router2
Cisco2514-02#sh run
Building configuration...
Current configuration : 1940 bytes
!
! Last configuration change at 13:25:23 UTC Mon Jun 9 2008
! NVRAM config last updated at 10:30:50 UTC Mon Nov 26 2007
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2514-02
!
enable password 7 070D80741F52
!
ip subnet-zero
no ip finger
!
!
interface Ethernet0
description LAN Connection for PCs
ip address 192.168.1.10 255.255.255.0
!
interface Ethernet1
description LAN Connection for IP Phones
ip address 192.168.5.10 255.255.255.0
!
interface Serial0
description connected to Cisco2514-02
ip address 192.168.254.9 255.255.255.252
encapsulation ppp
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router eigrp 7
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 192.168.254.0
no auto-summary
no eigrp log-neighbor-changes
!
ip default-gateway 192.168.1.9
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.9
ip route 10.1.2.0 255.255.255.0 192.168.1.6 permanent
ip route 10.10.10.0 255.255.255.0 192.168.1.9
ip route 192.168.2.0 255.255.255.0 192.168.1.6 permanent
ip route 192.168.13.0 255.255.255.0 192.168.1.6 permanent
ip route 192.168.14.0 255.255.255.0 192.168.1.6 permanent
ip route 192.168.112.0 255.255.255.0 192.168.1.7
ip route 192.168.113.0 255.255.255.0 192.168.3.8
no ip http server
!
!
map-class frame-relay v384k
no frame-relay adaptive-shaping
frame-relay cir 384000
frame-relay bc 3840
frame-relay be 0
frame-relay mincir 384000
frame-relay fair-queue
!
map-class frame-relay v512k
no frame-relay adaptive-shaping
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
frame-relay fair-queue
!
map-class frame-relay v768k
no frame-relay adaptive-shaping
frame-relay cir 768000
access-list 102 permit udp any any eq rip
!
line con 0
password 7 02022574123964E21
login
transport input none
line aux 0
line vty 0 4
password 7 12145212E 44577
login
!
end
Cisco2514-02#
===--=-=-=--===
For testing purposes, 3550-port-19 is plugged into a Netgear switch. I have PC1 (192.168.14.20) plugged into the Netgear switch. Then I plugged a PC2 (192.168.14.30) anywhere on VLAN1. IT WORKS!! I’m able to ping the PC’s. I can also ping the PC’s through VLAN2.
However, I have another building, another location:
2514 Router1-->Point-To-Point-->2514 Router2-->3550 Switch (VLAN1, VLAN2, VLAN4)
2514 Router1 (192.168.3.10)
2514 Router2 (192.168.1.10)
VLAN1 (192.168.1.6)
VLAN2 (192.168.2.10)
VLAN4 (192.168.14.10)
PC’s 1 and 2 can see each other, however, PC3 (192.168.14.40) on the other side of 2514 Router1 can’t see PC’s 1 and 2.
In the 2514 Routers, I’d like to implement a VLAN and TRUNK voice data over to the Cisco 3550 switch.
If it is possible, what is the 2514 Cisco configuration for this?
Equipment List:
(1) Cisco 3550 switch (12.2(25)SEB4)
(2) Cisco 2514 Routers (IOS (tm) 2500 Software (C2500-I-L), Version 12.1(5))
(1) Dell 2608 Gigabit Switch
(1) Dell 2616 Gigabit Switch
(4) Netgear 10/100 FS524 switches
(1) Netgear 10-BaseT EN516 hub
(1) Linksys EF3124 switch
(2) Watchguard Fireboxes
What the 3550 Cisco IOS configuration on this?
I appreciate any help on this.
VLAN1 – Data
VLAN2 - Data
VLAN4 – Voice
Cisco 3550 IOS Commands
config t
int vlan 4
ip address 192.168.14.10 255.255.255.0
no shut
exit
int range fa0/19-20
switchport
switchport access vlan 4
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,4
switchport voice vlan 4
switchport mode trunk
exit
exit
config t
int range fa0/15
switchport
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
exit
exit
===--=-=-=--===
Cisco 3550 Switch
Cisco3550#sh run
Building configuration...
Current configuration : 6374 bytes
!
! Last configuration change at 14:29:05 UTC Mon Jun 30 2008
! NVRAM config last updated at 13:26:53 UTC Tue Jun 24 2008
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco3550
!
enable secret 5 $1$k5oV$00GvZUV3PVHRlxgLwDxXL0
enable password greatbay
!
no aaa new-model
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos min-reserve 5 170
mls qos min-reserve 6 85
mls qos min-reserve 7 51
mls qos min-reserve 8 34
mls qos
!
!output suppressed
!
interface FastEthernet0/15
switchport access vlan 2
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface FastEthernet0/19
switchport access vlan 4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,4
switchport mode trunk
switchport voice vlan 4
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
spanning-tree portfast
!
!
interface Vlan1
ip address 192.168.1.6 255.255.255.0
!
interface Vlan2
ip address 192.168.2.10 255.255.255.0
!
interface Vlan3
ip address 192.168.13.10 255.255.255.0
!
interface Vlan4
ip address 192.168.14.10 255.255.255.0
!
End
===--=-=-=--===
2514 Router1
Cisco2514-01#sh run
Building configuration...
Current configuration : 1587 bytes
!
! NVRAM config last updated at 08:20:05 UTC Wed Jun 25 2008
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2514-01
!
enable password 7 082454577545
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip name-server 4.2.2.1
!
interface Ethernet0
description connected to EthernetLAN
ip address 192.168.3.10 255.255.255.0
ip helper-address 192.168.1.2
!
interface Ethernet1
description connected to EthernetLAN_1
ip address 192.168.4.10 255.255.255.0
!
interface Serial0
description connected to Cisco2514-01
ip address 192.168.254.10 255.255.255.252
encapsulation ppp
!
interface Serial1
no ip address
shutdown
!
router eigrp 7
network 192.168.2.0
network 192.168.3.0
network 192.168.4.0
network 192.168.254.0
no auto-summary
no eigrp log-neighbor-changes
!
router rip
network 192.168.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.8
ip route 10.0.1.0 255.255.255.0 192.168.1.9
ip route 10.1.2.0 255.255.255.0 192.168.1.6
ip route 10.10.10.0 255.255.255.0 192.168.1.9
ip route 192.168.2.0 255.255.255.0 192.168.1.6
ip route 192.168.5.0 255.255.255.0 192.168.1.10
ip route 192.168.14.0 255.255.255.0 192.168.1.6
ip route 192.168.112.0 255.255.255.0 192.168.1.7
ip route 192.168.113.0 255.255.255.0 192.168.3.8
ip route 192.168.199.0 255.255.255.0 192.168.1.6
no ip http server
!
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password 7 1214758258D554455
login
transport input none
line aux 0
line vty 0 4
password 7 121478266D51444
login
!
end
Cisco2514-01#
===--=-=-=--===
2514 Router2
Cisco2514-02#sh run
Building configuration...
Current configuration : 1940 bytes
!
! Last configuration change at 13:25:23 UTC Mon Jun 9 2008
! NVRAM config last updated at 10:30:50 UTC Mon Nov 26 2007
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2514-02
!
enable password 7 070D80741F52
!
ip subnet-zero
no ip finger
!
!
interface Ethernet0
description LAN Connection for PCs
ip address 192.168.1.10 255.255.255.0
!
interface Ethernet1
description LAN Connection for IP Phones
ip address 192.168.5.10 255.255.255.0
!
interface Serial0
description connected to Cisco2514-02
ip address 192.168.254.9 255.255.255.252
encapsulation ppp
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router eigrp 7
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 192.168.254.0
no auto-summary
no eigrp log-neighbor-changes
!
ip default-gateway 192.168.1.9
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.9
ip route 10.1.2.0 255.255.255.0 192.168.1.6 permanent
ip route 10.10.10.0 255.255.255.0 192.168.1.9
ip route 192.168.2.0 255.255.255.0 192.168.1.6 permanent
ip route 192.168.13.0 255.255.255.0 192.168.1.6 permanent
ip route 192.168.14.0 255.255.255.0 192.168.1.6 permanent
ip route 192.168.112.0 255.255.255.0 192.168.1.7
ip route 192.168.113.0 255.255.255.0 192.168.3.8
no ip http server
!
!
map-class frame-relay v384k
no frame-relay adaptive-shaping
frame-relay cir 384000
frame-relay bc 3840
frame-relay be 0
frame-relay mincir 384000
frame-relay fair-queue
!
map-class frame-relay v512k
no frame-relay adaptive-shaping
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
frame-relay fair-queue
!
map-class frame-relay v768k
no frame-relay adaptive-shaping
frame-relay cir 768000
access-list 102 permit udp any any eq rip
!
line con 0
password 7 02022574123964E21
login
transport input none
line aux 0
line vty 0 4
password 7 12145212E 44577
login
!
end
Cisco2514-02#
===--=-=-=--===
For testing purposes, 3550-port-19 is plugged into a Netgear switch. I have PC1 (192.168.14.20) plugged into the Netgear switch. Then I plugged a PC2 (192.168.14.30) anywhere on VLAN1. IT WORKS!! I’m able to ping the PC’s. I can also ping the PC’s through VLAN2.
However, I have another building, another location:
2514 Router1-->Point-To-Point-->2514 Router2-->3550 Switch (VLAN1, VLAN2, VLAN4)
2514 Router1 (192.168.3.10)
2514 Router2 (192.168.1.10)
VLAN1 (192.168.1.6)
VLAN2 (192.168.2.10)
VLAN4 (192.168.14.10)
PC’s 1 and 2 can see each other, however, PC3 (192.168.14.40) on the other side of 2514 Router1 can’t see PC’s 1 and 2.
In the 2514 Routers, I’d like to implement a VLAN and TRUNK voice data over to the Cisco 3550 switch.
If it is possible, what is the 2514 Cisco configuration for this?
Equipment List:
(1) Cisco 3550 switch (12.2(25)SEB4)
(2) Cisco 2514 Routers (IOS (tm) 2500 Software (C2500-I-L), Version 12.1(5))
(1) Dell 2608 Gigabit Switch
(1) Dell 2616 Gigabit Switch
(4) Netgear 10/100 FS524 switches
(1) Netgear 10-BaseT EN516 hub
(1) Linksys EF3124 switch
(2) Watchguard Fireboxes
What the 3550 Cisco IOS configuration on this?
I appreciate any help on this.