Hi there,
I'm new to the ASA, and have been given this sanitised config from someone's ASA. The machines can get out to the Internet ok (so routing/outbound NAT is ok), but the incoming port forwardings for SMTP etc are not working .
I have used PIXs ok, and basing my knowledge on them, it looks sort of ok:
static commands are there
inbound access-list is there
inbound access-list is applied
192.168.1.x is internal
the external IPs have been replaced with 10.10.10.x
Can anyone suggest what might be wrong?
Thanks.
ASA Version 7.2(2)
!
hostname xxx-fw
domain-name xxx
enable password xxx encrypted
names
dns-guard
!
interface Ethernet0/0
description To xxx LAN
nameif inside
security-level 100
ip address 192.168.1.253 255.255.255.0
!
interface Ethernet0/1
description World Facing to YYY/Internet
nameif outside
security-level 0
ip address 10.10.10.17 255.255.255.240
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
shutdown
nameif management
security-level 100
no ip address
management-only
!
passwd xxx encrypted
no ftp mode passive
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
domain-name xxx
access-list inbound extended permit tcp any host 10.10.10.17 eq 3389
access-list inbound extended permit tcp any host 10.10.10.18 eq 3389
access-list inbound extended permit tcp any host 10.10.10.19 eq 3389
access-list inbound extended permit tcp any host 10.10.10.17 eq smtp
access-list inbound extended permit tcp any host 10.10.10.17 eq www
access-list inbound extended permit tcp any host 10.10.10.17 eq https
access-list nat-overload extended permit ip 192.168.1.0 255.255.255.0 any
access-list noNAT extended permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.0
pager lines 24
logging enable
logging timestamp
logging buffer-size 16000
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu management 1500
ip local pool vpn-roam 172.16.1.1-172.16.1.254
ip verify reverse-path interface inside
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list noNAT
nat (inside) 1 access-list nat-overload
static (inside,outside) tcp 192.168.1.252 smtp 10.10.10.17 smtp netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.6 3389 10.10.10.17 3389 netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.7 3389 10.10.10.18 3389 netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.251 3389 10.10.10.19 3389 netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.6 255.255.255.255
static (inside,outside) tcp 192.168.1.6 https 10.10.10.17 https netmask 255.255.255.255
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 10.10.10.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy roampolicy internal
group-policy roampolicy attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value noNAT
user-authentication disable
username vpn-roam password xxx encrypted
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication serial console LOCAL
aaa authentication secure-http-client
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set myset-3des esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset-3des
crypto map my-map 40 ipsec-isakmp dynamic dynmap
crypto map my-map interface outside
crypto isakmp enable outside
crypto isakmp policy 3
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
tunnel-group vpn-roam type ipsec-ra
tunnel-group vpn-roam general-attributes
address-pool vpn-roam
authorization-server-group LOCAL
default-group-policy roampolicy
tunnel-group vpn-roam ipsec-attributes
pre-shared-key *
telnet 192.168.10.0 255.255.255.0 inside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh xxx 255.255.255.255 outside
ssh xxx 255.255.255.255 outside
ssh timeout 5
console timeout 0
!
class-map HTTP
match port tcp eq www
class-map inspection_default
match default-inspection-traffic
!
!
policy-map SYN-Defence
class HTTP
set connection per-client-max 100 per-client-embryonic-max 50
class class-default
policy-map global-policy
class inspection_default
inspect ftp
!
service-policy global-policy global
I'm new to the ASA, and have been given this sanitised config from someone's ASA. The machines can get out to the Internet ok (so routing/outbound NAT is ok), but the incoming port forwardings for SMTP etc are not working .
I have used PIXs ok, and basing my knowledge on them, it looks sort of ok:
static commands are there
inbound access-list is there
inbound access-list is applied
192.168.1.x is internal
the external IPs have been replaced with 10.10.10.x
Can anyone suggest what might be wrong?
Thanks.
ASA Version 7.2(2)
!
hostname xxx-fw
domain-name xxx
enable password xxx encrypted
names
dns-guard
!
interface Ethernet0/0
description To xxx LAN
nameif inside
security-level 100
ip address 192.168.1.253 255.255.255.0
!
interface Ethernet0/1
description World Facing to YYY/Internet
nameif outside
security-level 0
ip address 10.10.10.17 255.255.255.240
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
shutdown
nameif management
security-level 100
no ip address
management-only
!
passwd xxx encrypted
no ftp mode passive
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
domain-name xxx
access-list inbound extended permit tcp any host 10.10.10.17 eq 3389
access-list inbound extended permit tcp any host 10.10.10.18 eq 3389
access-list inbound extended permit tcp any host 10.10.10.19 eq 3389
access-list inbound extended permit tcp any host 10.10.10.17 eq smtp
access-list inbound extended permit tcp any host 10.10.10.17 eq www
access-list inbound extended permit tcp any host 10.10.10.17 eq https
access-list nat-overload extended permit ip 192.168.1.0 255.255.255.0 any
access-list noNAT extended permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.0
pager lines 24
logging enable
logging timestamp
logging buffer-size 16000
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu management 1500
ip local pool vpn-roam 172.16.1.1-172.16.1.254
ip verify reverse-path interface inside
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list noNAT
nat (inside) 1 access-list nat-overload
static (inside,outside) tcp 192.168.1.252 smtp 10.10.10.17 smtp netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.6 3389 10.10.10.17 3389 netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.7 3389 10.10.10.18 3389 netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.251 3389 10.10.10.19 3389 netmask 255.255.255.255
static (inside,outside) tcp 192.168.1.6 255.255.255.255
static (inside,outside) tcp 192.168.1.6 https 10.10.10.17 https netmask 255.255.255.255
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 10.10.10.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy roampolicy internal
group-policy roampolicy attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value noNAT
user-authentication disable
username vpn-roam password xxx encrypted
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication serial console LOCAL
aaa authentication secure-http-client
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set myset-3des esp-3des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset-3des
crypto map my-map 40 ipsec-isakmp dynamic dynmap
crypto map my-map interface outside
crypto isakmp enable outside
crypto isakmp policy 3
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
tunnel-group vpn-roam type ipsec-ra
tunnel-group vpn-roam general-attributes
address-pool vpn-roam
authorization-server-group LOCAL
default-group-policy roampolicy
tunnel-group vpn-roam ipsec-attributes
pre-shared-key *
telnet 192.168.10.0 255.255.255.0 inside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh xxx 255.255.255.255 outside
ssh xxx 255.255.255.255 outside
ssh timeout 5
console timeout 0
!
class-map HTTP
match port tcp eq www
class-map inspection_default
match default-inspection-traffic
!
!
policy-map SYN-Defence
class HTTP
set connection per-client-max 100 per-client-embryonic-max 50
class class-default
policy-map global-policy
class inspection_default
inspect ftp
!
service-policy global-policy global