It's been a while since I have been here, good to be back!
I'm hoping someone here can help me out I can't think anymore and this is driving me crazy! I have an older Cisco 851 router running IOS 12.4 that I've hooked up to my cable mode. I have a dynamic public address so I configured the WAN interface with the following command
int fa4
ip address dhcp
The router get's an IP address from COX at this point and I'm able to ping external IP addresses so I have a connection to the outside world. At this point I disconnected the router from the cable modem inn order to lock it down. This is the part where I get confused...
From inside my internal network I cannot connect to the internet. I have my internal network pointing to the routers BVI interface, is this wrong? If anyone can review this config and point out my mistakes I would appreciate it greatly!!!
Building configuration...
Current configuration : 1885 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SDrouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 *****************************
!
no aaa new-model
!
resource policy
!
no ip subnet-zero
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1 192.168.100.20
!
ip dhcp pool LAN
import all
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
!
!
ip cef
ip inspect name InspectFirewallR icmp
ip inspect name InspectFirewallR tcp
ip inspect name InspectFirewallR udp
no ip domain lookup
!
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp
ip access-group 101 in
ip inspect InspectFirewallR in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.100.1 255.255.255.0
ip access-group 100 in
ip inspect InspectFirewallR in
ip nat inside
ip virtual-reassembly
!
ip classless
!
no ip http server
no ip http secure-server
ip nat inside source list 10 interface FastEthernet4 overload
!
access-list 10 permit 192.168.100.0 0.0.0.255
access-list 10 deny any
access-list 100 permit ip 192.168.100.0 0.0.0.255 any
access-list 100 deny ip any any
access-list 101 permit udp any eq bootps any eq bootpc
access-list 101 permit tcp any any
access-list 101 permit udp any any
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 deny ip any any
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password ***********
login
!
scheduler max-task-time 5000
end
Visit www.netwerkin.com
MCSE MCSA MCTS MCITP MCP CCNA CCA A+ N+
I'm hoping someone here can help me out I can't think anymore and this is driving me crazy! I have an older Cisco 851 router running IOS 12.4 that I've hooked up to my cable mode. I have a dynamic public address so I configured the WAN interface with the following command
int fa4
ip address dhcp
The router get's an IP address from COX at this point and I'm able to ping external IP addresses so I have a connection to the outside world. At this point I disconnected the router from the cable modem inn order to lock it down. This is the part where I get confused...
From inside my internal network I cannot connect to the internet. I have my internal network pointing to the routers BVI interface, is this wrong? If anyone can review this config and point out my mistakes I would appreciate it greatly!!!
Building configuration...
Current configuration : 1885 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SDrouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 *****************************
!
no aaa new-model
!
resource policy
!
no ip subnet-zero
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1 192.168.100.20
!
ip dhcp pool LAN
import all
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
!
!
ip cef
ip inspect name InspectFirewallR icmp
ip inspect name InspectFirewallR tcp
ip inspect name InspectFirewallR udp
no ip domain lookup
!
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address dhcp
ip access-group 101 in
ip inspect InspectFirewallR in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.100.1 255.255.255.0
ip access-group 100 in
ip inspect InspectFirewallR in
ip nat inside
ip virtual-reassembly
!
ip classless
!
no ip http server
no ip http secure-server
ip nat inside source list 10 interface FastEthernet4 overload
!
access-list 10 permit 192.168.100.0 0.0.0.255
access-list 10 deny any
access-list 100 permit ip 192.168.100.0 0.0.0.255 any
access-list 100 deny ip any any
access-list 101 permit udp any eq bootps any eq bootpc
access-list 101 permit tcp any any
access-list 101 permit udp any any
access-list 101 permit icmp any any echo-reply
access-list 101 permit icmp any any time-exceeded
access-list 101 permit icmp any any unreachable
access-list 101 deny ip any any
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password ***********
login
!
scheduler max-task-time 5000
end
Visit www.netwerkin.com
MCSE MCSA MCTS MCITP MCP CCNA CCA A+ N+