Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations bkrike on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

cisco 3600 series router

Status
Not open for further replies.

tomum231

Technical User
Sep 11, 2009
4
US
hi, please tell me how I can make the two networks to talk.

what i want is one nic connect to my ips modem (verizon) other nics can connect to switches or directly to a pc.

thank you much!


version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
description connect to verizon modem
ip address 192.168.1.20 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface TokenRing2/0
no ip address
shutdown
ring-speed 16
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
login
!
 
so what you're saying is that you'd like to get your hosts to the Internet??

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
The below is a very basic NAT setup that should get you running:

interface FastEthernet0/0
description connect to verizon modem
ip nat outside
!
interface FastEthernet0/1
ip nat inside

ip nat inside source list 1 interface FastEthernet0/0 overload
!

access-list 1 permit 192.168.2.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0


Regards
 
thanks Minue!

after I made changes, I now can ping the 192.168.1.x from 192.168.2.x. however, I still can't connect to the internet.

below is the config. thank you!

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MyRouter
!
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.20
!
ip dhcp pool inside
import all
network 192.168.2.0 255.255.255.0
!
!
!
!
interface FastEthernet0/0
description connect to verizon modem
ip address 192.168.1.20 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
description direct connects to laptop
ip address 192.168.2.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface TokenRing2/0
no ip address
shutdown
ring-speed 16
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip http server
!
access-list 1 permit 192.168.2.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
login
!
end
 
have you tried pinging something by ip address? what are you showing for your DNS IP address(es) on your host?? tell us about your verizon modem; is it cable, fios, etc?? does it do any NATing??

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
I have verizon fios.

I tried ping google.com and didn't work.

don't know much about natting on the verizon modem.

do I need to add gateway, DNS on the 192.168.1.x nic?
 
i want to make sure that your client has a valid DNS server address being provided via dhcp. Have you tried to ping something by IP address such as 4.2.2.2??

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top