Thanks. I found out. I tried to program it, but I kep getting transceiver problem. Do you know what that it? Also, is ip address for ethernet 0 is ISP ip address? do I need to give fast ethenet an ip address too?
Below is a very basic config for connecting via DSL modem to the internet. You can also enable DHCP on the router so you do not have to manually configure IP settings the clients.
! ******************************************************************
! Cisco1720.cfg - Cisco router configuration file
! Automatically created by Cisco ConfigMaker v2.6 Build 6
! Saturday, April 15, 2006, 10:00:50 PM
!
! Hostname: Cisco1720
! Model: 1720
! ******************************************************************
!
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Cisco1720
!
enable password password
!
no ip name-server
!
ip subnet-zero
no ip domain-lookup
ip routing
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface Dialer 1
description connected to Internet
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer-group 2
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname username
ppp chap password password
ppp pap sent-username username password password
!
interface FastEthernet 0
no shutdown
description connected to Hub
ip address 192.168.1.1 255.255.255.0
ip nat inside
keepalive 10
ip tcp adjust-mss 1452
!
interface Ethernet 0
no shutdown
description connected to Internet
no ip address
no keepalive
pppoe enable
pppoe-client dial-pool-number 1
!
! Access Control List 1
!
no access-list 1
access-list 1 permit 192.168.1.0 0.0.0.255
!
! Dialer Control List 2
!
no dialer-list 2
dialer-list 2 protocol ip permit
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Dialer 1 overload
!
router rip
version 2
network 192.168.1.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
no ip http server
snmp-server community public RO
no snmp-server location
no snmp-server contact
!
line console 0
exec-timeout 0 0
password password
login
!
line vty 0 4
password password
login
!
end
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.