IllegalOperation
Technical User
Hello once again all. I have noticed that at specific times (around 5:00pm EST mostly), my WAN interface randomly drops. More specifically - the "ATM interface".
The router is a Cisco 827. When I do a debug PPP and ATM errors, I get these error messages...
*Mar 1 00:01:41.735: DSL: Defect: LOS LOF LCDf LOM: retraining
*Mar 1 00:01:44.723: %LINK-3-UPDOWN: Interface ATM0, changed state to down
*Mar 1 00:01:45.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, chan
ged state to down
*Mar 1 00:01:53.063: Vi1 LCP: echo_cnt 2, sent id 3, line up
*Mar 1 00:02:03.227: %LINK-3-UPDOWN: Interface ATM0, changed state to up
*Mar 1 00:02:04.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, chan
ged state to up
So far I have only been successful stopping this problem by constantly rebooting the router. I dont know if this problem is related to the time of day or not. Also, I noticed that the router only has 368308 bytes of free memory (its the way I have it set up).
Anyways, here is the running config. Let me know if you see any reasons why my interface would be dropping. Thanks....
Current configuration : 2627 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Odyssey1
!
logging rate-limit console 10 except errors
enable secret *******
enable password *******
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip name-server *.*.*.*
ip name-server *.*.*.*
!
no ip dhcp-client network-discovery
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
bridge irb
!
!
!
interface Tunnel0
ip address *.*.*.* 255.255.255.252
tunnel source Dialer1
tunnel destination *.*.*.*
!
interface Ethernet0
ip address *.*.*.* 255.255.255.0
no ip redirects
ip nat inside
ip tcp adjust-mss 1452
no ip mroute-cache
no cdp enable
!
interface ATM0
no ip address
no ip redirects
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
bridge-group 1
bridge-group 1 spanning-disabled
!
interface ATM0.1 point-to-point
no ip mroute-cache
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address *.*.*.* 255.255.255.248
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ip access-group odyssey in
ppp pap sent-username ************.net
password *******
!
ip classless
ip route 0.0.0.0 0.0.0.0 *.*.*.*
ip route ***** 255.255.255.0 Tunnel0
ip route ***** 255.255.255.0 Tunnel0
ip http server
!
!
ip access-list extended odyssey
permit tcp any any established
deny tcp any any eq 135
deny tcp any any eq 137
deny tcp any any eq 138
deny tcp any any eq 139
deny tcp any any eq 445
deny tcp any any eq 593
deny tcp any any eq 1433
deny tcp any any eq 4444
deny udp any any eq netbios-ns
deny udp any any eq netbios-dgm
deny udp any any eq tftp
deny udp any any eq 135
deny udp any any eq netbios-ss
deny udp any any eq 445
deny udp any any eq 1434
permit ip any host *****
permit ip host ***** any
permit ip host ***** any
permit ip ***** 0.0.0.255 any
permit ip ***** 0.0.0.255 any
permit ip host ***** any
permit ip host ***** any
permit ip ***** 0.0.0.255 any
permit ip host ***** any
permit ip host ***** any
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static *.*.*.* 67.37.22.133
access-list 1 permit *.*.*.* 0.0.0.255
no cdp run
!
line con 0
stopbits 1
line vty 0 4
password *******
login
!
scheduler max-task-time 5000
end
The router is a Cisco 827. When I do a debug PPP and ATM errors, I get these error messages...
*Mar 1 00:01:41.735: DSL: Defect: LOS LOF LCDf LOM: retraining
*Mar 1 00:01:44.723: %LINK-3-UPDOWN: Interface ATM0, changed state to down
*Mar 1 00:01:45.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, chan
ged state to down
*Mar 1 00:01:53.063: Vi1 LCP: echo_cnt 2, sent id 3, line up
*Mar 1 00:02:03.227: %LINK-3-UPDOWN: Interface ATM0, changed state to up
*Mar 1 00:02:04.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, chan
ged state to up
So far I have only been successful stopping this problem by constantly rebooting the router. I dont know if this problem is related to the time of day or not. Also, I noticed that the router only has 368308 bytes of free memory (its the way I have it set up).
Anyways, here is the running config. Let me know if you see any reasons why my interface would be dropping. Thanks....
Current configuration : 2627 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Odyssey1
!
logging rate-limit console 10 except errors
enable secret *******
enable password *******
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip name-server *.*.*.*
ip name-server *.*.*.*
!
no ip dhcp-client network-discovery
vpdn enable
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
bridge irb
!
!
!
interface Tunnel0
ip address *.*.*.* 255.255.255.252
tunnel source Dialer1
tunnel destination *.*.*.*
!
interface Ethernet0
ip address *.*.*.* 255.255.255.0
no ip redirects
ip nat inside
ip tcp adjust-mss 1452
no ip mroute-cache
no cdp enable
!
interface ATM0
no ip address
no ip redirects
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
bridge-group 1
bridge-group 1 spanning-disabled
!
interface ATM0.1 point-to-point
no ip mroute-cache
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address *.*.*.* 255.255.255.248
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ip access-group odyssey in
ppp pap sent-username ************.net
password *******
!
ip classless
ip route 0.0.0.0 0.0.0.0 *.*.*.*
ip route ***** 255.255.255.0 Tunnel0
ip route ***** 255.255.255.0 Tunnel0
ip http server
!
!
ip access-list extended odyssey
permit tcp any any established
deny tcp any any eq 135
deny tcp any any eq 137
deny tcp any any eq 138
deny tcp any any eq 139
deny tcp any any eq 445
deny tcp any any eq 593
deny tcp any any eq 1433
deny tcp any any eq 4444
deny udp any any eq netbios-ns
deny udp any any eq netbios-dgm
deny udp any any eq tftp
deny udp any any eq 135
deny udp any any eq netbios-ss
deny udp any any eq 445
deny udp any any eq 1434
permit ip any host *****
permit ip host ***** any
permit ip host ***** any
permit ip ***** 0.0.0.255 any
permit ip ***** 0.0.0.255 any
permit ip host ***** any
permit ip host ***** any
permit ip ***** 0.0.0.255 any
permit ip host ***** any
permit ip host ***** any
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static *.*.*.* 67.37.22.133
access-list 1 permit *.*.*.* 0.0.0.255
no cdp run
!
line con 0
stopbits 1
line vty 0 4
password *******
login
!
scheduler max-task-time 5000
end