I am attaching my router configuration to connect three remote sites to one office using point to point T1 lines. Each remote site will be configured the same as router #2 so I have omitted them for the sake of brevity. I am waiting for the T1 lines so I have not had a chance to test these. Any comments would be greatly appreciated. I am using 2650 routers with 1-WIC-DSU/CSU-T1 cards at the remote sites and a 2650 router with 1-WIC-DSU/CSU-T1 and 1 VWIC-2MFT-T1 card for the main router
Main Router
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2650main
!
enable secret
enable password
!
ip subnet-zero
!
controller T1 0/1
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/2
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
!
!
interface FastEthernet0/0
ip address 172.18.1.20 255.255.255.0
ip helper-address 172.18
speed auto
half-duplex
!
interface Serial0/0
description connected to branch office
ip unnumbered FastEthernet0/0
no fair-queue
service-module t1 clock source internal
service-module t1 remote-alarm-enable
!
interface Serial0/1:0
description connected to Nap Office
ip unnumbered FastEthernet0/0
!
interface Serial0/2:0
description Connected to San Office
ip unnumbered FastEthernet0/0
!
router rip
network 172.18.0.0
network 172.19.0.0
network 172.20.0.0
network 172.21.0.0
!
ip classless
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
password
login
!
no scheduler allocate
end
2650main#
Second Router
!
version 12.2
service timestamps debug uptime
service timestamps
service password-encryption
!
hostname 2650Branch
!
enable secret
!
ip subnet-zero
!
ip domain-name aooanwot.com
ip name-server 172.18.1.1
!
interface FastEthernet0/0
description connected to branch office
ip address 172.20.1.20 255.255.255.0
ip helper-address 172.18.1.1
duplex auto
speed auto
!
interface Serial0/0
description connected to main office
ip unnumbered FastEthernet0/0
fair-queue
service-module t1 remote-alarm-enable
!
router rip
version 2
network 172.20.0.0
no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
snmp-server community public RO
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
2650Branch#
Main Router
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2650main
!
enable secret
enable password
!
ip subnet-zero
!
controller T1 0/1
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/2
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 64
!
!
!
interface FastEthernet0/0
ip address 172.18.1.20 255.255.255.0
ip helper-address 172.18
speed auto
half-duplex
!
interface Serial0/0
description connected to branch office
ip unnumbered FastEthernet0/0
no fair-queue
service-module t1 clock source internal
service-module t1 remote-alarm-enable
!
interface Serial0/1:0
description connected to Nap Office
ip unnumbered FastEthernet0/0
!
interface Serial0/2:0
description Connected to San Office
ip unnumbered FastEthernet0/0
!
router rip
network 172.18.0.0
network 172.19.0.0
network 172.20.0.0
network 172.21.0.0
!
ip classless
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
password
login
!
no scheduler allocate
end
2650main#
Second Router
!
version 12.2
service timestamps debug uptime
service timestamps
service password-encryption
!
hostname 2650Branch
!
enable secret
!
ip subnet-zero
!
ip domain-name aooanwot.com
ip name-server 172.18.1.1
!
interface FastEthernet0/0
description connected to branch office
ip address 172.20.1.20 255.255.255.0
ip helper-address 172.18.1.1
duplex auto
speed auto
!
interface Serial0/0
description connected to main office
ip unnumbered FastEthernet0/0
fair-queue
service-module t1 remote-alarm-enable
!
router rip
version 2
network 172.20.0.0
no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
snmp-server community public RO
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
2650Branch#