Could someone please check over this config for me and tell me where I’m going wrong?
This is a new configuration and I’m using a 2503 to dial up over ISDN to our head office. The router appears to connect ok, but I cannot get across from one LAN to the other.
I assume I’ve missed something, but I’m quite new to this.
Any help would be appreciated.
!
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Ossett-Mirfield-ISDN
!
enable password secret
!
no ip name-server
!
isdn switch-type basic-net3
!
ip subnet-zero
no ip domain-lookup
ip routing
!
interface Dialer 1
description connected to CorporateNetwork
ip address 10.10.1.22 255.255.0.0
no ip split-horizon
encapsulation ppp
dialer in-band
dialer idle-timeout 120
dialer string 01924489304
dialer hold-queue 10
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname administrator
ppp chap password 7 154B5E555C243F
ppp pap sent-username administrator password 7 025F510253081B
no ppp multilink
no cdp enable
!
interface Ethernet 0
no shutdown
description connected to EthernetLAN
ip address 10.30.1.1 255.255.255.0
keepalive 10
!
interface Serial 0
no description
no ip address
shutdown
!
interface Serial 1
no description
no ip address
shutdown
!
interface BRI 0
no shutdown
description connected to CorporateNetwork
no ip address
dialer rotary-group 1
!
! Dialer Control List 1
!
no dialer-list 1
dialer-list 1 protocol ip permit
!
router rip
version 2
network 10.0.0.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
no ip http server
no snmp-server location
no snmp-server contact
!
line console 0
exec-timeout 0 0
password secret
login
!
line vty 0 4
password secret
login
!
end
This is a new configuration and I’m using a 2503 to dial up over ISDN to our head office. The router appears to connect ok, but I cannot get across from one LAN to the other.
I assume I’ve missed something, but I’m quite new to this.
Any help would be appreciated.
!
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service tcp-small-servers
no service udp-small-servers
!
hostname Ossett-Mirfield-ISDN
!
enable password secret
!
no ip name-server
!
isdn switch-type basic-net3
!
ip subnet-zero
no ip domain-lookup
ip routing
!
interface Dialer 1
description connected to CorporateNetwork
ip address 10.10.1.22 255.255.0.0
no ip split-horizon
encapsulation ppp
dialer in-band
dialer idle-timeout 120
dialer string 01924489304
dialer hold-queue 10
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname administrator
ppp chap password 7 154B5E555C243F
ppp pap sent-username administrator password 7 025F510253081B
no ppp multilink
no cdp enable
!
interface Ethernet 0
no shutdown
description connected to EthernetLAN
ip address 10.30.1.1 255.255.255.0
keepalive 10
!
interface Serial 0
no description
no ip address
shutdown
!
interface Serial 1
no description
no ip address
shutdown
!
interface BRI 0
no shutdown
description connected to CorporateNetwork
no ip address
dialer rotary-group 1
!
! Dialer Control List 1
!
no dialer-list 1
dialer-list 1 protocol ip permit
!
router rip
version 2
network 10.0.0.0
passive-interface Dialer 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Dialer 1
no ip http server
no snmp-server location
no snmp-server contact
!
line console 0
exec-timeout 0 0
password secret
login
!
line vty 0 4
password secret
login
!
end