If you are running AIX 4.3.3 you could also try 'topas' or 'nmon' both are excellent tools for monitoring the system - and both have switches to check top processes.
And both are standard products....
Very quickly - I created a data file called x which contains
FIELD1 123.45- 123
abdc 12.45 123
abcd 1.20- 123
I created the following file called x.sh
while read -r f1 f2 f3
do
echo $f1"\t\c"
LENGTH=`expr $f2 : ".*"`...
can you do an 'id' instead of whoami, and check root is part of the sys group
I guess that you are not using ACL's
have you logged in as root - or su'd -
try doing an ls -lb to display any strange characters in a filename
This normally occurs when there are files still in the directory - perhaps a hidden . file
From the parent directory enter rm -fr <directoryname> and this will delete the contents of the directory as well
Take great care with this, but thats the way i'd do it
John
OK - here's the next challange, I rebooted the server again
stopped everything from autostarting and ran a mksysb. It used 6.5 Gb of memory and didnt release it again when it finished.
When I check svmon it's pinning a number of files into memory for no apparent reason - these are all largeish...
raylin
When connecting to your database try doing an :
sqlplus ' / as sysdba '
which implicitly connects to the database an removes the need to connect internal
BTW - my loadext returns the same as your's
if you do a lsattr -E -l aio0 , what do you get
Raylin,
Thanks very much for you're help - this is what I would expect - unfortunately this does not reflect what is happenning on our box - it only returns the SGA ( about 300 Mb )
Is there any change you could details your vmtune / schedtune details.
Do you use asynchronous i/o ?
Can you...
I've seen this before on a HACMP Cluster - for the port that's monitoring the heartbeat.
There's some documentation relating the the tty settings I think the parameter is IMAXBEL - which ignores overflows
have a look at stty
So if you stop your application, does the value in the FRE column return to a reasonable level - IE does it free more than just the Oracle SGA.
If you then do a svmon again - have you still got these areas of memory still allocated - we have !!
Thanks for your help with this - it is most useful
The P680 is a 64Bit machine, but the kernel is 32bit and uses kernel extensions.
We have installed both 32bit and 64bit 8.1.7 Oracle to try to resolve this issue and the only difference is that the 32bit uses the memory slower than the 64bit - but the end game is the same - it holds onto the...
I'm currently investigating a problem with a P680 ( 6 way / 8Gb RAM ) running Oracle ( 8.1.7 ), and AIX (4.3.3 Maint Level 8 ), which does not appear to be managing its memory correctly - it appears to be holding large amounts of data in memory even if Oracle and its associated applications are...
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.