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Order TSM uses to determine Error log location

ADSM/TSM Troubleshooting Tips

Order TSM uses to determine Error log location

by  LED888  Posted    (Edited  )
TechDoc: 1245225
Order TSM uses to determine Error log location
http://www-01.ibm.com/support/docview.wss?uid=swg21245225

Question
There are a number of ways to specify where the TSM client error log is located, and what it is named. What is the order used in determining which error log the TSM client creates or updates?

Cause
The TSM client has a few methods for controlling the location and filename of the file commonly called "dsmerror.log". In which order does the TSM client decide where to log its error behavior?

Answer
According to the TSM Problem Determination Guide, the following order is used:

"If the log does not exist, it will be created with default permissions

1) The name and the directory specified by the ERRORLOGNAME option in the dsm.opt or dsm.sys will be used

2) If the option is absent, the name dsmerror.log in the directory specified in the DSM_LOG environment variable, if present, will be used.

3) Otherwise, the name dsmerror.log in the current working directory will be used.

"Because default permissions are used, a log created by the root user may not be writable by any other user. If this is the case, the root user must set the proper permissions or ACLs to allow free use of the TSM application by all users who need it.

"If the log is successfully created, an error-free session will leave a zero-length (empty) log file.

"The client does not attempt to create logs in the root directory. ANS1398E is displayed when the method in rule 1 directs the log file to be created in the root directory.

"If a log file exists and can be located using the method in rule 1, it will be used (and it can be in the root directory if you choose). Furthermore, whatever permissions you give that log file will be preserved by TSM code."

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The last two paragraphs above may seem contradictory, but actually are not. An existing log file in the root directory can be written to, but if it does not already exist then method 1 will not actually create the file. If you wish to use method 1 to point to a log file in the root directory, use the 'touch' command to create a new file with that name in the root directory, thereby allowing the client to update the already-created file.

For more information on this and other methods of ensuring that behavioral information is properly logged to known locations, see the TSM Problem Determination Guide.

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