×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Disk and filesystem management

Get MPIO to work with Hitachi (HP XP) SAN by mrn
Posted: 24 Aug 06

Struggled with this for a while, but here's how I setup MPIO with a HP XP 12000 (Hitachi SAN)

odmget -qattribute=mpio_model_map PdAt > /tmp/odm.orig

cp /tmp/odm.orig /tmp/odm.modif

vi /tmp/odm.modif

change all occurances of HITACHI to HP<><><><><> where <> is a space

1,$s/HITACHI/HP     /g
wq

odmadd /tmp/odm.modif

cfgmgr

if you already have disks showing remove and re-run cfgmgr.

lsdev -l hdisk* > /tmp/disks

edit /tmp/disks and remove internal disks from file (hdisk0,1...)

for i in `cat /tmp/disks` ; do
rmdev -l $i -d
done


This method doesn't support load balancing (you'll have to get a copy of HDLM to do that)
Hope this helps

Back to IBM: AIX FAQ Index
Back to IBM: AIX Forum

My Archive

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close