INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Problems connecting to SQLBase using SQLTalk

Problems connecting to SQLBase using SQLTalk

(OP)
Hey there.
We're using at our company SQLBase Server 7.5.1. It has just one, yet huge database, which is designed to work with specialised software we get from public health department.
I've been trying to connect to this database using SQLTalk, because we need some reports on patients that are not included in software.
The configuration in sql.ini is:

[dbnt5sv]
servername=START,sqlapipe,sqlws32
cache=8000
sortcache=4000
readonly=1
oracleouterjoin=0
logfileprealloc=0
partitions=0
optimizerlevel=2
locktimeout=275
centurydefaultmode=0
password=ourpassword
dbdir=C:\CENTURA\DATA
tempdir=C:\CENTURA\TEMP
country=poland
dbname=RUMKAT,sqlapipe,sqlws32

I sniffed login data using the Ethereal, what I got is:
.......RUMKAT/C7340119/LOOGJLDPIHHICILK............
RUMKAT is the name of our DB, C7340119 is user name, so I guess LOOGJ* is the password.

Having all that, I tried to connect to the database:
connect RUMKAT C7340119/LOOGJLDPIHHICILK;
Error: Invalid password

Any ideas on what might be wrong ? Maybe the password in [dbnt5sv] sql.ini's section has something to do with it ?
Hope you think of something :)

Cheers

RE: Problems connecting to SQLBase using SQLTalk

Paskuda

Usually you can connect to Sqlbase as SYSADM/SYSADM if all else fails. Try that. Alternatively, you may need to try: 'Set server  START' before the connect.  Or try commenting out the password entry in sql.ini temorarily (Restart Sqltalk afterwards ). It maybe that LOOGJLDPIHHICILK is the encrypted version.Otherwise find a different user to connect as.

RE: Problems connecting to SQLBase using SQLTalk

(OP)
Steve,

Thanks for help. I found a way to bypass this problem by exporting reports generated by our software into xls files and then using small program I've written to insert them in my firebird DB.

And I didn't manage to connect to SQLBase anyway I'm not the one who installed it, he's not working here anymore, and he didn't leave any passwords/configuration info. Data security at it's best

Thanks again,
Michael

RE: Problems connecting to SQLBase using SQLTalk

The setting password= in the sql.ini is not the password for your database user connect. It represents the global password for the server connect. So, if you want to do a 'SET SERVER.... ' you need to do it with this password.
e.g. in your case:  SET SERVER START/OURPASSWORD

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close