Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

pickletech (IS/IT--Management) (OP)
5 Jan 05 14:45
Hello everyone, I currently have a VMS/VAX (7.1, I believe) system and need to change its IP address. The users here mostly telnet into it, and we need to change our IP ranges. I know how to get around in the VAX, but I am nowhere near proficient. I know it is something in UCX, but not sure. Any help would be appreciated.
BobGezelter (Programmer)
5 Jan 05 23:27
pickletech,

The easiest way is to reconfigure the TCP/IP configuration using the supplied command file in SYS$MANAGER:TCPIP$CONFIG.COM.

You need to do this from a management account, with privileges enabled. You will find it under "Core Environment", submenu "Interfaces".

You will then need to restart TCP. Obviously, in general it is a good idea to run this session from a LAT, DECnet, or direct terminal connection (restarting TCPIP can be done without re-booting the machine, but you cannot be on a TCP connection while doing it).

- Bob

Robert "Bob" Gezelter, http://www.rlgsc.com

pickletech (IS/IT--Management) (OP)
7 Jan 05 13:11
Bob,

Apparently I can't get around as well as I thought. I could not find the TCPIP$CONFIG.COM file. I also did not see a "Core Environment" menu. I am logging in as SYSTEM, and using a keyer id that I believe is an administrator, once I start MENU. Thank you for your help.
BobGezelter (Programmer)
7 Jan 05 14:37
pickletech,

Ok, first things first. At the "$" prompt, do a SHOW SYSTEM command. The VMS version will display on the first line of the output.

Then, set your default directory to the system manager's directory using the command $ SET DEFAULT SYS$MANAGER

Then, do a directory command, use $ DIRECTORY *$CONFIG.COM

You should get a list of one or more files. You are interested in TCPIP$CONFIG.COM. If that is not present, check for UCX$CONFIG.COM (you could have an older version of the software).  Then run that file.

- Bob Gezelter. CSA, CSE, CDP

Robert "Bob" Gezelter, http://www.rlgsc.com

pickletech (IS/IT--Management) (OP)
7 Jan 05 15:02
Bob,
Thank you so much. I am so close now I can taste it. I do in fact have OpenVMS 7.1. I did not have a TCPIP$CONFIG.COM, but I do have UCX$CONFIG.COM. I got an error trying to run it though. Here is a "screenshot" of what I did:

HO_System ? SET DEFAULT SYS$MANAGER                                             
HO_System ? DIRECTORY *$CONFIG.COM                                              
                                                                                
Directory SYS$COMMON:[SYSMGR]                                                   
                                                                                
ATK$CONFIG.COM;1    DTSS$CONFIG.COM;1   UCX$CONFIG.COM;2                        
                                                                                
Total of 3 files.                                                               
HO_System ? RUN UCX$CONFIG.COM                                                  
%DCL-W-ACTIMAGE, error activating image UCX$CONFIG.COM                          
-CLI-E-IMGNAME, image file R1WCRG$DIA0:[SYS0.SYSCOMMON.][SYSMGR]UCX$CONFIG.COM;2
-IMGACT-F-BADHDR, an error was discovered in the image header

As you probably noticed "HO_System ?" is our command prompt. Am I using the wrong syntax? Thank you so much for your help and prompt responses.                       
BobGezelter (Programmer)
7 Jan 05 15:09
pickletech,

Ok, somebody customized the prompts, not a problem.

To run a command procedure (a .COM file; executable binaries are .EXE), use the syntax "@filename"

- Bob Gezelter, CSA, CSE, CDP

Robert "Bob" Gezelter, http://www.rlgsc.com

pickletech (IS/IT--Management) (OP)
7 Jan 05 15:18
Bob,
SWEET! I just tried it and it worked. Well I could get into the program and see what you were talking about at least, I don't have an actual terminal in front of me, I'm telnetting into it now. I will probably actually do the cut-over sometime next week. One quick question as I leave though. This shouldn't have any effect on anything except people telnetting from their desktops, right? THANK YOU SO MUCH!
BobGezelter (Programmer)
7 Jan 05 15:22
pickletech,

When you make the change, all IP connections will get disrupted. DECnet, LAT and other protocol stacks will be unaffected (hence my suggestion to use either a local console, a DECnet remote terminal, or a LAT connection when making the change).

- Bob Gezelter

Robert "Bob" Gezelter, http://www.rlgsc.com

pickletech (IS/IT--Management) (OP)
7 Jan 05 15:24
Bob,
That's what I thought, just figured it would be best to check. Thanks again.
Aaron1940 (MIS)
26 Sep 05 14:34
Hey Guys,

This thread came in handy for me, but I am stuck, I was hoping someone can help me too.  I need to chamge the IP address of this server

I have a VMS 5.5.  I did $ set def sys$manager
then in the directory all I have is cluster_config.com, netconfig.com, and syconfig.com.  I do not see anything with ucx or tcpip.  I closest assumption is the netconfig.com, but it did not have the change ip option only node.

Please help.
Aaron1940 (MIS)
26 Sep 05 14:42


I need to chamge the IP address of the DEC server

I have a VMS 5.5.  I did $ set def sys$manager
then in the directory all I have is cluster_config.com, netconfig.com, and syconfig.com.  I do not see anything with ucx or tcpip.  I closest assumption is the netconfig.com, but it did not have the change ip option only node.

Please help.
kenrbnsn (TechnicalUser)
26 Sep 05 21:37
Sounds like you don't have UCX on the machine, you might have TCPware or Multinet. Do a

$ sho logical/sys multinet*
$ sho logical/sys tcpware*

and see if you get anything back.

Also, my may want to post on the newsgroup comp.os.vms

If you don't know what a newsgroup is, go to <http://groups.google.com/group/comp.os.vms>

Ken

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close