Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

ErrolDC (MIS) (OP)
27 Nov 04 18:13
Hi folks. I'm trying to get EIGRP up and running on my network because I need to load balance traffic between two subnets over a two un-equal cost links. Based upon some advice from this same forum, I setup a tunnel interface between my two routers which are already directly connected via a T-1. I needed the tunnel interface to form a virtual direction connection between routers over an SDSL based network. I believe I have setup EIGRP properly on both routers. The problem is that they are not learning and installing routes from each other. I was hoping to get some help. I'm not very learned with it comes to dynamic routing protocols.
Here is the relevant information for both routers. Ignore the static routes. Even with the static routes removed, the routers are still not installing the EIGRP routes over the interfaces I described in the config. I'm sure I'm missing something small or overlooking a critical detail. Any help will be much appreciated.

#### Router-A #####

interface Tunnel0
 bandwidth 8256
 ip address 192.168.254.2 255.255.255.0
 delay 2000
 keepalive 10 3
 tunnel source 192.168.192.240
 tunnel destination 192.168.168.2
!
interface FastEthernet0/0
 ip address 172.16.101.240 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation dot1Q 400
 ip address 192.168.192.240 255.255.255.0
 no cdp enable
!
interface Serial1/0
 ip address 10.222.222.1 255.255.255.0
!
router eigrp 400
 network 10.222.222.0 0.0.0.255
 network 192.168.254.0
 no auto-summary

1760-DFIS#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.192.0/24 is directly connected, FastEthernet0/0.1
     172.16.0.0/24 is subnetted, 2 subnets
S       172.16.3.0 is directly connected, Serial1/0
C       172.16.101.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.222.222.0 is directly connected, Serial1/0
C    192.168.254.0/24 is directly connected, Tunnel0
S    192.168.168.0/24 [1/0] via 192.168.192.2
1760-DFIS#sh ip eigrp interfaces
IP-EIGRP interfaces for process 400

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se1/0              1        0/0         0       0/15        1027           0
Tu0                1        0/0         0       0/10           0           0
1760-DFIS#sh ip eigrp traffic
IP-EIGRP Traffic Statistics for AS 400
  Hellos sent/received: 35405/35399
  Updates sent/received: 12/15
  Queries sent/received: 1/0
  Replies sent/received: 0/1
  Acks sent/received: 7/4
  Input queue high water mark 2, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
  Hello Process ID: 76
  PDM Process ID: 75

1760-DFIS#sh ip eigrp toplogy
                         ^
% Invalid input detected at '^' marker.

1760-DFIS#sh ip eigrp topology
IP-EIGRP Topology Table for AS(400)/ID(192.168.254.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.222.222.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/0
P 192.168.254.0/24, 1 successors, FD is 822016
        via Connected, Tunnel0
1760-DFIS#sh ip eigrp topology 10.222.222.0 255.255.255.0
IP-EIGRP (AS 400): Topology entry for 10.222.222.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
  Routing Descriptor Blocks:
  0.0.0.0 (Serial1/0), from Connected, Send flag is 0x0
      Composite metric is (2169856/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 20000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  192.168.254.240 (Tunnel0), from 192.168.254.240, Send flag is 0x0
      Composite metric is (2681856/2169856), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 40000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1476
        Hop count is 1
1760-DFIS#sh ip eigrp neighbors
IP-EIGRP neighbors for process 400
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.222.222.2            Se1/0             14 16:49:47    1  4500  0  8
0   192.168.254.240         Tu0               10 16:49:48    1  4500  0  9



#### Router-B ####
interface Tunnel0
 bandwidth 8256
 ip address 192.168.254.240 255.255.255.0
 delay 2000
 keepalive 10 3
 tunnel source 192.168.168.2
 tunnel destination 192.168.192.240
!
interface FastEthernet0/0
 ip address 172.16.3.2 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation dot1Q 400
 ip address 192.168.168.2 255.255.255.0
!
interface Serial0/0
 ip address 10.222.222.2 255.255.255.0
!
router eigrp 400
 network 10.222.222.0 0.0.0.255
 network 192.168.254.0
 no auto-summary

DFIN-1760#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.192.0/24 [1/0] via 192.168.168.6
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.3.0 is directly connected, FastEthernet0/0
S       172.16.101.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.222.222.0 is directly connected, Serial0/0
C    192.168.254.0/24 is directly connected, Tunnel0
C    192.168.168.0/24 is directly connected, FastEthernet0/0.1

DFIN-1760#sh ip eigrp topology
IP-EIGRP Topology Table for AS(400)/ID(192.168.254.240)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.222.222.0/24, 1 successors, FD is 2169856
        via Connected, Serial0/0
P 192.168.254.0/24, 1 successors, FD is 822016
        via Connected, Tunnel0
DFIN-1760#sh ip eigrp interfaces
IP-EIGRP interfaces for process 400

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0         0       0/15          50           0
Tu0                1        0/0       909       0/10          50           0
DFIN-1760#sh ip eigrp traffic
IP-EIGRP Traffic Statistics for AS 400
  Hellos sent/received: 35379/35369
  Updates sent/received: 15/12
  Queries sent/received: 0/1
  Replies sent/received: 1/0
  Acks sent/received: 4/7
  Input queue high water mark 2, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
  Hello Process ID: 75
  PDM Process ID: 74

DFIN-1760#sh ip eigrp topology 10.222.222.0 255.255.255.0
IP-EIGRP (AS 400): Topology entry for 10.222.222.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
  Routing Descriptor Blocks:
  0.0.0.0 (Serial0/0), from Connected, Send flag is 0x0
      Composite metric is (2169856/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 20000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
  192.168.254.2 (Tunnel0), from 192.168.254.2, Send flag is 0x0
      Composite metric is (2681856/2169856), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 40000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1476
        Hop count is 1
DFIN-1760#sh ip eigrp neighbors
IP-EIGRP neighbors for process 400
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.254.2           Tu0               11 16:50:47  909  5000  0  8
0   10.222.222.1            Se0/0             12 16:50:47    1  3000  0  9
ErrolDC (MIS) (OP)
27 Nov 04 19:40
Okay, after this post.. I got a revelation. I changed all the direct connect interfaces to the same classfull subnet. Then I deleted the static routes and the routing updates worked. I'm confused. Why did the interfaces have to be in the same Class B?

#### Router-A ###

interface Tunnel0
 bandwidth 8256
 ip address 172.16.254.1 255.255.255.0
 delay 2000
 keepalive 10 3
 tunnel source 192.168.192.240
 tunnel destination 192.168.168.2
!
interface FastEthernet0/0
 ip address 172.16.101.240 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation dot1Q 400
 ip address 192.168.192.240 255.255.255.0
 no cdp enable
!
interface Serial1/0
 ip address 172.16.222.1 255.255.255.0
!
router eigrp 10
 variance 2
 passive-interface FastEthernet0/0
 network 172.16.0.0
 auto-summary

1760-DFIS#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.192.0/24 is directly connected, FastEthernet0/0.1
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.254.0 is directly connected, Tunnel0
C       172.16.222.0 is directly connected, Serial1/0
D       172.16.3.0 [90/824576] via 172.16.254.2, 00:18:52, Tunnel0
C       172.16.101.0 is directly connected, FastEthernet0/0
S    192.168.168.0/24 [1/0] via 192.168.192.2

1760-DFIS#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.254.2            Tu0               10 00:19:41    8   200  0  4
0   172.16.222.2            Se1/0             14 00:19:41    8   200  0  5
1760-DFIS#sh ip eigrp interfaces
IP-EIGRP interfaces for process 10

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se1/0              1        0/0         8       0/15          50           0
Tu0                1        0/0         8       0/10          50           0
1760-DFIS#sh ip eigrp topology 172.16.3.0 255.255.255.0
IP-EIGRP (AS 10): Topology entry for 172.16.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 824576
  Routing Descriptor Blocks:
  172.16.254.2 (Tunnel0), from 172.16.254.2, Send flag is 0x0
      Composite metric is (824576/28160), Route is Internal
      Vector metric:
        Minimum bandwidth is 8257 Kbit
        Total delay is 20100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1476
        Hop count is 1
  172.16.222.2 (Serial1/0), from 172.16.222.2, Send flag is 0x0
      Composite metric is (2172416/28160), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 20100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

#### Router-B ####

interface Tunnel0
 bandwidth 8256
 ip address 172.16.254.2 255.255.255.0
 delay 2000
 keepalive 10 3
 tunnel source 192.168.168.2
 tunnel destination 192.168.192.240
!
interface FastEthernet0/0
 ip address 172.16.3.2 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation dot1Q 400
 ip address 192.168.168.2 255.255.255.0
!
interface Serial0/0
 ip address 172.16.222.2 255.255.255.0
!
router eigrp 10
 variance 2
 passive-interface FastEthernet0/0
 network 172.16.0.0
 auto-summary

DFIN-1760#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

S    192.168.192.0/24 [1/0] via 192.168.168.6
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.254.0 is directly connected, Tunnel0
C       172.16.222.0 is directly connected, Serial0/0
C       172.16.3.0 is directly connected, FastEthernet0/0
D       172.16.101.0 [90/824576] via 172.16.254.1, 00:21:32, Tunnel0
C    192.168.168.0/24 is directly connected, FastEthernet0/0.1
DFIN-1760#sh ip eigrp interfaces
IP-EIGRP interfaces for process 10

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0       149       0/15         751           0
Tu0                1        0/0       681       0/10        3406           0
DFIN-1760#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   172.16.222.1            Se0/0             14 00:21:46  149   894  0  4
0   172.16.254.1            Tu0               10 00:21:47  681  4086  0  3
DFIN-1760#sh ip eigrp topology 172.16.101.0 255.255.255.0
IP-EIGRP (AS 10): Topology entry for 172.16.101.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 824576
  Routing Descriptor Blocks:
  172.16.254.1 (Tunnel0), from 172.16.254.1, Send flag is 0x0
      Composite metric is (824576/28160), Route is Internal
      Vector metric:
        Minimum bandwidth is 8257 Kbit
        Total delay is 20100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1476
        Hop count is 1
  172.16.222.1 (Serial0/0), from 172.16.222.1, Send flag is 0x0
      Composite metric is (2172416/28160), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 20100 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1


One other thing, is failover automatic between both paths now? Or is there something else I need to configure?
Thanks!

Errol


Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close