Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

jatkinson (TechnicalUser) (OP)
20 Sep 04 8:05
I've done everything I can think of, looked through loads of forums and googled for hours but I cannot find a solution to my problem.

A few weeks ago I noticed I could no longer access shared drives on an XP workstation in my 2k domain.  I investigated a found I couldn't even get the workstation trough My Network Places although it is listed.

I can't even ping the workstation via it's name OR by IP address.  I can however ping othere workstations and servers from the XP workstation.

I have checked all DNS settings.
I have checked domain membership for the workstation
I have checked DHCP
I have checked TCP/IP/WINS/NetBIOS settings
The XP firewall is off
There is a software firewall on the workstation but it has been disabled.  It was previously set to allow ICMP packets though.
The workstation is patched completely up to date and has been thoroughly virus scanned.

I'm sure the fact I cannot ping nor access the workstation through My Network Places are related but I don't know what else to try.

I've checked routing tables, used tracert, pathping, nbtstat etc and I can't seen anything out of the ordinary.

Anybody any ideas?

Regards

jatkinson
Helpful Member!  bcastner (IS/IT--Management)
20 Sep 04 8:29
Have you tried replacing the ethernet board?

Can the XP workstation:

. ping anyone else by name?
. ping anyone else by IP?
. ping 127.0.0.1?

You may be helped by the discussion in FAQ779-4625
Helpful Member!(2)  jatkinson (TechnicalUser) (OP)
20 Sep 04 9:22
I haven't tried replacing the ethernet board yet, I was hoping to eliminate all things software related before tackling hardware.

I'll check out the discussion, thanks for the link.

For info, the XP workstation can ping by name and by IP itself and all other machines on the domain.

Cheers
MALICKA (Programmer)
20 Sep 04 23:18
you Using Winxp pro or Home .
Create a user profile in win2k domain
use the same user account detail in your workstaion & try.

-Mal

linney (TechnicalUser)
21 Sep 04 0:58
Just an idea to help you discover whether it is a software or hardware problem.

http://www.nu2.nu/pebuilder/#intro
jatkinson (TechnicalUser) (OP)
21 Sep 04 4:23
Hi

Mal

It is XP Pro, I've tried my account as well as the admin account for the domain.

Linney

I'll check out the link and post back

Cheers

bcastner (IS/IT--Management)
21 Sep 04 6:48
Remove the computer account from the Domain.  Wait thirty minutes.  Re-add the account.
jatkinson (TechnicalUser) (OP)
21 Sep 04 7:09
I've removed the computer several times.  I've also removed it then purged all records of it in WINS/DNS and AD.  I've left it in a workgroup overnight and then added it back to the domain the following morning and still the same!
bcastner (IS/IT--Management)
21 Sep 04 7:18
Look for 'hidden' firewalls, as this is most certainly a firewall issue.  PC-Illan antivirus, for example, would lead to this issue with its hidden firewall component.  There are other AV programs that also include a firwall component.

Check that ICF is not enabled, the native XP firewall.
jatkinson (TechnicalUser) (OP)
21 Sep 04 7:28
ICF is not enabled.  I run McAfee AV 7.1 on all my machines.  All same version, all patched to same level.  I'll double-check it though.
bcastner (IS/IT--Management)
21 Sep 04 7:38
"There is a software firewall on the workstation but it has been disabled.  It was previously set to allow ICMP packets though."

Try an uninstall.  Zone Alarm, Norton and Sygate (three I know of with the behavior) if disabled an not uninstalled will do this.

bcastner (IS/IT--Management)
21 Sep 04 7:39
"There is a software firewall on the workstation but it has been disabled.  It was previously set to allow ICMP packets though."

Try an uninstall.  Zone Alarm, Norton and Sygate (three I know of with the behavior) if disabled an not uninstalled will do this.

If after all of that it will not return ICMP requests, swap a known working good ethernet adapter in and test.
jatkinson (TechnicalUser) (OP)
21 Sep 04 7:52
Hi bcastner

Thanks for your help on this.  I was wondering when I was going to have to bite the bullet and resign myself to these last 2 tasks.  Fingers crossed it's the firewall (Kerio)that's being the pain!

I'll report back on any progress

Cheers
jatkinson (TechnicalUser) (OP)
25 Sep 04 15:27
OK, it's definately odd this!!!

I've completely removed the firewall and that didn't solve it.

I've also added a wlan card and given it an IP address and I can't ping that from another machine either.  So could it be something configured on XP that's causing it?

Cheers
bcastner (IS/IT--Management)
25 Sep 04 16:56
What is a "wlan" card?  A wireless lan adapter?

See FAQ779-4625

. Use the WinsockFix utility
. See the last paragraph of the FAQ.  Use the last link there to rebuild the TCP/IP service stack.
marc91215 (IS/IT--Management)
26 Sep 04 1:23
your having web issues also with this machine?
jatkinson (TechnicalUser) (OP)
26 Sep 04 13:56
I hadn't up until recently had any problems with the machine.  I just started to note odd things which lead me to discover the problems with not being able to access it via My Network Places and not being able to ping it.

Recently though it is taking an age to load the profile when logging into it, so maybe this is related too.

bcastner, yes sorry, I meant wireless lan adapter by wlan card.

I'll have a go at rebuilding the TCP/IP service stack and report back.

Cheers
bcastner (IS/IT--Management)
26 Sep 04 14:35
If using WEP, redo the key.  It is not unheard of WEP key to become corrupted as stored by the adapter driver.
jatkinson (TechnicalUser) (OP)
5 Oct 04 4:34
I've ran throught the winsock FAQ and applied the fix.  The PC is now connecting to other machines fine again, however I still cannot ping it nor access it from My Network Places on another device.

I have tried to ping the address for the LAN card and the wireless LAN card and neither replies so I'm assuming there has to be something at a lower level that is causing both cards to react in the same way.

bcastner (IS/IT--Management)
5 Oct 04 4:54
There is something blocking ICMP traffic (ping responses) and Netbios traffic.  It is either in the router settings or the remnents of firewall software on that PC.

Is your router set to block broadcast messages, or has a firewall component, or a denial of service blocking feature?  

If McAfee is still being used, is it set to allow Netbios and ICMP traffic through on your LAN subnet in both directions?

It is a firewall component either in the router or the PC.
bcastner (IS/IT--Management)
5 Oct 04 4:58

Quote:

however I still cannot ping it nor access it from My Network Places on another device.

. Does it appear in Network Neighborhood on itself?
. Does it appear in Network Neighborhood on others?

Check that the Domain name is correct, and that Netbios over TCP/IP is enabled under TCP/IP Properties, Advanced, WINS tab.

If it appears, what error message do you receive when you try to access its shares?

If you look in the Event Viewer on the problem workstation, is there anything network related shown as an error?  Similarly, on the server, is there anything in Event Viewer?
jatkinson (TechnicalUser) (OP)
5 Oct 04 5:16
Yes to both questions.

I've checked and double-checked domain name, even removing the machine into it's own workgroup before adding it back to the domain.  Netbios over TCP/IP is enabled

Error:
----------------------------------------
\\MACHINE is not accesible.  You might not have permission to use this network resource. Contact the administrator............

The network path was not found.
----------------------------------------

I figure the most important bit of this error is the "The network path was not found" as this seems to tie into the fact I cannot ping the machine.  I've checked DNS and WINS settings too and the machine is listed in DNS with the correct name and IP address.

I can't see any errors in the server logs.  However I'm at a remote site at present so cannot access the workstation to check it's Event Viewer.

jatkinson (TechnicalUser) (OP)
5 Oct 04 5:21
With regard to the router and firewall etc post.

There is no firewall on the XP workstation any more so it would have to be a remnant setting.  Not sure where to start there so will have to do some further investigating.

It could be down to the router but I discounted this as I cannot see anything in it's settings to do this and indeed the other devices on the LAN are connected via the 4-port switch built into the router so I'd assume that I wouldn't be able to ping anything else that was connected.
bcastner (IS/IT--Management)
5 Oct 04 10:46
. Is the Computer Browser service started?  It should be.  Start, Run, services.msc to check.

. Is Netbios over TCP/IP enabled in the Advanced, WINS tab, property sheet for all Workstations?  Do not use the Default setting here, explicitly enable the setting.

. For the results from IPCONFIG /all for the problem machine, what is the value for "Node Type"?
jatkinson (TechnicalUser) (OP)
6 Oct 04 4:12
1. Yes the computer browser service is started.
2. Netbios is configured as per your post
3. I can't recall, I'll check when I return home.

Thanks again for your continued help
jatkinson (TechnicalUser) (OP)
6 Oct 04 13:41
To confirm, the Node Type is set to Hybrid.

Cheers
bcastner (IS/IT--Management)
6 Oct 04 13:54
Your node type is fine then.

Try:  http://www.michna.com/kb/wxnet.htm
jatkinson (TechnicalUser) (OP)
14 Oct 04 15:56
Followed everything through I could find relevant.  Good site by the way full of good info but I still can't trace the problem.

It's so annoying.
johnway (TechnicalUser)
15 Oct 04 9:20
I dont know if you have checked this but it maybe as simple as enabling file and printer sharing, you could also uninstall tcp/ip and reinstall and see how you get on.
jatkinson (TechnicalUser) (OP)
15 Oct 04 9:27
Hi johnway

Thanks for posting.  Unfortunately I've checked both of these.

I was going to give up and move the 2nd HDD I use for my file shares into another machine, unfortunately it's a SATA drive and the other machines only support EIDE so stuffed there too.

johnway (TechnicalUser)
15 Oct 04 9:33
you could try modifying the host file, add in static entries for the domain controller,and the file and print and other machines you want access to,its a pain in the backside but it should get you out, failing that then id say a rebuild of your O.S. is needed.
jatkinson (TechnicalUser) (OP)
16 Oct 04 7:52
I can get out to the other machines, I can't get to this one from any others which is the problem.
linney (TechnicalUser)
16 Oct 04 18:06
Did you ever try this from "way back"?

Just an idea to help you discover whether it is a software or hardware problem.

http://www.nu2.nu/pebuilder/#intro

If you can access the machine running this version of XP it would suggest a settings or software problem.  If you can't access it, it may be it is a hardware problem.

Something else along the same lines.

266465 - HOW TO: Perform a Parallel Installation of Windows 2000
http://support.microsoft.com/default.aspx?scid=kb;...

You can do the same with XP.  Don't install any unnecessary programs, just keep the parallel installation as simple as possible.




 
stewm (MIS)
17 Oct 04 15:06
Have you checked to see that all wiring in the back of your computer is the same as it was when it worked?  I noticed that some cable modem run a couple of wires and if one is disconnected the DNS servers appears to be broke.

Mark Stewart
Senior Analyst
Consultants Club Corp.
Windsor, Ontario
Canada
www.consultantsclub.biz

jatkinson (TechnicalUser) (OP)
23 Oct 04 13:48
Checked and double checked all cabling.  I'm looking to find some time to investigate Linney's links.

Thanks.

bigrig9799 (TechnicalUser)
11 Nov 04 18:07
I have to know how this turned out........this thread is awesome.  Anyone know?
bcastner (IS/IT--Management)
11 Nov 04 18:11
A dollar bet:  a firewall issue.
jatkinson (TechnicalUser) (OP)
12 Nov 04 4:00
I'd agree with you bcastner, but there is no evidence of a firewall being there anymore.

It has frustrated me so much of late I haven't done anything further with it.  Hopefully I'll be able to carry on the 'fight' this weekend.

confused123 (TechnicalUser)
14 Nov 04 6:16
Thank you guys . I just registered today and have the exactly the same problem as jatkinson. Only grace, I know how this problem started. I have 4 laptops(A,B,C,D all with windows XP home) connected to a switch(no router) sharing broadband through A. All worked fine until I removed one Laptop(C), connected another laptop(E) in place , ran the XP home network setup wizard on E and tried to transfer files.

That didnt work.After a bit of fight,I replaced laptop C again. And thats the point I started getting exactly the SAME problem as JATKINSON on C and havent resolved it as yet since a month.

Hope this information can help troubleshoot.
jatkinson (TechnicalUser) (OP)
2 Dec 04 16:34
Seems I may owe you a dollar afterall bcastner!!

Having struggled with this problem for ages I had given up.  That is until I tried to use the Cisco VPN Client to connect into the office and realised that it had become corrupt and needed re-installing. I then thought, you guessed it Cisco VPN Firewall !!

I couldn't uninstall Cisco VPN software for some reason until I had removed the hardware from device manager.  After removing the softare and rebooting I checked Network Places on my other machines and I can now access the XP workstation shares again!!!!

Other than a .NET framework SP1 update I ran just before I haven't done anything to the workstation other than remove the Cisco VPN client, so I'm happy to conclude that this was causing the problem all along.

That is unless someone can categorically suggest otherwise

Thanks again

jatkinson
bcastner (IS/IT--Management)
2 Dec 04 16:39
Give the dollar to your favorite Christmas charity.

Bill
jatkinson (TechnicalUser) (OP)
2 Dec 04 17:09
Why not! good idea.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close