INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Minimize SQLBASE on restart

Minimize SQLBASE on restart

(OP)
I use veritas backup exec with the command to stop centura sqlbase before the backup and restart after the backup, when it restarts, the window is displayed on the desktop, how can I have it restart the service and be minimized? Thank you

RE: Minimize SQLBASE on restart

If you use sqlbase 8.x you can find in the server sql.ini file a section [dbnt1sv.gui]
in the entry
MAINWIN=MIN,267,208,757,560

you can set with
MAINWIN=MIN  ( minimized window )
MAINWIN=MAX  ( maximized window )

or do you mean that the sqlbase window should be hidden ( no console )?

Oliver

RE: Minimize SQLBASE on restart

(OP)
I'm using sqlbase 7.5.1. I looked in the sql.ini and there is no dbnt1sv.gui section and no place where mainwin exists. I was mainly interested in having the thing start minimized, but if it can be started hidden (no console) that would be even better. Thanks

RE: Minimize SQLBASE on restart

Try to use the SILENTMODE keyword in sql.ini:

silentmode
Turns the display for a multi-user server on and off.
Warning: If you turn off the server display, there will be no visible window and you cannot
shut down the server with Windows Task Manager. The only way you can shut down the server
is through SQLTalk or the SQLBase API.
This keyword is optional. Configure this keyword in any server section of SQL.INI.
Default value By default, multi-user server displays are on (0).
Example To set the display of the server screens off, specify:
silentmode=1

Oliver

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close