INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

info about Btrieve

info about Btrieve

(OP)
Hi,

I've been asked to find out some info about Btrieve, we don't use it at all (we use MySql) but some of our customers use it and so we will soon need it. Can someone tell me where to get info for beginners, does it work with Java? or anything like links?

Many thanks
vero

RE: info about Btrieve

Depending on the version you're using, Java is a supported platform. With Pervasive.SQL V8, you can use JDBC or JCL (which is a native Btrieve like interface).
FOr more information about Btrieve/Pervasive, you might check out www.pervasive.com

info@mirtheil.com
Custom VB and Btrieve development.
Certified Pervasive Developer
Certified Pervasive Technician

RE: info about Btrieve

(OP)
Pervasive is a successor to the btrieve databases. Sadly those drivers
only work on v8 ... while we need v6?

RE: info about Btrieve

You really should upgrade.  Btrieve 6.15 was last supported in 1999.  There have been three (3) major relases since v6.15 (currently v8.5). Pervasive is just the current version of Btrieve with extra bells and whistles added.  
6.15 also is limited to Win16, WIn32, DOS, and NetWare.  V8 also supports Linux as a client and server.

Mirtheil
Certified Pervasive Developer
Certified Pervasive Technician
Custom VB and Btrieve development.
http://www.mirtheil.com

RE: info about Btrieve

(OP)
Hi Mirtheil, thanks for all your advices.

It's not possible for us to upgrade as the data in question is embedded by another vendor (Primavera - P3).

Any other ideas? i.e where can I find some useful info for our situation?

Cheers
vero

RE: info about Btrieve

In terms of using Java, Btrieve 6.15 didn't support it. It only supported Win16, DOS, Win32, NLM and OS/2 interfaces.  
Ask Primavera why they don't support newer versions of Pervasive/Btrieve.  
The Pervasive web site is a good source of general information.  All of the Btrieve information applies to 6.15 and newer.  Only things like ODBC, JDBC, JCL, ActiveX, PDAC, and OLEDB are version specific.

Mirtheil
Certified Pervasive Developer
Certified Pervasive Technician
Custom VB and Btrieve development.
http://www.mirtheil.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close