Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

xerox999 (TechnicalUser) (OP)
8 Jun 04 12:39
Hi,

I am trying to access one of my machines on XP via remote desktop. I have a wireless 54G Belkin router and a couple of machines attached to it. I am unable to Remote into them as they have internal IP addresses. I placed the machine on the DMZ for access but this does not work either. Is there any way for me to connect to the machine from outside, internaly i have no problems.

Many Thanks in advance
Helpful Member!  smah (MIS)
8 Jun 04 17:34
Belkin calls the feature that you need 'virtual server'.  http://web.belkin.com/support/kb/kb.asp?a=1426  Nearly everyone else calls it port forwarding.  You need to forward port 3389 to the internal, private IP address of the machine that you want to connect to.
xerox999 (TechnicalUser) (OP)
8 Jun 04 20:10
smah, thanks for your help. I have already added the port but stil no joy, any other ideas?

Thanks
bcastner (IS/IT--Management)
9 Jun 04 14:46
The "couple of machines" bothers me.  You need to create port forwards, add unique addresses for each Host machine, and use a full IP:port number specification for each unique host.

See:  http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&threadm=%23Ak75o3MCHA.1996%40tkmsftngp12&rnum=2&prev=/groups%3Fq%3Drd%2Blinksys%2Bmultiple%26ie%3DUTF-8%26hl%3Den
xerox999 (TechnicalUser) (OP)
10 Jun 04 3:58
Thanks for your help. A couple of machine are on the router. I done a port forward for the machine i want access to but still no joy..
Helpful Member!  AcquisitiveOne (TechnicalUser)
11 Jun 04 12:23
If you are connecting externally over the internet be sure you are using the IP address of the WAN side of the router when using the Remote Desktop Connection Software (When connecting from the Remote Machine use the External IP address not the computer name like you would on the internal side).  Also if you are using a cable modem/dsl remember that your External WAN IP address might change often.  How do you remote desktop to the computer when on the internal LAN?  If its by computer name you will not be able to do this from the outside.  You must first make the connection to the router using its WAN IP address.  From there your router will look at the port number the application is using (in this case port 3389) and if it has port forwarding information it will forward it to the IP address listed in its table.  Be sure that the IP address for the Computer that you are trying to remote desktop to has a static IP address.  If it it using DHCP its IP address might change and therefore the port forward in the table will no longer be valid.  Please let me know if this helps.

Acquisitive_One
MCSA, A+

Acquisitive - 1. Characterized by a strong desire to gain and possess. 2. Tending to acquire and retain ideas or information :)

xerox999 (TechnicalUser) (OP)
14 Jun 04 4:27
Thanks for the help. I am accessing the machine via RDP client over the internet. I am using the WAN IP to connect to. I have forwarded port 3389 to the approciate machine. It is currently set to DHCP maybe thats what it could be, but each time I check the IP address it alaways assigns the same one, hence i forwared 3389 to that IP, are there any other ports that I need to forward?

Thanks
smah (MIS)
14 Jun 04 10:24
This shouldn't have any effect, but try turning off the 'block ping' function of your router.
lamarw (MIS)
14 Jun 04 19:54
Is there a possibility that the client behind the router is DHCP'ong the router winding up with a different IP each time? The DHCP port forwarding table will always show the port 3389 forwarded to the ip address of, say,192.168.1.200 but if the machine is DHCP'ing every time it is booted it may oir maynot get the IP address it once had. Have you static'ed the IP yet?
jaapski (MIS)
14 Jul 04 17:22
Hi I'm new here, but I have exact the same problem with also a 54G Belkin router. I've checked and done the same things you suggest, but still no joy.
I've tried running the webserver on the machine i want to remote desktop into and that works fine over the internet. In the virtual server I have enabled the windows 2000 terminal server.
I also trief Ping blocking and DMZ. Form the local network the remote desktop works ok.
The automatic check for firmware updates says there are no firmware updates.

I'm running out of options to try, any help would be nice.

btw I don't know what MIS stands for.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close