Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

joerdg (MIS) (OP)
19 May 04 11:51
hello,

I have a windows XP pro machine (sp1a) that is missing the workstation service.  I am unable to view shares or create shares with other computers.  I go to services in the control panel and I look through the list and the workstation service is no where to be found.  Is there any way to recreate this?  I have tried reinstalling the service pack but the workstation service is still missing.  Has anyone else run into something like this?  Any help would be greatly appreciated.

Thanks,

Joe









Helpful Member!  jrbarnett (Programmer)
19 May 04 12:31
The workstation service is the Client for Microsoft networks. Try installing it from the Local Area Network connection properties.

John
joerdg (MIS) (OP)
19 May 04 22:12
John,

Thanks for the tip, it solved my problem.  For some reason the client for microsoft networks wasn't installed.  Really weird.  This machine was on a domain when I configured it and then it was sent off to a remote office.  Not sure how it ended up uninstalled.

Thanks again.
Helpful Member!(2)  bcastner (IS/IT--Management)
19 May 04 22:26
Odd.

I can see reasons for the Server service not to be installed, but not the Workstation service.

A well deserved star for John.
yjd2000 (MIS)
15 Jun 04 15:23
bcastner, I have a xp computer that the server service is not in the list of services. Tried reinstalling the microsoft client, no luck. Any suggestions.
bcastner (IS/IT--Management)
15 Jun 04 15:30
Start, Run, sc queryex rasman

What does it say?
jrbarnett (Programmer)
15 Jun 04 16:20
The Server service is "File and Printer sharing for Microsoft Networks" network component accessed from that same network properties dialogue box.

John
yjd2000 (MIS)
16 Jun 04 10:37
when I type sc queryex rasman it responses with
SERVICE_NAME: rasman
        TYPE              : 20 WIN32_SHARE_PROCESS
        STATE             : 4 RUNNING      
                   <STOPPABLE,NOT_PAUSABLE,IGNORES_SHUTDOWN>
       WIN32_EXIT_CODE    : 0  <0x0>
       SERVICE_EXIT_CODE  : 0  <0x0>
       CHECKPOINT         : 0x0
       WAIT_HINT          : 0x0
       PID                : 664
       FLAGS              :
bcastner (IS/IT--Management)
16 Jun 04 13:16
Now do an sc queryex server
yjd2000 (MIS)
16 Jun 04 14:44
typing sc queryex server I receive

[sc] enumquery servicesstatus: open service failed 1060:
The specified service does not exist as an installed service
bcastner (IS/IT--Management)
16 Jun 04 15:16
Start, Run, C:\WINDOWS\System32\svchost.exe -k netsvcs

Now look in Administrative Tools, Event Viewer, to see if any error messages appear for the lanmanserver service.
yjd2000 (MIS)
16 Jun 04 15:56
I found some error messages the source was, service control
manager, the error was "The computer browsers service depends on the following non existent service LanmanServer"
bcastner (IS/IT--Management)
16 Jun 04 16:04
Hmmm.


Export the registry key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer

from a machine where the server service is running as it should, to a registry file with the name Lanmansvr.reg

Then, on a computer with no server service installed, run the following two command lines from e.g. a batch file (note that the rundll32 line will wrap below, it should be one single line).


%SystemRoot%\system32\rundll32.exe setupapi.dll,InstallHinfSection Install.ndi132 %SystemRoot%\Inf\netserv.inf

regedit.exe /s "<some path>\Lanmansvr.reg"

Source: Torgeir, MVP
yjd2000 (MIS)
18 Jun 04 10:29
bcastner, Hi I typed the 2 comands in a batch file. I don't know how it affected anything rebooted and I also imported the registry key. Now I have the Server Service in the list of services but when I click on start to run the service it gives me these errors.

Configuration Manager: The specidied device instance handle does not correspond to a present device.

Could not start the server service on local computer
Error 2: The system cannot find the field specifed.

My thought do I now need to import reg key for the computer browser?

bcastner (IS/IT--Management)
18 Jun 04 11:31
1. Export HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\lanmanserver
2. right-click the exported .reg file, and select Edit
3. Click Edit, Replace
Find What:  ControlSet003
Replace With: CurrentControlSet

Replace any possible instances of ControlSet003.  Save the file as lanman.reg

4. Then do:  Start, Run, regedit /s lanman.reg

Reboot.

5. Edit your batch file (from the post above) so that it reads only:
%SystemRoot%\system32\rundll32.exe setupapi.dll,InstallHinfSection Install.ndi132

%SystemRoot%\Inf\netserv.inf

6. Run the batch file.

7. Reboot.  Examine your Network connection settings to make sure that File and

Printer sharing, and Client for Microsoft networking are both checked.

8. Check the status of the server service now in Admin Tools, Services.

yjd2000 (MIS)
21 Jun 04 10:17
bcastner, It works thank you so much for all your help.
bcastner (IS/IT--Management)
21 Jun 04 10:20
You are very welcome.

Best,
Bill Castner

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close