Member Login

Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Annoying sound in emacs

Annoying sound in emacs

Maybe this isn't the place to post this, but I could find no other emacs forum. Every time I cancel a command (C-g) or do something which has no efect, like pressing down when I am at the end of the file, emacs warns me hrough an annoying sound from the computer's internal speaker. Surely you know it: *peep*. Now, I want to work in quiet so please tell me if there is any way to deactivate this from inside emacs.

Life is a bad joke -- don't take it serious...

RE: Annoying sound in emacs

I found this with "M-x apropos" and "beep"


set-message-beep is a built-in function.

Set the sound generated when the bell is rung.
SOUND is 'asterisk, 'exclamation, 'hand, 'question, 'ok, or 'silent to use the corresponding system sound for the bell.  The 'silent sound prevents Emacs from making any sound at all.
SOUND is nil to use the normal beep.

(set-message-beep SOUND)
If you put (set-message-beep 'silent) in your .emacs file, it keeps Emacs from beeping.  This wasn't an issue for me since I always keep my speaker muted anyway, but I tried it with speaker unmuted and it does seem to work.

RE: Annoying sound in emacs

Thanks. You've been of great help. However, I've one more question: how *do* you mute your speaker? I know this is slightly off-topic, but sice you mentioned it, I thought it would be ok.

Life is a bad joke -- don't take it serious...

RE: Annoying sound in emacs

If you're using Windows, Start->Control Panel->Sounds and Audio Devices.

RE: Annoying sound in emacs

The tip I use for this "beep-problem" is to set the visible-bell variable to a non-nil value.

Hope it might help you ;)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close