Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

No Script Engine For File Extension VBS

jerjim (Programmer) (OP)
7 May 01 9:01
When I double-click on a .vbs script file to execute it,
I get the error message "There is no script engine for file extension VBS".
Thus I cannot execute VBS files.

But I have no problem executing JS files.

Can anyone help me on this?

Klae (Programmer)
7 May 01 18:49
try this...

Install a New Scripting Engine
Go to http://www.microsoft.com/msdownload/vbscript/scripting.asp


Click "x86" (located to the right of US English).


Click STE51en.exe (located at the bottom of the page).


Select the Save to Disk option and save the file to the default location.


Double-click the STE51en.exe icon located on your Desktop


After the installation is complete, you can remove STE51en.exe from your Desktop by right-clicking the icon and clicking Delete.


Hope it works.

Klae

You're only as good as your last answer!

jerjim (Programmer) (OP)
7 May 01 23:38
Thanks for the help Klae but
I have already installed scripten.exe
But I'll install it again just to make sure.
I'm running Windows 2000 by the way.

Let you know what happens.

Klae (Programmer)
8 May 01 18:21
OK try this..
In your file types tab (in "View|Folder Options" or "Tools|FOlder Options" in an Explorer window)

See if there is a VBScript Script file (VBS) file type if there is then make sure the parameters are as follows..


Description of type:
VBScript Script File
(If creating a new file type...)Associated Extension:.vbs
In the actions have the follow four actions and make sure the actions are identical to what I type.


Edit -
C:\WINDOWS\Notepad.exe
Open -
C:\WINDOWS\WScript.exe "%1" %*
Print -
C:\WINDOWS\Notepad.exe /p
Open With MS-DOS Prompt -
C:\WINDOWS\COMMAND\CScript.exe "%1" %*
Lastly change the icon to the blue scroll icon in C:\WINDOWS\WScript.exe.


Now you need to edit your registry.
Please ONLY change and write to your registry what I tell here in this thread.


0.5 Run "Regedit"
1. locate "vbsfile" key(folder) under HKEY_CLASSES_ROOT.
2. Add a "ScriptEngine" key under vbsfile.
3. Click your newly created key, and double-click the (default) value and put the text "VBScript"
4. Add a "ScriptHostEncode" Key under vbsfile.
5. Click your newly created key, and double-click the (default) string value and put the text "{85131631-480C-11D2-B1F9-00C04F86C324}" in it.
6. Create a "ShellEx" Key under vbsfile
7. Create a "PropertySheetHandlers" Key under ShellEx
8. Create a "WSHProps" Key under PropertySheetHandlers
9. Click the newly created key and double-click the (default) string value and enter the text "{60254CA5-953B-11CF-8C96-00AA00B8708C}"
10. Exit regedit and test out a VBS file.

Complicated registry stuff there. Please read it through and ask yourself if you can do this confidently before you go in. Please don't mess with any settings that "seem interesting".

Good luck..

Klae

You're only as good as your last answer!

jerjim (Programmer) (OP)
13 May 01 22:06
Dear Klae:

Problem Solved. And thanks a million, billion, trillion for taking the time to help me out.
When I ran RegEdit, the parameters were already set as you had described so, the problem was really in the Tools|Folder Options, File Types Tab.
VBS Files were associated with the Xing Mpeg Player.
I tried to change the parameters but it still wouldn't work.
Finally, I deleted the VBS file extension from File Types, created a new VBS File extension and in the description associated it with VBScript Script File. Bwala!!! everything worked.

Problem now is when i click on an mpeg or mpg file, Windows Scripting Host is executed.
So back to File Types Tab to edit the Mpeg, Mpg extensions.  HA HA HA.

I guess the problem was caused by the Xing Mpeg Player installation program.

Again thanks a million, billion, trillion.
    

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close