Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

dragonturtle (Programmer) (OP)
6 Jan 04 15:25
Hello,

I don't know what's going on. I had some reports being passed parameters via ASP running on RAS 9.0 just fine for a couple of months. Out of the blue yesterday, the reports no longer open. Instead, I get this error:



This field name is not known. Error in File C:\WINNT\{81311666-34A4-446E-AE34-B33FD83C6140}.rpt: Error in formula . '{table1.column1}=4' This field name is not known.

webReporting.dll error '80041019'

This field name is not known. Error in File C:\WINNT\{81311666-34A4-446E-AE34-B33FD83C6140}.rpt: Error in formula <Record_Selection>. '{table1.column1}=4' This field name is not known.

/CrystalReportsInteractiveViewer.asp, line 38


I've made NO changes to the reports or the scripts for a month. The web server is not local, but the server admin wouldn't have done anything without telling me. I don't know where to begin looking. All the processes are running.

Any ideas?
Turkbear (TechnicalUser)
6 Jan 04 16:06
Hi,
It appears that some change was made that affects the datasource for the report, such that the field names are not there...No knowing what database you are using makes it impossible to suggest what may have changed, but it could be a change in the ODBC DSNs on the IIS box, or something else at the database level.



dragonturtle (Programmer) (OP)
6 Jan 04 16:37
Hi,

I've checked the dates on the reports and scripts, and they were last modified in November. I've even restored backup copies, but no deal.

I thought it was the database too, but other ASP pages that use the very same tables work fine. The only changes to the database is data input, and there hasn't been much of that due to Xmas vacation.

I hate my job. :(
Turkbear (TechnicalUser)
6 Jan 04 16:56
Hi,
Just to confirm, the other asp pages that work are on the same IIS box, use the same connection info and connect to the same database and table?

Try opening one of the troublesome reports in CR Pro and select 'Verify Database' from the Database menu...

Does it have any problems with that field name?

dragonturtle (Programmer) (OP)
6 Jan 04 17:14
Hi Turkbear,

the database is up-to-date. Note that I developed the reports using Access and dynamically change the datasource to MS SQL on the web server.

In any case, it's definitely not the database. I've gone and looked at every table. There's only 3 tables in most of the reports, not complicated at all. Nothing has changed.

Unfortunately, I have no accesst to the web server, otherwise I'd just reinstall the thing.
dragonturtle (Programmer) (OP)
8 Jan 04 13:21
For future reference, if anyone else has this problem, a simple restart of the web server got the reports running again.

I don't know why that worked. Arranging for a restart of a remote server is not easy. I'm both thrilled and frustrated right now... strange feeling.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close